Permalink
Commits on Jan 10, 2017
  1. Don't set CONTENT_TYPE / CONTENT_LENGTH if they're not provided by th…

    …e client (#1056)
    
    * Don't set CONTENT_TYPE / CONTENT_LENGTH if they're not provided by the client
    
    * Add change log
    
    * Add tests
    wong2 committed with untitaker Jan 10, 2017
Commits on Dec 31, 2016
  1. Add empty line in docstring of BaseCache.clear() (#839)

    Tags should be clearly separated from the method's summary,
    otherwise they may not be parsed correctly:
    http://werkzeug.pocoo.org/docs/0.11/contrib/cache/#werkzeug.contrib.cache.BaseCache.clear
    ricordisamoa committed with untitaker Dec 31, 2016
Commits on Dec 30, 2016
  1. Bump dev version

    untitaker committed Dec 30, 2016
  2. Version 0.11.15

    untitaker committed Dec 30, 2016
  3. Expand Request docs from Flask (#1057)

    untitaker committed on GitHub Dec 30, 2016
  4. Bump to dev version

    untitaker committed Dec 30, 2016
  5. Version 0.11.14

    untitaker committed Dec 30, 2016
  6. Fix travis

    untitaker committed Dec 30, 2016
  7. Test under Python 3.6

    untitaker committed Dec 30, 2016
  8. Raise exception on platforms that can't fork

    Raise a ValueError when trying to initialize ForkingWSGIServer on
    platforms that don't support forking, also create a ForkingMixIn stub
    on those platforms.
    Noctem committed with untitaker Dec 30, 2016
  9. Avoid errors on systems that cannot fork

    Check if OS can fork before importing ForkingMixIn since Python 3.6
    will no longer define that when it is not available on the operating
    system.
    Noctem committed with untitaker Aug 28, 2016
Commits on Dec 29, 2016
Commits on Dec 26, 2016
  1. 0.11.13

    mitsuhiko committed Dec 26, 2016
  2. Correct fix for reloader issue

    mitsuhiko committed Dec 26, 2016
  3. 0.11.12

    mitsuhiko committed Dec 26, 2016
Commits on Dec 10, 2016
  1. Added changelog entry

    mitsuhiko committed Dec 10, 2016
Commits on Nov 15, 2016
  1. Closes #1012: Fixed IPython 5.x shell support (#1033)

    * `global_ns` was deprecated in IPython 4.x, and was removed in IPython 5.x.
    * According to the discussion in ipython/ipython#9798, `InteractiveShellEmbed.instance` should be used over `InteractiveShellEmbed` as it sets the shell as a default one automatically
    frol committed with untitaker Nov 15, 2016
  2. Ignore new Flake8 error

    untitaker committed Nov 15, 2016
Commits on Nov 11, 2016
  1. Changelog for #1031

    untitaker committed Nov 11, 2016