Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

port to Debian #220

Closed
Z-Y00 opened this issue Oct 13, 2017 · 2 comments
Closed

port to Debian #220

Z-Y00 opened this issue Oct 13, 2017 · 2 comments

Comments

@Z-Y00
Copy link

@Z-Y00 Z-Y00 commented Oct 13, 2017

Hi ,
I'm wondering if you can upgrade the llvm dependence. since the older version of llvm(3.x)will be removed from Debian.
#107 (comment)
if it is impossible, can you fork the needed llvm to panda.
because if Debian is to remove old llvm, after some while Ubuntu is going to follow up.

@moyix

This comment has been minimized.

Copy link
Collaborator

@moyix moyix commented Oct 14, 2017

Unfortunately we can't migrate past LLVM 3.3 – they removed functionality we depend on (specifically the JIT compiler). We have an Ubuntu PPA that includes the LLVM 3.3, and that may work for you on Debian as well (it's also not too hard to build LLVM 3.3 from source; see the details in the compile doc).

@moyix moyix closed this Oct 28, 2017
@Z-Y00

This comment has been minimized.

Copy link
Author

@Z-Y00 Z-Y00 commented Oct 28, 2017

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
Linked pull requests

Successfully merging a pull request may close this issue.

None yet
2 participants
You can’t perform that action at this time.