Skip to content
Newer
Older
100644 155 lines (127 sloc) 3.99 KB
b7eb7d0 Rails3: Gemfile: use Rails 3.0.9 (#4796)
Toshi MARUYAMA authored Jun 17, 2011
1 # source 'http://rubygems.org'
ce2637d bundler: use bundler (#5638)
Toshi MARUYAMA authored Jun 13, 2011
2 source :rubygems
3 source :rubyforge
4 source :gemcutter
5
b7eb7d0 Rails3: Gemfile: use Rails 3.0.9 (#4796)
Toshi MARUYAMA authored Jun 17, 2011
6 # gem 'bundler', '~> 1.0.0'
d3666ec Rails3.1: Gemfile: update Rails 3.1.1
Toshi MARUYAMA authored Aug 22, 2011
7 gem 'rails', '3.1.1'
b7eb7d0 Rails3: Gemfile: use Rails 3.0.9 (#4796)
Toshi MARUYAMA authored Jun 17, 2011
8
e2fd5f2 Rails3: Gemfile: add dynamic_form
Toshi MARUYAMA authored Sep 13, 2011
9 gem 'dynamic_form'
10
b7eb7d0 Rails3: Gemfile: use Rails 3.0.9 (#4796)
Toshi MARUYAMA authored Jun 17, 2011
11 # gem 'rubytree', '0.5.2', :require => 'tree'
12 gem 'rubytree', '0.7.0'
13 # gem 'rack' , '~> 1.1.1'
14 # gem 'i18n', '>= 0.4.2'
ce2637d bundler: use bundler (#5638)
Toshi MARUYAMA authored Jun 13, 2011
15 # gem 'coderay', '~> 0.9.7'
16 gem 'coderay'
17
6003916 Gemfile: add fastercsv (#5638)
Toshi MARUYAMA authored Aug 24, 2011
18 gem "fastercsv", "~> 1.5.0", :platforms => [:mri_18, :jruby, :mingw_18]
19
b7eb7d0 Rails3: Gemfile: use Rails 3.0.9 (#4796)
Toshi MARUYAMA authored Jun 17, 2011
20 # gem 'ruby-prof', :git => 'http://github.com/wycats/ruby-prof.git'
21 gem 'ruby-prof'
22 # gem 'jquery-rails'
23 # gem 'prototype-rails'
1b4e7e1 Rails3.1: Gemfile: add prototype-rails
Toshi MARUYAMA authored Sep 13, 2011
24 # gem 'prototype-rails', :git => "https://github.com/rails/prototype-rails.git"
25 gem 'prototype-rails'
b7eb7d0 Rails3: Gemfile: use Rails 3.0.9 (#4796)
Toshi MARUYAMA authored Jun 17, 2011
26
f0bcecd Rails3.1: Gemfile: add therubyracer
Toshi MARUYAMA authored Sep 13, 2011
27 gem 'therubyracer', :platforms => [:mri_18, :mri_19]
28
4900fb1 Rails3.1: Gemfile: add group :assets
Toshi MARUYAMA authored Sep 13, 2011
29 # Gems used only for assets and not required
30 # in production environments by default.
31 group :assets do
32 # gem 'sass-rails', " ~> 3.1.1"
33 # gem 'coffee-rails', "~> 3.1.1"
34 gem 'sass-rails'
35 gem 'coffee-rails'
36 gem 'uglifier'
37 end
38
22de040 @thegcat Rails3: Gemfile: replace vendored awesome_nested_set with the gem
thegcat authored Sep 3, 2011
39 # TODO rails-3.1: review the core changes to awesome_nested_set and decide on actions
40 gem 'awesome_nested_set'
ab390c1 Rails3: Gemfile: comment out open_id_authentication
Toshi MARUYAMA authored Oct 10, 2011
41 ## TODO rails-3.1: review the core changes to open_id_authentication and decide on actions
42 # gem 'open_id_authentication'
22de040 @thegcat Rails3: Gemfile: replace vendored awesome_nested_set with the gem
thegcat authored Sep 3, 2011
43
2796282 @paneidos Swap out the ruby-net-ldap-0.0.4 plugin for the net-ldap gem. This fi…
authored Oct 25, 2011
44 gem 'net-ldap'
45
194b990 @redox Rails3: Gemfile: restore auto_link
redox authored Sep 29, 2011
46 gem 'rails_autolink'
3acb116 Rails3: Gemfile: add rails_legacy_mapper
Toshi MARUYAMA authored Oct 2, 2011
47 gem 'rails_legacy_mapper'
194b990 @redox Rails3: Gemfile: restore auto_link
redox authored Sep 29, 2011
48
ce2637d bundler: use bundler (#5638)
Toshi MARUYAMA authored Jun 13, 2011
49 group :development do
bfa3d23 @redox Gemfile: add rails-dev-tweaks
redox authored Oct 1, 2011
50 # gem 'thin'
51 # gem 'autotest'
52 # gem 'autotest-growl'
53 # gem 'autotest-fsevent'
54 # gem 'mynyml-redgreen'
55 gem 'rails-dev-tweaks', '~> 0.5.1'
ce2637d bundler: use bundler (#5638)
Toshi MARUYAMA authored Jun 13, 2011
56 end
57
58 group :production do
59 end
60
61 group :test do
b7eb7d0 Rails3: Gemfile: use Rails 3.0.9 (#4796)
Toshi MARUYAMA authored Jun 17, 2011
62 gem 'test-unit'
3042e27 Rails3: Gemfile: remove shoulda version
Toshi MARUYAMA authored Jun 23, 2011
63 # gem 'shoulda', '~> 2.10.3'
bfa3d23 @redox Gemfile: add rails-dev-tweaks
redox authored Oct 1, 2011
64 # gem 'shoulda', :git => 'http://github.com/redox/shoulda', :branch => 'rails3'
3042e27 Rails3: Gemfile: remove shoulda version
Toshi MARUYAMA authored Jun 23, 2011
65 gem 'shoulda'
ce2637d bundler: use bundler (#5638)
Toshi MARUYAMA authored Jun 13, 2011
66 gem 'mocha'
d93af9d Rails3: Gemfile: remove 'edavis10-object_daddy'
Toshi MARUYAMA authored Sep 25, 2011
67 ## ruby script/rails plugin install git://github.com/awebneck/object_daddy.git
68 # gem 'edavis10-object_daddy', :require => 'object_daddy'
69 # gem 'object_daddy', :git => 'https://github.com/awebneck/object_daddy.git'
df23e9f @meineerde Gemfile: add ruby-debug as test dependency to debug failing tests (#5…
meineerde authored Jul 25, 2011
70
71 # cannot install on mingw due to fail installing linecache with native extensions
72 platforms :mri_18 do gem 'ruby-debug' end
73 platforms :mri_19 do gem 'ruby-debug19', :require => 'ruby-debug' end
ce2637d bundler: use bundler (#5638)
Toshi MARUYAMA authored Jun 13, 2011
74 end
75
762a497 @schmidt Gemfile: making openid opt-out by adding it to a group (#5638)
schmidt authored Mar 19, 2011
76 group :openid do
77 gem "ruby-openid", '~> 2.1.4', :require => 'openid'
78 end
77db699 @schmidt bundler: update bundler files (#5638)
schmidt authored Mar 18, 2011
79
d12ba0a @schmidt Gemfile: add rmagick, making it opt-out (#5638)
schmidt authored Mar 19, 2011
80 group :rmagick do
e8d38f4 Gemfile: use rmagick on only Linux Ruby 1.8 (mri_18) (#5638)
Toshi MARUYAMA authored Aug 28, 2011
81 platforms :mri_18 do gem "rmagick", "~> 1.15.17" end
82 ## You cannot specify the same gem twice with different version requirements.
83 ## You specified: rmagick (~> 1.15.17) and rmagick (>= 0)
84 ## https://github.com/carlhuda/bundler/issues/751
85 # platforms :mri_19 do gem "rmagick" end
d12ba0a @schmidt Gemfile: add rmagick, making it opt-out (#5638)
schmidt authored Mar 19, 2011
86 end
87
77db699 @schmidt bundler: update bundler files (#5638)
schmidt authored Mar 18, 2011
88 # Use the commented pure ruby gems, if you have not the needed prerequisites on
89 # board to compile the native ones. Note, that their use is discouraged, since
90 # their integration is propbably not that well tested and their are slower in
91 # orders of magnitude compared to their native counterparts. You have been
92 # warned.
93 #
bbec33c Gemfile: add database gems for mingw (Ruby on Windows) (#5638)
Toshi MARUYAMA authored Oct 18, 2011
94 platforms :mri, :mingw do
77db699 @schmidt bundler: update bundler files (#5638)
schmidt authored Mar 18, 2011
95 group :mysql do
96 gem "mysql"
97 # gem "ruby-mysql"
98 end
99
100 group :postgres do
101 gem "pg", "~> 0.9.0"
102 # gem "postgres-pr"
103 end
6319e96 @edavis10 Gemfile: fix string encodings coming from sqlite3 in MRI 1.9.x (#5638)
edavis10 authored Jul 22, 2011
104 end
77db699 @schmidt bundler: update bundler files (#5638)
schmidt authored Mar 18, 2011
105
bbec33c Gemfile: add database gems for mingw (Ruby on Windows) (#5638)
Toshi MARUYAMA authored Oct 18, 2011
106 platforms :mri_18, :mingw_18 do
77db699 @schmidt bundler: update bundler files (#5638)
schmidt authored Mar 18, 2011
107 group :sqlite do
e052824 Rails3.1: Gemfile: use sqlite3 1.3 on Ruby 1.8 (mri_18).
Toshi MARUYAMA authored Aug 22, 2011
108 # gem "sqlite3-ruby", "< 1.3", :require => "sqlite3"
109 gem "sqlite3"
6319e96 @edavis10 Gemfile: fix string encodings coming from sqlite3 in MRI 1.9.x (#5638)
edavis10 authored Jul 22, 2011
110 end
111 end
112
113 platforms :mri_19 do
bbec33c Gemfile: add database gems for mingw (Ruby on Windows) (#5638)
Toshi MARUYAMA authored Oct 18, 2011
114 ## Add Windows support
115 ## https://github.com/brianmario/mysql2/issues/8
116 ## Getting mysql2 gem to work with Ruby on Rails 3.0 and Windows 7 64bit
117 ## http://paul-wong-jr.blogspot.com/2011/06/getting-mysql2-gem-to-work-with-ruby-on.html
118 group :mysql2 do
43c43e1 @paneidos Update mysql2 for Rails 3.1
authored Oct 27, 2011
119 gem "mysql2"
bbec33c Gemfile: add database gems for mingw (Ruby on Windows) (#5638)
Toshi MARUYAMA authored Oct 18, 2011
120 end
121
6319e96 @edavis10 Gemfile: fix string encodings coming from sqlite3 in MRI 1.9.x (#5638)
edavis10 authored Jul 22, 2011
122 group :sqlite do
123 gem "sqlite3"
77db699 @schmidt bundler: update bundler files (#5638)
schmidt authored Mar 18, 2011
124 end
125 end
126
127 platforms :jruby do
128 gem "jruby-openssl"
129
130 group :mysql do
131 gem "activerecord-jdbcmysql-adapter"
132 end
133
134 group :postgres do
135 gem "activerecord-jdbcpostgresql-adapter"
136 end
137
138 group :sqlite do
139 gem "activerecord-jdbcsqlite3-adapter"
140 end
141 end
142
56d47cd @edavis10 Gemfile: read Gemfile.local for local gem inclusions (#5638)
edavis10 authored Jul 22, 2011
143 # Load a "local" Gemfile
144 gemfile_local = File.join(File.dirname(__FILE__), "Gemfile.local")
145 if File.readable?(gemfile_local)
146 puts "Loading #{gemfile_local} ..." if $DEBUG
147 instance_eval(File.read(gemfile_local))
148 end
149
ce2637d bundler: use bundler (#5638)
Toshi MARUYAMA authored Jun 13, 2011
150 # Load plugins Gemfiles
151 Dir.glob(File.join(File.dirname(__FILE__), %w(vendor plugins * Gemfile))) do |file|
79ce566 @edavis10 Gemfile: only print the plugin Gemfile messages when $DEBUG is set (#…
edavis10 authored May 13, 2011
152 puts "Loading #{file} ..." if $DEBUG # `ruby -d` or `bundle -v`
ce2637d bundler: use bundler (#5638)
Toshi MARUYAMA authored Jun 13, 2011
153 instance_eval File.read(file)
154 end
Something went wrong with that request. Please try again.