Permalink
Browse files

Require JRuby 1.7.

  • Loading branch information...
pangloss committed Aug 24, 2012
1 parent d1033e1 commit fc7b165e37666809114a952d34cc0165b26276f1
Showing with 11 additions and 2 deletions.
  1. +8 −0 README.md
  2. +3 −2 lib/pacer.rb
View
@@ -31,6 +31,14 @@ If you like, you can also use the documentation locally via
gem install yard
yard server
+## JRuby 1.7 Required
+
+As of Pacer 1.0.0, [JRuby](http://jruby.org/) 1.7 is required because it is both faster and
+fixes some problems that I previously had to work around in Pacer.
+
+The easiest way (ie. the way I do it) to get the most recent version of
+JRuby is to use [RVM](https://rvm.io/)
+
## Installation
The easiest way to get Pacer is `gem install pacer`.
View
@@ -1,11 +1,11 @@
-if not defined?(JRUBY_VERSION) or JRUBY_VERSION =~ /^(0|1\.[0-5]|1\.6\.[0-3])/
+if not defined?(JRUBY_VERSION) or JRUBY_VERSION =~ /^(0|1\.[0-6])/
# NOTE: This is because JRuby 1.6.4 fixes a bug that made it impossible to
# instantiate Java classes with a varargs constructor signature with 0
# arguments. Marko would not accept a patch to create a 0 args constructor to
# work around the problem, therefore this version of Pacer will not work
# under any older versions of JRuby. The oldest Pacer version that will work
# is 0.8.1.
- raise Exception, 'Pacer >= 0.8.2 requires JRuby version 1.6.4 or higher. It is strongly recommended that you use the latest JRuby release.'
+ raise Exception, 'Pacer >= 1.0.0 requires JRuby version 1.7.0 preview or higher. It is strongly recommended that you use the latest JRuby release.'
end
if RUBY_VERSION == '1.8.7'
@@ -15,6 +15,7 @@
defaulting to 1.9 mode by setting the environment variable
JRUBY_OPTS=--1.9
WARNING
+ raise Exception, "Pacer must be run in JRuby 1.9 mode"
end
require 'java'

0 comments on commit fc7b165

Please sign in to comment.