New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Upgrade virtualenv. #5679

Merged
merged 1 commit into from Apr 9, 2018

Conversation

Projects
None yet
4 participants
@jsirois
Copy link
Member

jsirois commented Apr 9, 2018

This is a good thing in its own right, more modern pip, setuptools,
wheel for bootstrapping pants and running release steps, but its also a
naive attempt to fix pip install errors on OSX in ci.

Release notes here: https://pypi.python.org/pypi/virtualenv/15.2.0

Upgrade virtualenv.
This is a good thing in its own right, more modern pip, setuptools,
wheel for bootstrapping pants and running release steps, but its also a
naive attempt to fix pip install errors on OSX in ci.

Release notes here: https://pypi.python.org/pypi/virtualenv/15.2.0
@jsirois

This comment has been minimized.

Copy link
Member

jsirois commented Apr 9, 2018

We've all been seeing a high incidence of errors like so on the OSX CI shard:

[=== 04:02 Building 3rdparty whls from 3rdparty/python/requirements.txt 3rdparty/python/twitter/commons/requirements.txt ===]
Using python at /usr/bin/python2.7
Downloading https://pypi.io/packages/source/v/virtualenv/virtualenv-15.1.0.tar.gz...
######################################################################## 100.0%
New python executable in /var/folders/vy/rcv48w3j4w79llzf_x6qnvw40000gn/T/pants.XXXXX.VFmoTzOI/bin/python
Installing setuptools, pip, wheel...done.
Collecting ansicolors==1.0.2 (from -r /Users/travis/build/pantsbuild/pants/3rdparty/python/requirements.txt (line 1))
  Could not find a version that satisfies the requirement ansicolors==1.0.2 (from -r /Users/travis/build/pantsbuild/pants/3rdparty/python/requirements.txt (line 1)) (from versions: )
No matching distribution found for ansicolors==1.0.2 (from -r /Users/travis/build/pantsbuild/pants/3rdparty/python/requirements.txt (line 1))

@jsirois jsirois requested a review from kwlzn Apr 9, 2018

@kwlzn

kwlzn approved these changes Apr 9, 2018

@stuhood

This comment has been minimized.

Copy link
Member

stuhood commented Apr 9, 2018

Thanks for looking at this John... I punted all of last week, and felt pretty awful about it.

@jsirois jsirois merged commit 8b74d55 into pantsbuild:master Apr 9, 2018

1 check passed

continuous-integration/travis-ci/pr The Travis CI build passed
Details

@jsirois jsirois deleted the jsirois:virtualenv/upgrade branch Apr 9, 2018

stuhood added a commit that referenced this pull request Apr 10, 2018

Upgrade virtualenv. (#5679)
This is a good thing in its own right, more modern pip, setuptools,
wheel for bootstrapping pants and running release steps, but its also a
naive attempt to fix pip install errors on OSX in ci.

Release notes here: https://pypi.python.org/pypi/virtualenv/15.2.0

wisechengyi added a commit that referenced this pull request Apr 19, 2018

Upgrade virtualenv. (#5679)
This is a good thing in its own right, more modern pip, setuptools,
wheel for bootstrapping pants and running release steps, but its also a
naive attempt to fix pip install errors on OSX in ci.

Release notes here: https://pypi.python.org/pypi/virtualenv/15.2.0
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment