New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Bump Scala versions #5738

Merged
merged 1 commit into from Apr 24, 2018

Conversation

Projects
None yet
3 participants
@BardurArantsson
Copy link
Contributor

BardurArantsson commented Apr 23, 2018

Problem

The default scala build toolchain is out-of-date and insecure(!). See https://nvd.nist.gov/vuln/detail/CVE-2017-15288 for details.

Solution

Bumped version numbers.

Use Scala 2.12.4 for --scala-platform-version=2.12
(I have *not* updated to 2.12.5 due to the potential severity of a
macro-handling bug in 2.12.5 when running on JVM >= 9.)

@BardurArantsson BardurArantsson force-pushed the ClockworkConsulting:scala-bumps branch from c7b09e0 to 5b7939f Apr 24, 2018

@BardurArantsson

This comment has been minimized.

Copy link
Contributor

BardurArantsson commented Apr 24, 2018

Hm, the failures look spurious to me. (One is a resolution failure and the other is "took too long".)

@stuhood stuhood merged commit c8d7b3f into pantsbuild:master Apr 24, 2018

1 check passed

continuous-integration/travis-ci/pr The Travis CI build passed
Details
@stuhood

This comment has been minimized.

Copy link
Member

stuhood commented Apr 24, 2018

Thanks! Please let me know if you need this cherry-picked to a stable release; otherwise, the 1.7.x release should be coming up in the next few weeks.

@BardurArantsson

This comment has been minimized.

Copy link
Contributor

BardurArantsson commented Apr 25, 2018

Thanks -- I think we can manage without having it in a stable release. I'll have to muck about with custom versions regardless :).

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment