New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Upgrade to pex 1.5.1; ~kill --resolver-blacklist. #6619

Merged
merged 4 commits into from Oct 11, 2018

Conversation

Projects
None yet
2 participants
@jsirois
Copy link
Member

jsirois commented Oct 11, 2018

PEX now handles blacklisting for us by respecting PEP-508 enviornment
markers.

Fixes #5696

jsirois added some commits Oct 9, 2018

Upgrade to pex 1.5.1; ~kill --resolver-blacklist.
PEX now handles blacklisting for us by respecting PEP-508 enviornment
markers.

Fixes #5696

@jsirois jsirois requested review from CMLivingston , stuhood and Eric-Arellano Oct 11, 2018

@Eric-Arellano
Copy link
Contributor

Eric-Arellano left a comment

Very cool change!

I remember how much confusion we had at Foursquare figuring out how to setup a blacklist, until you all in Slack mentioned this option. So, this consolidation with standard Python conventions is great to see.

cc @mateor - no need to review, but so you're aware of this change when Foursquare upgrades Pants again.

@jsirois jsirois merged commit eb59efd into pantsbuild:master Oct 11, 2018

1 check passed

continuous-integration/travis-ci/pr The Travis CI build passed
Details

@jsirois jsirois deleted the jsirois:issues/5696 branch Oct 11, 2018

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment