New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Pin a floating conan dep #6825

Merged
merged 1 commit into from Nov 28, 2018

Conversation

Projects
None yet
3 participants
@stuhood
Copy link
Member

stuhood commented Nov 28, 2018

Problem

Master is currently failing to translate typed_ast on python 2, with:

**** Failed to install typed-ast-1.1.0 (caused by: NonZeroExit("received exit code 1 during execution of `['/home/travis/build/pantsbuild/pants/build-support/pants_dev_deps.venv/bin/python2.7', '-', 'bdist_wheel', '--dist-dir=/tmp/tmpJy273C']` while trying to execute `['/home/travis/build/pantsbuild/pants/build-support/pants_dev_deps.venv/bin/python2.7', '-', 'bdist_wheel', '--dist-dir=/tmp/tmpJy273C']`",)
 ):
 stdout:
 
 stderr:
 Error: typed_ast only runs on Python 3.3 and above.

Solution

Pin a conan dep that was floating to a version that was not compatible with py2.

Result

Broken tests are fixed.

@stuhood stuhood requested review from jsirois , CMLivingston and Eric-Arellano Nov 28, 2018

@stuhood

This comment has been minimized.

Copy link
Member

stuhood commented Nov 28, 2018

From my experiments, it looks like creating virtualenvs and using pip with py2 and py3 result in interpreter constraints being applied to downloaded packages such that pylint==1.9.3 is installed under py2, while pylint==2.2.1 is installed under py3. So it's possible that either 1) pex does not apply those same constraints, 2) we're not giving pex enough information about the interpreter to do the right thing. So it feels like a better solution might be available.

@illicitonion illicitonion merged commit 2df869b into pantsbuild:master Nov 28, 2018

1 check passed

continuous-integration/travis-ci/pr The Travis CI build passed
Details

@illicitonion illicitonion deleted the twitter:stuhood/pin-floating-conan-dep branch Nov 28, 2018

@jsirois

This comment has been minimized.

Copy link
Member

jsirois commented Nov 28, 2018

@stuhood it's 1. I tested using pex directly specifying a python2.7 interpreter and pylint>=1.9.3. I've filed pantsbuild/pex#628

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment