Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Set internal compatibility to >= CPython 3.6 and remove ./pants2 #7925

Merged
merged 1 commit into from Jun 22, 2019

Conversation

Projects
None yet
4 participants
@Eric-Arellano
Copy link
Contributor

commented Jun 21, 2019

External code can still use Python 2, but our own code should only ever use Python 3.6+ (beyond testprojects).

@Eric-Arellano Eric-Arellano requested review from stuhood, benjyw and ity Jun 21, 2019

@benjyw

benjyw approved these changes Jun 21, 2019

Copy link
Contributor

left a comment

EPIC!

@ity

ity approved these changes Jun 21, 2019

@Eric-Arellano Eric-Arellano merged commit 62b566f into pantsbuild:master Jun 22, 2019

1 check passed

continuous-integration/travis-ci/pr The Travis CI build passed
Details

@Eric-Arellano Eric-Arellano deleted the Eric-Arellano:remove-pants2 branch Jun 22, 2019

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
You can’t perform that action at this time.