Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Upgrade cloc #8111

Merged
merged 3 commits into from Jul 27, 2019

Conversation

@gshuflin
Copy link
Contributor

commented Jul 25, 2019

cf. #8103

@stuhood
Copy link
Member

left a comment

Thanks! Will merge on green CI.

gshuflin added some commits Jul 23, 2019

Allow cloc process to raise an exception
When running the external cloc process, allow it to raise an
exception if the process fails, to provide a better error message.
(temporarily) downgrade to cloc 1.80
cf. AlDanial/cloc#401, the current latest
version of cloc, version 1.82, is broken in such a way that it breaks
pants tests. Version 1.80 doesn't have this bug, so we can upgrade to
this version for now, pending a fix upstream.

@gshuflin gshuflin force-pushed the gshuflin:upgrade_cloc branch from 169ba23 to 8f23d05 Jul 26, 2019

@stuhood stuhood merged commit a1b9eb9 into pantsbuild:master Jul 27, 2019

1 check was pending

continuous-integration/travis-ci/pr The Travis CI build is in progress
Details
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
2 participants
You can’t perform that action at this time.