Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

Already on GitHub? Sign in to your account

Extract Text not working (Windows) #8

Closed
ehud opened this Issue Sep 30, 2012 · 2 comments

Comments

Projects
None yet
2 participants

ehud commented Sep 30, 2012

Fresh installation (of 0.2.2). Any "Extract Text" fails. I tried a collection named "test" with a single item, with nothing fancy (no smart quotes in file names), and it failed too. Any suggestions?

Here is a representative log:

INFO:root:command: C:\Udi\Zotero\papermachines\processors\extract.pyw C:\Udi\Zotero\papermachines\args\ef25bcb4.json
INFO:root:starting to process
ERROR:root:Traceback (most recent call last):
File "~\Zotero\papermachines\processors\extract.pyw", line 52, in process
import_proc = subprocess.Popen(import_args, stdout = subprocess.PIPE)
File "C:\Python27\lib\subprocess.py", line 679, in init
errread, errwrite)
File "C:\Python27\lib\subprocess.py", line 896, in _execute_child
startupinfo)
WindowsError: [Error 2]

INFO:root:writing HTML

ehud commented Sep 30, 2012

The issue seems to be that pdftotext wasn't installed. Now things are moving along, but still the extraction seems to freeze from time to time. I'll reinstall and if the issues persist I will let you know.
I suggest indicating the need to make sure pdftotext is installed in the installation instructions.

Contributor

corajr commented Sep 30, 2012

I have updated the requirements to reflect this.

@corajr corajr closed this Sep 30, 2012

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment