Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP

Loading…

ImportError: No module named transport (Paramiko, Python 3.2.5) #198

Closed
Hersh500 opened this Issue · 4 comments

5 participants

Hersh Sanghvi Shahriyar Rzayev Jiehan Zheng Ian Beringer Jeff Forcier
Hersh Sanghvi

I installed PyCrypto and Paramiko (in their respective directories) with

python3 setup.py install

and both were installed successfully. However, when I try

import paramiko 

in the 3.2.5 interpreter, I get this error:

Traceback (most recent call last):
  File "<stdin>", line 1, in <module>
  File "/Library/Frameworks/Python.framework/Versions/3.2/lib/python3.2/site-packages/paramiko/__init__.py", line 64, in <module>
     from transport import SecurityOptions, Transport
ImportError: No module named transport

I checked in the folder and the transport.py module is there.

Shahriyar Rzayev

Same issue with Python 3.3.2:

import paramiko
File "/usr/local/lib/python3.3/site-packages/paramiko-1.11.0-py3.3.egg/paramiko/init.py", line 64, in
ImportError: No module named 'transport'

i find transport.py too.

Jiehan Zheng

I am also having the same problem:

Traceback (most recent call last):
  File "../run_experiments.py", line 4, in <module>
    from server_adapters.ssh import SSHRunner
  File "/Users/jiehan/Dropbox/workspace/py_experiment_manager/server_adapters/ssh.py", line 2, in <module>
    from paramiko import SSHClient
  File "/usr/local/lib/python3.3/site-packages/paramiko/__init__.py", line 64, in <module>
    from transport import SecurityOptions, Transport
ImportError: No module named 'transport'

Hope this can be fixed! Thanks!

Ian Beringer

Same for me, with Python 3.3.2:

  File "C:\Python33\lib\site-packages\paramiko\__init__.py", line 64, in <module>
    from transport import SecurityOptions, Transport
ImportError: No module named 'transport'

Relevant stackoverflow question: http://stackoverflow.com/questions/18179156/importerror-no-module-named-transport-paramiko-python-3-2-5

I would love to see this fixed!

Jeff Forcier
Owner

See #16, Paramiko is not Python 3 compatible just yet :)

Jeff Forcier bitprophet closed this
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Something went wrong with that request. Please try again.