Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Fix whitespacing in dependency version declaration #697

Closed
wants to merge 1 commit into from

Conversation

@jlec
Copy link

@jlec jlec commented Feb 26, 2016

With recent setuptools the following error occurs

error in paramiko setup command: 'install_requires' must be a string
or list of strings containing valid project/version requirement specifiers;
Invalid requirement, parse error at "'!= 2.4'"

Simply dropping the whitespace is enough to fix

Signed-off-by: Justin Lecher jlec@gentoo.org

With recent setuptools the following error occurs

error in paramiko setup command: 'install_requires' must be a string \
or list of strings containing valid project/version requirement specifiers; \
Invalid requirement, parse error at "'!= 2.4'"

Simply dropping the whitespace is enough to fix

Signed-off-by: Justin Lecher <jlec@gentoo.org>
@bitprophet
Copy link
Member

@bitprophet bitprophet commented Feb 27, 2016

Fun times. Thanks for the catch!

@bitprophet
Copy link
Member

@bitprophet bitprophet commented Feb 27, 2016

Hm, I can't recreate this on my end, even with the latest pip and its embedded setuptools (pip==8.0.3, setuptools==18.3.2) under Python 2.6.9 on OSX 10.10. Can you clarify the details for the environment you're experiencing the bug under?

@jlec
Copy link
Author

@jlec jlec commented Feb 27, 2016

@bitprophet Actually this is/was a regression in setuptools-20.2.1.

@bitprophet
Copy link
Member

@bitprophet bitprophet commented Feb 28, 2016

Do you mean in the sense that setuptools-20.2.1 can't install Paramiko period, even with this PR in place, or were you just clarifying the setuptools version triggering the bug?

I actually grabbed setuptools 20.2.1 from their source repo (they removed it from PyPI) and I can't get paramiko to install under it at all, even with all the whitespace removed from the install_requires. The error I get is different from yours, though - it's possible my baseline of Python 2.6 is triggering other problems or something:

Obtaining file:///Users/jforcier/Code/oss/paramiko
    Complete output from command python setup.py egg_info:
    /System/Library/Frameworks/Python.framework/Versions/2.6/lib/python2.6/distutils/dist.py:266: UserWarning: Unknown distribution option: 'install_require
s'
      warnings.warn(msg)
    usage: -c [global_opts] cmd1 [cmd1_opts] [cmd2 [cmd2_opts] ...]
       or: -c --help [cmd1 cmd2 ...]
       or: -c --help-commands
       or: -c cmd --help

    error: invalid command 'egg_info'

Under setuptools 20.2.2, installation works fine, whitespace or no whitespace.

Barring more info I'm tempted to just remove all whitespace in those lines, just to be safe. Doing so presents no problems to my older setuptools (18.x).

bitprophet added a commit that referenced this pull request Feb 28, 2016
@bitprophet
Copy link
Member

@bitprophet bitprophet commented Feb 28, 2016

Did that, backported to 1.13.x and then upwards to master. Feel free to reopen if I goofed somehow. Thanks again!

@jlec
Copy link
Author

@jlec jlec commented Feb 28, 2016

Do you mean in the sense that setuptools-20.2.1 can't install Paramiko period, even with this PR in place, or were you just clarifying the setuptools version triggering the bug?

With the PR everything is fine. But the old behaviour has been reinstalled with setuptools-20.2.2

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
Linked issues

Successfully merging this pull request may close these issues.

None yet

2 participants