Permalink
Browse files

Ruby 2.3 Compatibility

  • Loading branch information...
1 parent e194816 commit 1598b568e351dc159051df48ccd6163511846b39 @distler distler committed Jan 5, 2016
Showing with 3,414 additions and 2,061 deletions.
  1. +1 −1 Gemfile
  2. +10 −5 bundle
  3. +1 −1 test/functional/wiki_controller_test.rb
  4. +3 −3 test/unit/page_renderer_test.rb
  5. BIN vendor/plugins/bundler/cache/bundler-1.10.4.gem
  6. BIN vendor/plugins/bundler/cache/bundler-1.11.2.gem
  7. +0 −21 vendor/plugins/bundler/gems/bundler-1.10.4/bin/bundle
  8. +0 −21 vendor/plugins/bundler/gems/bundler-1.10.4/bin/bundler
  9. +0 −32 vendor/plugins/bundler/gems/bundler-1.10.4/bundler.gemspec
  10. +0 −87 vendor/plugins/bundler/gems/bundler-1.10.4/lib/bundler/cli/config.rb
  11. +0 −43 vendor/plugins/bundler/gems/bundler-1.10.4/lib/bundler/dep_proxy.rb
  12. +0 −27 vendor/plugins/bundler/gems/bundler-1.10.4/lib/bundler/fetcher/base.rb
  13. +0 −26 vendor/plugins/bundler/gems/bundler-1.10.4/lib/bundler/gem_helpers.rb
  14. +0 −2 vendor/plugins/bundler/gems/bundler-1.10.4/lib/bundler/gem_tasks.rb
  15. +0 −13 vendor/plugins/bundler/gems/bundler-1.10.4/lib/bundler/match_platform.rb
  16. +0 −13 vendor/plugins/bundler/gems/bundler-1.10.4/lib/bundler/templates/newgem/CODE_OF_CONDUCT.md.tt
  17. +0 −7 vendor/plugins/bundler/gems/bundler-1.10.4/lib/bundler/ui.rb
  18. +0 −2 vendor/plugins/bundler/gems/bundler-1.10.4/lib/bundler/vendored_molinillo.rb
  19. +0 −3 vendor/plugins/bundler/gems/bundler-1.10.4/lib/bundler/vendored_thor.rb
  20. 0 vendor/plugins/bundler/gems/{bundler-1.10.4 → bundler-1.11.2}/.gitignore
  21. 0 vendor/plugins/bundler/gems/{bundler-1.10.4 → bundler-1.11.2}/.rspec
  22. +105 −0 vendor/plugins/bundler/gems/bundler-1.11.2/.rubocop.yml
  23. +120 −0 vendor/plugins/bundler/gems/bundler-1.11.2/.rubocop_todo.yml
  24. +8 −24 vendor/plugins/bundler/gems/{bundler-1.10.4 → bundler-1.11.2}/.travis.yml
  25. +119 −0 vendor/plugins/bundler/gems/{bundler-1.10.4 → bundler-1.11.2}/CHANGELOG.md
  26. +6 −4 vendor/plugins/bundler/gems/{bundler-1.10.4 → bundler-1.11.2}/CODE_OF_CONDUCT.md
  27. 0 vendor/plugins/bundler/gems/{bundler-1.10.4 → bundler-1.11.2}/CONTRIBUTING.md
  28. +4 −5 vendor/plugins/bundler/gems/{bundler-1.10.4 → bundler-1.11.2}/DEVELOPMENT.md
  29. 0 vendor/plugins/bundler/gems/{bundler-1.10.4 → bundler-1.11.2}/ISSUES.md
  30. 0 vendor/plugins/bundler/gems/{bundler-1.10.4 → bundler-1.11.2}/LICENSE.md
  31. +7 −3 vendor/plugins/bundler/gems/{bundler-1.10.4 → bundler-1.11.2}/README.md
  32. +71 −88 vendor/plugins/bundler/gems/{bundler-1.10.4 → bundler-1.11.2}/Rakefile
  33. +14 −0 vendor/plugins/bundler/gems/bundler-1.11.2/bin/rake
  34. +10 −0 vendor/plugins/bundler/gems/bundler-1.11.2/bin/rspec
  35. +11 −0 vendor/plugins/bundler/gems/bundler-1.11.2/bin/rubocop
  36. +34 −0 vendor/plugins/bundler/gems/bundler-1.11.2/bundler.gemspec
  37. +20 −0 vendor/plugins/bundler/gems/bundler-1.11.2/exe/bundle
  38. +6 −4 vendor/plugins/bundler/gems/{bundler-1.10.4/bin → bundler-1.11.2/exe}/bundle_ruby
  39. +20 −0 vendor/plugins/bundler/gems/bundler-1.11.2/exe/bundler
  40. +100 −120 vendor/plugins/bundler/gems/{bundler-1.10.4 → bundler-1.11.2}/lib/bundler.rb
  41. +2 −2 vendor/plugins/bundler/gems/{bundler-1.10.4 → bundler-1.11.2}/lib/bundler/capistrano.rb
  42. +86 −75 vendor/plugins/bundler/gems/{bundler-1.10.4 → bundler-1.11.2}/lib/bundler/cli.rb
  43. +1 −2 vendor/plugins/bundler/gems/{bundler-1.10.4 → bundler-1.11.2}/lib/bundler/cli/binstubs.rb
  44. +0 −1 vendor/plugins/bundler/gems/{bundler-1.10.4 → bundler-1.11.2}/lib/bundler/cli/cache.rb
  45. +7 −5 vendor/plugins/bundler/gems/{bundler-1.10.4 → bundler-1.11.2}/lib/bundler/cli/check.rb
  46. +0 −1 vendor/plugins/bundler/gems/{bundler-1.10.4 → bundler-1.11.2}/lib/bundler/cli/clean.rb
  47. +6 −7 vendor/plugins/bundler/gems/{bundler-1.10.4 → bundler-1.11.2}/lib/bundler/cli/common.rb
  48. +100 −0 vendor/plugins/bundler/gems/bundler-1.11.2/lib/bundler/cli/config.rb
  49. +8 −8 vendor/plugins/bundler/gems/{bundler-1.10.4 → bundler-1.11.2}/lib/bundler/cli/console.rb
  50. +5 −4 vendor/plugins/bundler/gems/{bundler-1.10.4 → bundler-1.11.2}/lib/bundler/cli/exec.rb
  51. +52 −40 vendor/plugins/bundler/gems/{bundler-1.10.4 → bundler-1.11.2}/lib/bundler/cli/gem.rb
  52. +5 −6 vendor/plugins/bundler/gems/{bundler-1.10.4 → bundler-1.11.2}/lib/bundler/cli/init.rb
  53. +1 −2 vendor/plugins/bundler/gems/{bundler-1.10.4 → bundler-1.11.2}/lib/bundler/cli/inject.rb
  54. +18 −21 vendor/plugins/bundler/gems/{bundler-1.10.4 → bundler-1.11.2}/lib/bundler/cli/install.rb
  55. +8 −3 vendor/plugins/bundler/gems/{bundler-1.10.4 → bundler-1.11.2}/lib/bundler/cli/lock.rb
  56. +4 −5 vendor/plugins/bundler/gems/{bundler-1.10.4 → bundler-1.11.2}/lib/bundler/cli/open.rb
  57. +7 −8 vendor/plugins/bundler/gems/{bundler-1.10.4 → bundler-1.11.2}/lib/bundler/cli/outdated.rb
  58. +1 −1 vendor/plugins/bundler/gems/{bundler-1.10.4 → bundler-1.11.2}/lib/bundler/cli/package.rb
  59. +2 −3 vendor/plugins/bundler/gems/{bundler-1.10.4 → bundler-1.11.2}/lib/bundler/cli/platform.rb
  60. +9 −9 vendor/plugins/bundler/gems/{bundler-1.10.4 → bundler-1.11.2}/lib/bundler/cli/show.rb
  61. +2 −3 vendor/plugins/bundler/gems/{bundler-1.10.4 → bundler-1.11.2}/lib/bundler/cli/update.rb
  62. +1 −2 vendor/plugins/bundler/gems/{bundler-1.10.4 → bundler-1.11.2}/lib/bundler/cli/viz.rb
  63. +1 −1 vendor/plugins/bundler/gems/{bundler-1.10.4 → bundler-1.11.2}/lib/bundler/constants.rb
  64. +38 −3 vendor/plugins/bundler/gems/{bundler-1.10.4 → bundler-1.11.2}/lib/bundler/current_ruby.rb
  65. +93 −97 vendor/plugins/bundler/gems/{bundler-1.10.4 → bundler-1.11.2}/lib/bundler/definition.rb
  66. +45 −0 vendor/plugins/bundler/gems/bundler-1.11.2/lib/bundler/dep_proxy.rb
  67. +17 −11 vendor/plugins/bundler/gems/{bundler-1.10.4 → bundler-1.11.2}/lib/bundler/dependency.rb
  68. +2 −2 vendor/plugins/bundler/gems/{bundler-1.10.4 → bundler-1.11.2}/lib/bundler/deployment.rb
  69. +3 −3 vendor/plugins/bundler/gems/{bundler-1.10.4 → bundler-1.11.2}/lib/bundler/deprecate.rb
  70. +63 −44 vendor/plugins/bundler/gems/{bundler-1.10.4 → bundler-1.11.2}/lib/bundler/dsl.rb
  71. 0 vendor/plugins/bundler/gems/{bundler-1.10.4 → bundler-1.11.2}/lib/bundler/endpoint_specification.rb
  72. +19 −12 vendor/plugins/bundler/gems/{bundler-1.10.4 → bundler-1.11.2}/lib/bundler/env.rb
  73. +1 −2 vendor/plugins/bundler/gems/{bundler-1.10.4 → bundler-1.11.2}/lib/bundler/environment.rb
  74. +82 −0 vendor/plugins/bundler/gems/bundler-1.11.2/lib/bundler/errors.rb
  75. +49 −40 vendor/plugins/bundler/gems/{bundler-1.10.4 → bundler-1.11.2}/lib/bundler/fetcher.rb
  76. +40 −0 vendor/plugins/bundler/gems/bundler-1.11.2/lib/bundler/fetcher/base.rb
  77. +5 −5 vendor/plugins/bundler/gems/{bundler-1.10.4 → bundler-1.11.2}/lib/bundler/fetcher/dependency.rb
  78. +1 −2 vendor/plugins/bundler/gems/{bundler-1.10.4 → bundler-1.11.2}/lib/bundler/fetcher/downloader.rb
  79. +4 −7 vendor/plugins/bundler/gems/{bundler-1.10.4 → bundler-1.11.2}/lib/bundler/fetcher/index.rb
  80. +15 −8 vendor/plugins/bundler/gems/{bundler-1.10.4 → bundler-1.11.2}/lib/bundler/friendly_errors.rb
  81. +44 −35 vendor/plugins/bundler/gems/{bundler-1.10.4 → bundler-1.11.2}/lib/bundler/gem_helper.rb
  82. +25 −0 vendor/plugins/bundler/gems/bundler-1.11.2/lib/bundler/gem_helpers.rb
  83. 0 vendor/plugins/bundler/gems/{bundler-1.10.4 → bundler-1.11.2}/lib/bundler/gem_path_manipulation.rb
  84. +41 −0 vendor/plugins/bundler/gems/bundler-1.11.2/lib/bundler/gem_remote_fetcher.rb
  85. +5 −0 vendor/plugins/bundler/gems/bundler-1.11.2/lib/bundler/gem_tasks.rb
  86. +25 −24 vendor/plugins/bundler/gems/{bundler-1.10.4 → bundler-1.11.2}/lib/bundler/graph.rb
  87. +21 −18 vendor/plugins/bundler/gems/{bundler-1.10.4 → bundler-1.11.2}/lib/bundler/index.rb
  88. +2 −4 vendor/plugins/bundler/gems/{bundler-1.10.4 → bundler-1.11.2}/lib/bundler/injector.rb
  89. +3 −3 vendor/plugins/bundler/gems/{bundler-1.10.4 → bundler-1.11.2}/lib/bundler/inline.rb
  90. +57 −144 vendor/plugins/bundler/gems/{bundler-1.10.4 → bundler-1.11.2}/lib/bundler/installer.rb
  91. +76 −0 vendor/plugins/bundler/gems/bundler-1.11.2/lib/bundler/installer/gem_installer.rb
  92. +24 −16 ...lugins/bundler/gems/{bundler-1.10.4 → bundler-1.11.2}/lib/bundler/installer/parallel_installer.rb
  93. +48 −0 vendor/plugins/bundler/gems/bundler-1.11.2/lib/bundler/installer/standalone.rb
  94. +4 −5 vendor/plugins/bundler/gems/{bundler-1.10.4 → bundler-1.11.2}/lib/bundler/lazy_specification.rb
  95. +21 −19 vendor/plugins/bundler/gems/{bundler-1.10.4 → bundler-1.11.2}/lib/bundler/lockfile_parser.rb
  96. +2 −2 vendor/plugins/bundler/gems/{bundler-1.10.4 → bundler-1.11.2}/lib/bundler/man/bundle
  97. +2 −2 vendor/plugins/bundler/gems/{bundler-1.10.4 → bundler-1.11.2}/lib/bundler/man/bundle-config
  98. +6 −4 vendor/plugins/bundler/gems/{bundler-1.10.4 → bundler-1.11.2}/lib/bundler/man/bundle-config.txt
  99. +1 −1 vendor/plugins/bundler/gems/{bundler-1.10.4 → bundler-1.11.2}/lib/bundler/man/bundle-exec
  100. +1 −1 vendor/plugins/bundler/gems/{bundler-1.10.4 → bundler-1.11.2}/lib/bundler/man/bundle-exec.txt
  101. +80 −0 vendor/plugins/bundler/gems/bundler-1.11.2/lib/bundler/man/bundle-gem
  102. +90 −0 vendor/plugins/bundler/gems/bundler-1.11.2/lib/bundler/man/bundle-gem.txt
  103. +10 −5 vendor/plugins/bundler/gems/{bundler-1.10.4 → bundler-1.11.2}/lib/bundler/man/bundle-install
  104. +105 −98 vendor/plugins/bundler/gems/{bundler-1.10.4 → bundler-1.11.2}/lib/bundler/man/bundle-install.txt
  105. +55 −0 vendor/plugins/bundler/gems/bundler-1.11.2/lib/bundler/man/bundle-lock
  106. +60 −0 vendor/plugins/bundler/gems/bundler-1.11.2/lib/bundler/man/bundle-lock.txt
  107. +1 −1 vendor/plugins/bundler/gems/{bundler-1.10.4 → bundler-1.11.2}/lib/bundler/man/bundle-package
  108. +1 −1 vendor/plugins/bundler/gems/{bundler-1.10.4 → bundler-1.11.2}/lib/bundler/man/bundle-package.txt
  109. +1 −1 vendor/plugins/bundler/gems/{bundler-1.10.4 → bundler-1.11.2}/lib/bundler/man/bundle-platform
  110. +1 −1 vendor/plugins/bundler/gems/{bundler-1.10.4 → bundler-1.11.2}/lib/bundler/man/bundle-platform.txt
  111. +1 −1 vendor/plugins/bundler/gems/{bundler-1.10.4 → bundler-1.11.2}/lib/bundler/man/bundle-update
  112. +1 −1 vendor/plugins/bundler/gems/{bundler-1.10.4 → bundler-1.11.2}/lib/bundler/man/bundle-update.txt
  113. +2 −2 vendor/plugins/bundler/gems/{bundler-1.10.4 → bundler-1.11.2}/lib/bundler/man/bundle.txt
  114. +32 −1 vendor/plugins/bundler/gems/{bundler-1.10.4 → bundler-1.11.2}/lib/bundler/man/gemfile.5
  115. +35 −11 vendor/plugins/bundler/gems/{bundler-1.10.4 → bundler-1.11.2}/lib/bundler/man/gemfile.5.txt
  116. +13 −0 vendor/plugins/bundler/gems/bundler-1.11.2/lib/bundler/match_platform.rb
  117. +5 −5 vendor/plugins/bundler/gems/{bundler-1.10.4 → bundler-1.11.2}/lib/bundler/psyched_yaml.rb
  118. +28 −3 vendor/plugins/bundler/gems/{bundler-1.10.4 → bundler-1.11.2}/lib/bundler/remote_specification.rb
  119. +98 −91 vendor/plugins/bundler/gems/{bundler-1.10.4 → bundler-1.11.2}/lib/bundler/resolver.rb
  120. +9 −10 vendor/plugins/bundler/gems/{bundler-1.10.4 → bundler-1.11.2}/lib/bundler/retry.rb
  121. +1 −1 vendor/plugins/bundler/gems/{bundler-1.10.4 → bundler-1.11.2}/lib/bundler/ruby_dsl.rb
  122. +7 −10 vendor/plugins/bundler/gems/{bundler-1.10.4 → bundler-1.11.2}/lib/bundler/ruby_version.rb
  123. +32 −27 vendor/plugins/bundler/gems/{bundler-1.10.4 → bundler-1.11.2}/lib/bundler/rubygems_ext.rb
  124. +2 −2 ...ndler-1.10.4/lib/bundler/gem_installer.rb → bundler-1.11.2/lib/bundler/rubygems_gem_installer.rb}
  125. +85 −70 vendor/plugins/bundler/gems/{bundler-1.10.4 → bundler-1.11.2}/lib/bundler/rubygems_integration.rb
  126. +65 −61 vendor/plugins/bundler/gems/{bundler-1.10.4 → bundler-1.11.2}/lib/bundler/runtime.rb
  127. +27 −26 vendor/plugins/bundler/gems/{bundler-1.10.4 → bundler-1.11.2}/lib/bundler/settings.rb
  128. +3 −3 vendor/plugins/bundler/gems/{bundler-1.10.4 → bundler-1.11.2}/lib/bundler/setup.rb
  129. +45 −20 vendor/plugins/bundler/gems/{bundler-1.10.4 → bundler-1.11.2}/lib/bundler/shared_helpers.rb
  130. +19 −21 vendor/plugins/bundler/gems/{bundler-1.10.4 → bundler-1.11.2}/lib/bundler/similarity_detector.rb
  131. +4 −5 vendor/plugins/bundler/gems/{bundler-1.10.4 → bundler-1.11.2}/lib/bundler/source.rb
  132. +29 −31 vendor/plugins/bundler/gems/{bundler-1.10.4 → bundler-1.11.2}/lib/bundler/source/git.rb
  133. +52 −26 vendor/plugins/bundler/gems/{bundler-1.10.4 → bundler-1.11.2}/lib/bundler/source/git/git_proxy.rb
  134. +25 −28 vendor/plugins/bundler/gems/{bundler-1.10.4 → bundler-1.11.2}/lib/bundler/source/path.rb
  135. +4 −4 vendor/plugins/bundler/gems/{bundler-1.10.4 → bundler-1.11.2}/lib/bundler/source/path/installer.rb
  136. +66 −48 vendor/plugins/bundler/gems/{bundler-1.10.4 → bundler-1.11.2}/lib/bundler/source/rubygems.rb
  137. +3 −3 vendor/plugins/bundler/gems/{bundler-1.10.4 → bundler-1.11.2}/lib/bundler/source/rubygems/remote.rb
  138. +4 −4 vendor/plugins/bundler/gems/{bundler-1.10.4 → bundler-1.11.2}/lib/bundler/source_list.rb
  139. +17 −15 vendor/plugins/bundler/gems/{bundler-1.10.4 → bundler-1.11.2}/lib/bundler/spec_set.rb
  140. 0 vendor/plugins/bundler/gems/{bundler-1.10.4 → bundler-1.11.2}/lib/bundler/ssl_certs/.document
  141. 0 ...dler/gems/{bundler-1.10.4 → bundler-1.11.2}/lib/bundler/ssl_certs/AddTrustExternalCARoot-2048.pem
  142. 0 ...s/bundler/gems/{bundler-1.10.4 → bundler-1.11.2}/lib/bundler/ssl_certs/AddTrustExternalCARoot.pem
  143. 0 ...dler-1.10.4 → bundler-1.11.2}/lib/bundler/ssl_certs/Class3PublicPrimaryCertificationAuthority.pem
  144. 0 ...er/gems/{bundler-1.10.4 → bundler-1.11.2}/lib/bundler/ssl_certs/DigiCertHighAssuranceEVRootCA.pem
  145. 0 ...r-1.10.4 → bundler-1.11.2}/lib/bundler/ssl_certs/EntrustnetSecureServerCertificationAuthority.pem
  146. 0 ...plugins/bundler/gems/{bundler-1.10.4 → bundler-1.11.2}/lib/bundler/ssl_certs/GeoTrustGlobalCA.pem
  147. +5 −6 ...ugins/bundler/gems/{bundler-1.10.4 → bundler-1.11.2}/lib/bundler/ssl_certs/certificate_manager.rb
  148. +2 −2 vendor/plugins/bundler/gems/{bundler-1.10.4 → bundler-1.11.2}/lib/bundler/stub_specification.rb
  149. +5 −5 vendor/plugins/bundler/gems/{bundler-1.10.4 → bundler-1.11.2}/lib/bundler/templates/Executable
  150. 0 ...lugins/bundler/gems/{bundler-1.10.4 → bundler-1.11.2}/lib/bundler/templates/Executable.standalone
  151. 0 vendor/plugins/bundler/gems/{bundler-1.10.4 → bundler-1.11.2}/lib/bundler/templates/Gemfile
  152. 0 ...lugins/bundler/gems/{bundler-1.10.4 → bundler-1.11.2}/lib/bundler/templates/newgem/.travis.yml.tt
  153. +49 −0 vendor/plugins/bundler/gems/bundler-1.11.2/lib/bundler/templates/newgem/CODE_OF_CONDUCT.md.tt
  154. 0 ...or/plugins/bundler/gems/{bundler-1.10.4 → bundler-1.11.2}/lib/bundler/templates/newgem/Gemfile.tt
  155. 0 ...lugins/bundler/gems/{bundler-1.10.4 → bundler-1.11.2}/lib/bundler/templates/newgem/LICENSE.txt.tt
  156. +2 −2 .../plugins/bundler/gems/{bundler-1.10.4 → bundler-1.11.2}/lib/bundler/templates/newgem/README.md.tt
  157. +4 −2 ...r/plugins/bundler/gems/{bundler-1.10.4 → bundler-1.11.2}/lib/bundler/templates/newgem/Rakefile.tt
  158. 0 ...lugins/bundler/gems/{bundler-1.10.4 → bundler-1.11.2}/lib/bundler/templates/newgem/bin/console.tt
  159. +2 −1 .../plugins/bundler/gems/{bundler-1.10.4 → bundler-1.11.2}/lib/bundler/templates/newgem/bin/setup.tt
  160. 0 ...plugins/bundler/gems/{bundler-1.10.4 → bundler-1.11.2}/lib/bundler/templates/newgem/exe/newgem.tt
  161. 0 ...dler/gems/{bundler-1.10.4 → bundler-1.11.2}/lib/bundler/templates/newgem/ext/newgem/extconf.rb.tt
  162. 0 ...undler/gems/{bundler-1.10.4 → bundler-1.11.2}/lib/bundler/templates/newgem/ext/newgem/newgem.c.tt
  163. 0 ...undler/gems/{bundler-1.10.4 → bundler-1.11.2}/lib/bundler/templates/newgem/ext/newgem/newgem.h.tt
  164. 0 .../plugins/bundler/gems/{bundler-1.10.4 → bundler-1.11.2}/lib/bundler/templates/newgem/gitignore.tt
  165. 0 ...gins/bundler/gems/{bundler-1.10.4 → bundler-1.11.2}/lib/bundler/templates/newgem/lib/newgem.rb.tt
  166. 0 ...dler/gems/{bundler-1.10.4 → bundler-1.11.2}/lib/bundler/templates/newgem/lib/newgem/version.rb.tt
  167. +2 −2 ...ins/bundler/gems/{bundler-1.10.4 → bundler-1.11.2}/lib/bundler/templates/newgem/newgem.gemspec.tt
  168. 0 vendor/plugins/bundler/gems/{bundler-1.10.4 → bundler-1.11.2}/lib/bundler/templates/newgem/rspec.tt
  169. 0 ...undler/gems/{bundler-1.10.4 → bundler-1.11.2}/lib/bundler/templates/newgem/spec/newgem_spec.rb.tt
  170. 0 ...undler/gems/{bundler-1.10.4 → bundler-1.11.2}/lib/bundler/templates/newgem/spec/spec_helper.rb.tt
  171. 0 ...undler/gems/{bundler-1.10.4 → bundler-1.11.2}/lib/bundler/templates/newgem/test/newgem_test.rb.tt
  172. 0 ...undler/gems/{bundler-1.10.4 → bundler-1.11.2}/lib/bundler/templates/newgem/test/test_helper.rb.tt
  173. +7 −0 vendor/plugins/bundler/gems/bundler-1.11.2/lib/bundler/ui.rb
  174. +2 −2 vendor/plugins/bundler/gems/{bundler-1.10.4 → bundler-1.11.2}/lib/bundler/ui/rg_proxy.rb
  175. +10 −6 vendor/plugins/bundler/gems/{bundler-1.10.4 → bundler-1.11.2}/lib/bundler/ui/shell.rb
  176. 0 vendor/plugins/bundler/gems/{bundler-1.10.4 → bundler-1.11.2}/lib/bundler/ui/silent.rb
  177. 0 ...gins/bundler/gems/{bundler-1.10.4 → bundler-1.11.2}/lib/bundler/vendor/molinillo/lib/molinillo.rb
  178. +82 −71 .../{bundler-1.10.4 → bundler-1.11.2}/lib/bundler/vendor/molinillo/lib/molinillo/dependency_graph.rb
  179. 0 ...ndler/gems/{bundler-1.10.4 → bundler-1.11.2}/lib/bundler/vendor/molinillo/lib/molinillo/errors.rb
  180. +1 −1 ...gems/{bundler-1.10.4 → bundler-1.11.2}/lib/bundler/vendor/molinillo/lib/molinillo/gem_metadata.rb
  181. +9 −0 ....4 → bundler-1.11.2}/lib/bundler/vendor/molinillo/lib/molinillo/modules/specification_provider.rb
  182. 0 ...r/gems/{bundler-1.10.4 → bundler-1.11.2}/lib/bundler/vendor/molinillo/lib/molinillo/modules/ui.rb
  183. +40 −21 ...r/gems/{bundler-1.10.4 → bundler-1.11.2}/lib/bundler/vendor/molinillo/lib/molinillo/resolution.rb
  184. 0 ...ler/gems/{bundler-1.10.4 → bundler-1.11.2}/lib/bundler/vendor/molinillo/lib/molinillo/resolver.rb
  185. +8 −0 ...undler/gems/{bundler-1.10.4 → bundler-1.11.2}/lib/bundler/vendor/molinillo/lib/molinillo/state.rb
  186. 0 vendor/plugins/bundler/gems/{bundler-1.10.4 → bundler-1.11.2}/lib/bundler/vendor/net/http/faster.rb
  187. 0 .../plugins/bundler/gems/{bundler-1.10.4 → bundler-1.11.2}/lib/bundler/vendor/net/http/persistent.rb
  188. 0 ...undler/gems/{bundler-1.10.4 → bundler-1.11.2}/lib/bundler/vendor/net/http/persistent/ssl_reuse.rb
  189. 0 vendor/plugins/bundler/gems/{bundler-1.10.4 → bundler-1.11.2}/lib/bundler/vendor/thor/lib/thor.rb
  190. 0 ...lugins/bundler/gems/{bundler-1.10.4 → bundler-1.11.2}/lib/bundler/vendor/thor/lib/thor/actions.rb
  191. 0 ...er/gems/{bundler-1.10.4 → bundler-1.11.2}/lib/bundler/vendor/thor/lib/thor/actions/create_file.rb
  192. 0 ...er/gems/{bundler-1.10.4 → bundler-1.11.2}/lib/bundler/vendor/thor/lib/thor/actions/create_link.rb
  193. 0 ...dler/gems/{bundler-1.10.4 → bundler-1.11.2}/lib/bundler/vendor/thor/lib/thor/actions/directory.rb
  194. 0 ...ems/{bundler-1.10.4 → bundler-1.11.2}/lib/bundler/vendor/thor/lib/thor/actions/empty_directory.rb
  195. 0 ...s/{bundler-1.10.4 → bundler-1.11.2}/lib/bundler/vendor/thor/lib/thor/actions/file_manipulation.rb
  196. 0 ...ms/{bundler-1.10.4 → bundler-1.11.2}/lib/bundler/vendor/thor/lib/thor/actions/inject_into_file.rb
  197. 0 ...r/plugins/bundler/gems/{bundler-1.10.4 → bundler-1.11.2}/lib/bundler/vendor/thor/lib/thor/base.rb
  198. 0 ...lugins/bundler/gems/{bundler-1.10.4 → bundler-1.11.2}/lib/bundler/vendor/thor/lib/thor/command.rb
  199. 0 ....10.4 → bundler-1.11.2}/lib/bundler/vendor/thor/lib/thor/core_ext/hash_with_indifferent_access.rb
  200. 0 ...ems/{bundler-1.10.4 → bundler-1.11.2}/lib/bundler/vendor/thor/lib/thor/core_ext/io_binary_read.rb
  201. 0 .../gems/{bundler-1.10.4 → bundler-1.11.2}/lib/bundler/vendor/thor/lib/thor/core_ext/ordered_hash.rb
  202. 0 .../plugins/bundler/gems/{bundler-1.10.4 → bundler-1.11.2}/lib/bundler/vendor/thor/lib/thor/error.rb
  203. 0 .../plugins/bundler/gems/{bundler-1.10.4 → bundler-1.11.2}/lib/bundler/vendor/thor/lib/thor/group.rb
  204. 0 ...ins/bundler/gems/{bundler-1.10.4 → bundler-1.11.2}/lib/bundler/vendor/thor/lib/thor/invocation.rb
  205. 0 ...ns/bundler/gems/{bundler-1.10.4 → bundler-1.11.2}/lib/bundler/vendor/thor/lib/thor/line_editor.rb
  206. 0 ...dler/gems/{bundler-1.10.4 → bundler-1.11.2}/lib/bundler/vendor/thor/lib/thor/line_editor/basic.rb
  207. 0 ...r/gems/{bundler-1.10.4 → bundler-1.11.2}/lib/bundler/vendor/thor/lib/thor/line_editor/readline.rb
  208. 0 ...plugins/bundler/gems/{bundler-1.10.4 → bundler-1.11.2}/lib/bundler/vendor/thor/lib/thor/parser.rb
  209. 0 ...undler/gems/{bundler-1.10.4 → bundler-1.11.2}/lib/bundler/vendor/thor/lib/thor/parser/argument.rb
  210. 0 ...ndler/gems/{bundler-1.10.4 → bundler-1.11.2}/lib/bundler/vendor/thor/lib/thor/parser/arguments.rb
  211. 0 .../bundler/gems/{bundler-1.10.4 → bundler-1.11.2}/lib/bundler/vendor/thor/lib/thor/parser/option.rb
  212. 0 ...bundler/gems/{bundler-1.10.4 → bundler-1.11.2}/lib/bundler/vendor/thor/lib/thor/parser/options.rb
  213. 0 ...ns/bundler/gems/{bundler-1.10.4 → bundler-1.11.2}/lib/bundler/vendor/thor/lib/thor/rake_compat.rb
  214. 0 ...plugins/bundler/gems/{bundler-1.10.4 → bundler-1.11.2}/lib/bundler/vendor/thor/lib/thor/runner.rb
  215. 0 .../plugins/bundler/gems/{bundler-1.10.4 → bundler-1.11.2}/lib/bundler/vendor/thor/lib/thor/shell.rb
  216. 0 ...ns/bundler/gems/{bundler-1.10.4 → bundler-1.11.2}/lib/bundler/vendor/thor/lib/thor/shell/basic.rb
  217. 0 ...ns/bundler/gems/{bundler-1.10.4 → bundler-1.11.2}/lib/bundler/vendor/thor/lib/thor/shell/color.rb
  218. 0 ...ins/bundler/gems/{bundler-1.10.4 → bundler-1.11.2}/lib/bundler/vendor/thor/lib/thor/shell/html.rb
  219. 0 ...r/plugins/bundler/gems/{bundler-1.10.4 → bundler-1.11.2}/lib/bundler/vendor/thor/lib/thor/util.rb
  220. 0 ...lugins/bundler/gems/{bundler-1.10.4 → bundler-1.11.2}/lib/bundler/vendor/thor/lib/thor/version.rb
  221. +2 −0 vendor/plugins/bundler/gems/bundler-1.11.2/lib/bundler/vendored_molinillo.rb
  222. +3 −3 vendor/plugins/bundler/gems/{bundler-1.10.4 → bundler-1.11.2}/lib/bundler/vendored_persistent.rb
  223. +3 −0 vendor/plugins/bundler/gems/bundler-1.11.2/lib/bundler/vendored_thor.rb
  224. +1 −1 vendor/plugins/bundler/gems/{bundler-1.10.4 → bundler-1.11.2}/lib/bundler/version.rb
  225. +1 −1 vendor/plugins/bundler/gems/{bundler-1.10.4 → bundler-1.11.2}/lib/bundler/vlad.rb
  226. +4 −5 vendor/plugins/bundler/gems/{bundler-1.10.4 → bundler-1.11.2}/lib/bundler/worker.rb
  227. +4 −2 vendor/plugins/bundler/gems/{bundler-1.10.4 → bundler-1.11.2}/man/bundle-config.ronn
  228. 0 vendor/plugins/bundler/gems/{bundler-1.10.4 → bundler-1.11.2}/man/bundle-exec.ronn
  229. +77 −0 vendor/plugins/bundler/gems/bundler-1.11.2/man/bundle-gem.ronn
  230. +13 −6 vendor/plugins/bundler/gems/{bundler-1.10.4 → bundler-1.11.2}/man/bundle-install.ronn
  231. +47 −0 vendor/plugins/bundler/gems/bundler-1.11.2/man/bundle-lock.ronn
  232. 0 vendor/plugins/bundler/gems/{bundler-1.10.4 → bundler-1.11.2}/man/bundle-package.ronn
  233. 0 vendor/plugins/bundler/gems/{bundler-1.10.4 → bundler-1.11.2}/man/bundle-platform.ronn
  234. 0 vendor/plugins/bundler/gems/{bundler-1.10.4 → bundler-1.11.2}/man/bundle-update.ronn
  235. +1 −1 vendor/plugins/bundler/gems/{bundler-1.10.4 → bundler-1.11.2}/man/bundle.ronn
  236. +18 −0 vendor/plugins/bundler/gems/{bundler-1.10.4 → bundler-1.11.2}/man/gemfile.5.ronn
  237. +1 −0 vendor/plugins/bundler/gems/{bundler-1.10.4 → bundler-1.11.2}/man/index.txt
  238. +10 −6 vendor/plugins/bundler/specifications/{bundler-1.10.4.gemspec → bundler-1.11.2.gemspec}
View
@@ -15,6 +15,6 @@ gem "rails_xss", "~> 0.4.0"
gem "file_signature", "~> 1.2.0"
gem "syntax", "~> 1.1.0"
gem "maruku", :git => 'git://github.com/distler/maruku.git', :branch => 'nokogiri'
-gem 'iconv', :platforms => [:ruby_20, :ruby_21, :ruby_22]
+gem 'iconv', :platforms => [:ruby_20, :ruby_21, :ruby_22, :ruby_23]
gem 'rdoc-data', :platforms => :ruby_18
gem 'test-unit', '~> 2.5.5'
View
@@ -8,13 +8,18 @@
require 'rubygems'
vend = File.join(File.dirname(__FILE__), 'vendor')
-Gem.use_paths File.join(vend, 'bundle', File.basename(Gem.dir)), (Gem.path + [File.join(vend, 'plugins', 'bundler')])
+#Gem.use_paths File.join(vend, 'bundle', 'ruby', File.basename(Gem.dir)), ([File.join(vend, 'plugins', 'bundler')] + Gem.path)
+Gem.use_paths File.join(vend, 'bundle', 'ruby', File.basename(Gem.dir)), [File.join(vend, 'plugins', 'bundler')]
-version = ">= 0"
+version = ">= 0.a"
-if ARGV.first =~ /^_(.*)_$/ and Gem::Version.correct? $1 then
- version = $1
- ARGV.shift
+if ARGV.first
+ str = ARGV.first
+ str = str.dup.force_encoding("BINARY") if str.respond_to? :force_encoding
+ if str =~ /\A_(.*)_\z/ and Gem::Version.correct?($1) then
+ version = $1
+ ARGV.shift
+ end
end
gem 'bundler', version
@@ -34,7 +34,7 @@ class << @request.session
@oak = pages(:oak)
@liquor = pages(:liquor)
@elephant = pages(:elephant)
- @eternity = Regexp.new('author=.*; path=/; expires=' + Time.utc(2030).strftime("%a, %d %b %Y %H:%M:%S -0000"))
+ @eternity = Regexp.new('author=.*; path=/; expires=' + Time.utc(2030).strftime("%a, %d( |-)%b( |-)%Y %H:%M:%S (-0000|GMT)"))
set_tex_header
end
@@ -420,13 +420,13 @@ def test_blahtex
re = Regexp.new(
%{<p>equation <span class='maruku-inline'><img alt='\\$a\\\\sin\\(\\\\theta\\)\\$' } +
%{class='maruku-png' src='\.\./files/pngs/\\w+\.png' style='vertical-align: -0\.5} +
- %{(5)+6ex; height: 2\.3(3)+ex;'/></span></p>})
+ %{(5)+6ex; height: 2\.([23])+3ex;'/></span></p>})
assert_match_markup_parsed_as(re, 'equation $a\sin(\theta)$')
re = Regexp.new(
%{<div class='maruku-equation'><img alt='\\$a\\\\sin\\(\\\\theta\\)\\$' } +
- %{class='maruku-png' src='\.\./files/pngs/\\w+\.png' style='height: 2\.3(3)+} +
- %{33333ex;'/><\/div>})
+ %{class='maruku-png' src='\.\./files/pngs/\\w+\.png' style='height: 2\.([23])+} +
+ %{3ex;'/><\/div>})
assert_match_markup_parsed_as(re, '$$a\sin(\theta)$$')
else
Binary file not shown.
Binary file not shown.
@@ -1,21 +0,0 @@
-#!/usr/bin/env ruby
-
-# Exit cleanly from an early interrupt
-Signal.trap("INT") { exit 1 }
-
-require 'bundler'
-# Check if an older version of bundler is installed
-$LOAD_PATH.each do |path|
- if path =~ %r'/bundler-0\.(\d+)' && $1.to_i < 9
- err = "Looks like you have a version of bundler that's older than 0.9.\n"
- err << "Please remove your old versions.\n"
- err << "An easy way to do this is by running `gem cleanup bundler`."
- abort(err)
- end
-end
-
-require 'bundler/friendly_errors'
-Bundler.with_friendly_errors do
- require 'bundler/cli'
- Bundler::CLI.start(ARGV, :debug => true)
-end
@@ -1,21 +0,0 @@
-#!/usr/bin/env ruby
-
-# Exit cleanly from an early interrupt
-Signal.trap("INT") { exit 1 }
-
-require 'bundler'
-# Check if an older version of bundler is installed
-$LOAD_PATH.each do |path|
- if path =~ %r'/bundler-0\.(\d+)' && $1.to_i < 9
- err = "Looks like you have a version of bundler that's older than 0.9.\n"
- err << "Please remove your old versions.\n"
- err << "An easy way to do this is by running `gem cleanup bundler`."
- abort(err)
- end
-end
-
-require 'bundler/friendly_errors'
-Bundler.with_friendly_errors do
- require 'bundler/cli'
- Bundler::CLI.start(ARGV, :debug => true)
-end
@@ -1,32 +0,0 @@
-# coding: utf-8
-lib = File.expand_path('../lib/', __FILE__)
-$:.unshift lib unless $:.include?(lib)
-require 'bundler/version'
-
-Gem::Specification.new do |s|
- s.name = 'bundler'
- s.version = Bundler::VERSION
- s.licenses = ['MIT']
- s.authors = ["André Arko", "Terence Lee", "Carl Lerche", "Yehuda Katz"]
- s.email = ["andre.arko+terence.lee@gmail.com"]
- s.homepage = "http://bundler.io"
- s.summary = %q{The best way to manage your application's dependencies}
- s.description = %q{Bundler manages an application's dependencies through its entire life, across many machines, systematically and repeatably}
-
- s.required_ruby_version = '>= 1.8.7'
- s.required_rubygems_version = '>= 1.3.6'
-
- s.add_development_dependency 'mustache', '0.99.6'
- s.add_development_dependency 'rake', '~> 10.0'
- s.add_development_dependency 'rdiscount', '~> 1.6'
- s.add_development_dependency 'ronn', '~> 0.7.3'
- s.add_development_dependency 'rspec', '~> 3.0'
-
- s.files = `git ls-files -z`.split("\x0").reject { |f| f.match(%r{^(test|spec|features)/}) }
- # we don't check in man pages, but we need to ship them because
- # we use them to generate the long-form help for each command.
- s.files += Dir.glob('lib/bundler/man/**/*')
-
- s.executables = %w(bundle bundler)
- s.require_paths = ["lib"]
-end
@@ -1,87 +0,0 @@
-module Bundler
- class CLI::Config
- attr_reader :options, :thor
- attr_accessor :args
-
- def initialize(options, args, thor)
- @options = options
- @args = args
- @thor = thor
- end
-
- def run
- peek = args.shift
-
- if peek && peek =~ /^\-\-/
- name, scope = args.shift, $'
- else
- name, scope = peek, "global"
- end
-
- unless name
- Bundler.ui.confirm "Settings are listed in order of priority. The top value will be used.\n"
-
- Bundler.settings.all.each do |setting|
- Bundler.ui.confirm "#{setting}"
- thor.with_padding do
- Bundler.settings.pretty_values_for(setting).each do |line|
- Bundler.ui.info line
- end
- end
- Bundler.ui.confirm ""
- end
- return
- end
-
- case scope
- when "delete"
- Bundler.settings.set_local(name, nil)
- Bundler.settings.set_global(name, nil)
- when "local", "global"
- if args.empty?
- Bundler.ui.confirm "Settings for `#{name}` in order of priority. The top value will be used"
- thor.with_padding do
- Bundler.settings.pretty_values_for(name).each { |line| Bundler.ui.info line }
- end
- return
- end
-
- new_value = args.join(" ")
- locations = Bundler.settings.locations(name)
-
- if scope == "global"
- if locations[:local]
- Bundler.ui.info "Your application has set #{name} to #{locations[:local].inspect}. " \
- "This will override the global value you are currently setting"
- end
-
- if locations[:env]
- Bundler.ui.info "You have a bundler environment variable for #{name} set to " \
- "#{locations[:env].inspect}. This will take precedence over the global value you are setting"
- end
-
- if locations[:global] && locations[:global] != new_value
- Bundler.ui.info "You are replacing the current global value of #{name}, which is currently " \
- "#{locations[:global].inspect}"
- end
- end
-
- if scope == "local" && locations[:local] != new_value
- Bundler.ui.info "You are replacing the current local value of #{name}, which is currently " \
- "#{locations[:local].inspect}"
- end
-
- if name.match(/\Alocal\./)
- pathname = Pathname.new(args.join(" "))
- new_value = pathname.expand_path.to_s if pathname.directory?
- end
-
- Bundler.settings.send("set_#{scope}", name, new_value)
- else
- Bundler.ui.error "Invalid scope --#{scope} given. Please use --local or --global."
- exit 1
- end
- end
-
- end
-end
@@ -1,43 +0,0 @@
-module Bundler
- class DepProxy
-
- attr_reader :__platform, :dep
-
- def initialize(dep, platform)
- @dep, @__platform = dep, platform
- end
-
- def hash
- @hash ||= dep.hash
- end
-
- def ==(o)
- dep == o.dep && __platform == o.__platform
- end
-
- alias eql? ==
-
- def type
- @dep.type
- end
-
- def name
- @dep.name
- end
-
- def requirement
- @dep.requirement
- end
-
- def to_s
- "#{name} (#{requirement}) #{__platform}"
- end
-
- private
-
- def method_missing(*args)
- @dep.send(*args)
- end
-
- end
-end
@@ -1,27 +0,0 @@
-module Bundler
- class Fetcher
- class Base
- attr_reader :downloader
- attr_reader :remote_uri
- attr_reader :fetch_uri
- attr_reader :display_uri
-
- def initialize(downloader, remote_uri, fetch_uri, display_uri)
- raise 'Abstract class' if self.class == Base
- @downloader = downloader
- @remote_uri = remote_uri
- @fetch_uri = fetch_uri
- @display_uri = display_uri
- end
-
- def api_available?
- api_fetcher?
- end
-
- def api_fetcher?
- false
- end
-
- end
- end
-end
@@ -1,26 +0,0 @@
-module Bundler
- module GemHelpers
-
- GENERIC_CACHE = {}
- GENERICS = [
- [Gem::Platform.new('java'), Gem::Platform.new('java')],
- [Gem::Platform.new('mswin32'), Gem::Platform.new('mswin32')],
- [Gem::Platform.new('mswin64'), Gem::Platform.new('mswin64')],
- [Gem::Platform.new('universal-mingw32'), Gem::Platform.new('universal-mingw32')],
- [Gem::Platform.new('x64-mingw32'), Gem::Platform.new('x64-mingw32')],
- [Gem::Platform.new('x86_64-mingw32'), Gem::Platform.new('x64-mingw32')],
- [Gem::Platform.new('mingw32'), Gem::Platform.new('x86-mingw32')]
- ]
-
- def generic(p)
- return p if p == Gem::Platform::RUBY
-
- GENERIC_CACHE[p] ||= begin
- _, found = GENERICS.find do |match, _generic|
- p.os == match.os && (!match.cpu || p.cpu == match.cpu)
- end
- found || Gem::Platform::RUBY
- end
- end
- end
-end
@@ -1,2 +0,0 @@
-require 'bundler/gem_helper'
-Bundler::GemHelper.install_tasks
@@ -1,13 +0,0 @@
-require 'bundler/gem_helpers'
-
-module Bundler
- module MatchPlatform
- include GemHelpers
-
- def match_platform(p)
- Gem::Platform::RUBY == platform or
- platform.nil? or p == platform or
- generic(Gem::Platform.new(platform)) === p
- end
- end
-end
@@ -1,13 +0,0 @@
-# Contributor Code of Conduct
-
-As contributors and maintainers of this project, we pledge to respect all people who contribute through reporting issues, posting feature requests, updating documentation, submitting pull requests or patches, and other activities.
-
-We are committed to making participation in this project a harassment-free experience for everyone, regardless of level of experience, gender, gender identity and expression, sexual orientation, disability, personal appearance, body size, race, ethnicity, age, or religion.
-
-Examples of unacceptable behavior by participants include the use of sexual language or imagery, derogatory comments or personal attacks, trolling, public or private harassment, insults, or other unprofessional conduct.
-
-Project maintainers have the right and responsibility to remove, edit, or reject comments, commits, code, wiki edits, issues, and other contributions that are not aligned to this Code of Conduct. Project maintainers who do not follow the Code of Conduct may be removed from the project team.
-
-Instances of abusive, harassing, or otherwise unacceptable behavior may be reported by opening an issue or contacting one or more of the project maintainers.
-
-This Code of Conduct is adapted from the [Contributor Covenant](http://contributor-covenant.org), version 1.0.0, available at [http://contributor-covenant.org/version/1/0/0/](http://contributor-covenant.org/version/1/0/0/)
@@ -1,7 +0,0 @@
-module Bundler
- module UI
- autoload :RGProxy, 'bundler/ui/rg_proxy'
- autoload :Shell, 'bundler/ui/shell'
- autoload :Silent, 'bundler/ui/silent'
- end
-end
@@ -1,2 +0,0 @@
-module Bundler; end
-require 'bundler/vendor/molinillo/lib/molinillo'
@@ -1,3 +0,0 @@
-module Bundler; end
-require 'bundler/vendor/thor/lib/thor'
-require 'bundler/vendor/thor/lib/thor/actions'
Oops, something went wrong.

0 comments on commit 1598b56

Please sign in to comment.