Skip to content
Branch: master
Find file History
dependabot-preview and tomusdrw Update ws requirement from 0.8 to 0.9 (#472)
Updates the requirements on [ws](https://github.com/housleyjk/ws-rs) to permit the latest version.
- [Release notes](https://github.com/housleyjk/ws-rs/releases)
- [Changelog](https://github.com/housleyjk/ws-rs/blob/master/CHANGELOG.md)
- [Commits](housleyjk/ws-rs@v0.8.0...v0.9.0)

Signed-off-by: dependabot-preview[bot] <support@dependabot.com>
Latest commit 3e7ae2f Aug 5, 2019
Permalink
Type Name Latest commit message Commit time
..
Failed to load latest commit information.
examples Use rustfmt (#407) Mar 30, 2019
src Implement subscription support in the client (#436) Jul 4, 2019
Cargo.toml Update ws requirement from 0.8 to 0.9 (#472) Aug 5, 2019
README.md Bump to 13.0 (#456) Jul 18, 2019

README.md

jsonrpc-ws-server

WebSockets server for JSON-RPC 2.0.

Documentation

Example

Cargo.toml

[dependencies]
jsonrpc-ws-server = "13.0"

main.rs

use jsonrpc_ws_server::*;
use jsonrpc_ws_server::jsonrpc_core::*;

fn main() {
	let mut io = IoHandler::new();
	io.add_method("say_hello", |_params| {
		Ok(Value::String("hello".into()))
	});

	let server = ServerBuilder::new(io)
		.start(&"0.0.0.0:3030".parse().unwrap())
		.expect("Server must start with no issues");

	server.wait().unwrap()
}
You can’t perform that action at this time.