Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

build(deps): update rand requirement from 0.7.2 to 0.8.0 #488

Merged
merged 9 commits into from Jan 4, 2021

Conversation

@dependabot @github
Copy link
Contributor

@dependabot dependabot bot commented on behalf of github Dec 28, 2020

Updates the requirements on rand to permit the latest version.

Changelog

Sourced from rand's changelog.

[0.8.0] - 2020-12-18

Platform support

  • The minimum supported Rust version is now 1.36 (#1011)
  • getrandom updated to v0.2 (#1041)
  • Remove wasm-bindgen and stdweb feature flags. For details of WASM support, see the getrandom documentation. (#948)
  • ReadRng::next_u32 and next_u64 now use little-Endian conversion instead of native-Endian, affecting results on Big-Endian platforms (#1061)
  • The nightly feature no longer implies the simd_support feature (#1048)
  • Fix simd_support feature to work on current nightlies (#1056)

Rngs

  • ThreadRng is no longer Copy to enable safe usage within thread-local destructors (#1035)
  • gen_range(a, b) was replaced with gen_range(a..b). gen_range(a..=b) is also supported. Note that a and b can no longer be references or SIMD types. (#744, #1003)
  • Replace AsByteSliceMut with Fill and add support for [bool], [char], [f32], [f64] (#940)
  • Restrict rand::rngs::adapter to std (#1027; see also #928)
  • StdRng: add new std_rng feature flag (enabled by default, but might need to be used if disabling default crate features) (#948)
  • StdRng: Switch from ChaCha20 to ChaCha12 for better performance (#1028)
  • SmallRng: Replace PCG algorithm with xoshiro{128,256}++ (#1038)

Sequences

  • Add IteratorRandom::choose_stable as an alternative to choose which does not depend on size hints (#1057)
  • Improve accuracy and performance of IteratorRandom::choose (#1059)
  • Implement IntoIterator for IndexVec, replacing the into_iter method (#1007)
  • Add value stability tests for seq module (#933)

Misc

  • Support PartialEq and Eq for StdRng, SmallRng and StepRng (#979)
  • Added a serde1 feature and added Serialize/Deserialize to UniformInt and WeightedIndex (#974)
  • Drop some unsafe code (#962, #963, #1011)
  • Reduce packaged crate size (#983)
  • Migrate to GitHub Actions from Travis+AppVeyor (#1073)

Distributions

  • Alphanumeric samples bytes instead of chars (#935)
  • Uniform now supports char, enabling rng.gen_range('A'..='Z') (#1068)
  • Add UniformSampler::sample_single_inclusive (#1003)

Weighted sampling

  • Implement weighted sampling without replacement (#976, #1013)
  • rand::distributions::alias_method::WeightedIndex was moved to rand_distr::WeightedAliasIndex. The simpler alternative rand::distribution::WeightedIndex remains. (#945)
  • Improve treatment of rounding errors in WeightedIndex::update_weights (#956)
  • WeightedIndex: return error on NaN instead of panic (#1005)

Documentation

  • Document types supported by random (#994)

... (truncated)

Commits

Dependabot will resolve any conflicts with this PR as long as you don't alter it yourself. You can also trigger a rebase manually by commenting @dependabot rebase.


Dependabot commands and options

You can trigger Dependabot actions by commenting on this PR:

  • @dependabot rebase will rebase this PR
  • @dependabot recreate will recreate this PR, overwriting any edits that have been made to it
  • @dependabot merge will merge this PR after your CI passes on it
  • @dependabot squash and merge will squash and merge this PR after your CI passes on it
  • @dependabot cancel merge will cancel a previously requested merge and block automerging
  • @dependabot reopen will reopen this PR if it is closed
  • @dependabot close will close this PR and stop Dependabot recreating it. You can achieve the same result by closing it manually
  • @dependabot ignore this major version will close this PR and stop Dependabot creating any more for this major version (unless you reopen the PR or upgrade to it yourself)
  • @dependabot ignore this minor version will close this PR and stop Dependabot creating any more for this minor version (unless you reopen the PR or upgrade to it yourself)
  • @dependabot ignore this dependency will close this PR and stop Dependabot creating any more for this dependency (unless you reopen the PR or upgrade to it yourself)
Updates the requirements on [rand](https://github.com/rust-random/rand) to permit the latest version.
- [Release notes](https://github.com/rust-random/rand/releases)
- [Changelog](https://github.com/rust-random/rand/blob/master/CHANGELOG.md)
- [Commits](rust-random/rand@0.7.3...0.8.0)

Signed-off-by: dependabot[bot] <support@github.com>
@dvdplm
Copy link
Member

@dvdplm dvdplm commented Dec 30, 2020

We have to wait for a new version of quickcheck before we can upgrade. The latest release uses rand 0.7, but master is updated to 0.8 so there's hope.

@ordian
Copy link
Member

@ordian ordian commented Jan 4, 2021

We have to wait for a new version of quickcheck before we can upgrade. The latest release uses rand 0.7, but master is updated to 0.8 so there's hope.

Actually we don't have to, pushed 0f82a11.

ordian added 3 commits Jan 4, 2021
* master:
  Remove deprecated FromStr/TryFrom impls for Secret (#495)
  primitive-types: address nits of #480 (#485)
  build(deps): update impl-trait-for-tuples requirement (#490)
  fix: make from_str parse 0x-prefixed strings (#487)
  update some dev-dependencies (#493)
@ordian
ordian approved these changes Jan 4, 2021
ordian added 2 commits Jan 4, 2021
* master:
  build(deps): update smallvec requirement from 0.6.10 to 1.6.0 (#494)
  build(deps): update secp256k1 requirement from 0.19.0 to 0.20.0 (#496)
@ordian ordian requested a review from dvdplm Jan 4, 2021
@dvdplm

This comment has been minimized.

Copy link
Member

@dvdplm dvdplm commented on 0f82a11 Jan 4, 2021

We can do this. We'll have to undo it when quickcheck 1.0 is released but that's fine.

@dvdplm
dvdplm approved these changes Jan 4, 2021
@dvdplm dvdplm merged commit 2c8cd78 into master Jan 4, 2021
1 of 2 checks passed
1 of 2 checks passed
continuous-integration/appveyor/pr Waiting for AppVeyor build to complete
Details
continuous-integration/travis-ci/pr The Travis CI build passed
Details
@dvdplm dvdplm deleted the dependabot/cargo/rand-0.8.0 branch Jan 4, 2021
ordian added a commit that referenced this pull request Jan 4, 2021
* master:
  build(deps): update rand requirement from 0.7.2 to 0.8.0 (#488)
  build(deps): update smallvec requirement from 0.6.10 to 1.6.0 (#494)
  build(deps): update secp256k1 requirement from 0.19.0 to 0.20.0 (#496)
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
Linked issues

Successfully merging this pull request may close these issues.

None yet

2 participants