Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with
or
.
Download ZIP
Browse files

[ci] Tell Travis to use a perl worker and test under perl 5.10 and 5.14

  • Loading branch information...
commit c662128655d4b02e03f107d61def47334943b4f8 1 parent 021101f
@leto leto authored
Showing with 12 additions and 9 deletions.
  1. +12 −9 .travis.yml
View
21 .travis.yml
@@ -1,13 +1,17 @@
+language: "perl"
+perl:
+ - 5.10
+ - 5.14
before_script:
- - sudo apt-get install libffi-dev libicu-dev libgmp3-dev clang llvm-dev liblocal-lib-perl zlib1g-dev gcc-multilib
- - curl -L http://cpanmin.us | sudo perl - --self-upgrade
- - export CI_USER=$USER
-# - env
- - mkdir ~/perl5 && perl -Mlocal::lib >> /tmp/local_lib_junk.sh && source /tmp/local_lib_junk.sh
- - sudo chown -R $CI_USER ~/.cpanm
- - sudo chown -R $CI_USER ~/perl5
+# This stuff used to be required, but was rolled into the Travis CI perl support.
+# - sudo apt-get install libffi-dev libicu-dev libgmp3-dev clang llvm-dev liblocal-lib-perl zlib1g-dev gcc-multilib
+# - curl -L http://cpanmin.us | sudo perl - --self-upgrade
+# - export CI_USER=$USER
+# - mkdir ~/perl5 && perl -Mlocal::lib >> /tmp/local_lib_junk.sh && source /tmp/local_lib_junk.sh
+# - sudo chown -R $CI_USER ~/.cpanm
+# - sudo chown -R $CI_USER ~/perl5
# No, we are not going to run the tests for all these dependencies on every commit
- - cpanm -n TAP::Harness::Archive TAP::Harness::ReportByDescription
+ - cpanm -n TAP::Harness::Archive TAP::Harness::ReportByDescription
script: "perl Configure.pl --test=build $PARROT_CONFIG_ARGS $PARROT_OPTIMIZE --cc=\"$CC\" --link=\"$CC\" --ld=\"$CC\" --ccflags='-g' ; make $PARROT_TEST"
# branches:
# only:
@@ -20,7 +24,6 @@ notifications:
on_failure: always
irc:
- "irc.parrot.org#parrot"
-# - "irc.freenode.net#perl6"
env:
- PARROT_CONFIG_ARGS="" PARROT_OPTIMIZE="--optimize" PARROT_TEST="smolder_fulltest" CC="clang"
- PARROT_CONFIG_ARGS="" PARROT_OPTIMIZE="" PARROT_TEST="smolder_fulltest" CC="clang"
Please sign in to comment.
Something went wrong with that request. Please try again.