Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Warning with Hugo v0.57.2 #59

Closed
k4rtik opened this issue Aug 18, 2019 · 7 comments

Comments

@k4rtik
Copy link

commented Aug 18, 2019

I am getting the following warning:

Module "Hugo-Octopress" is not compatible with this Hugo version; run "hugo mod graph" for more information.

Further, the index page is not listing any of my posts. Unsure if the two issues are related, some help will be appreciated.

FYI, I did not update since de3a76b on Nov 13, 2016, but now trying to rebuild using master.

@parsiya

This comment has been minimized.

Copy link
Owner

commented Aug 22, 2019

Sorry for not seeing this sooner, I am not sure why I did not get a notification for this.

So in Hugo v0.57.0, something has changed about home.Pages which has broken many themes. You can see the issue at gohugoio/hugoThemes#682.

The latest commit has fixed the issue. Please let me know if it works or not and I will see what has gone wrong.

@k4rtik

This comment has been minimized.

Copy link
Author

commented Aug 22, 2019

I found the issue, I had to add the following to my config.toml:

    mainSections = ["post"]

Your recent change at 3f80dea#diff-e8212813d07f0cfc99ce66dbd8933479R6 doesn't default to showing content as said in the README for older config files, AFAICT.

@k4rtik k4rtik closed this Aug 22, 2019
@k4rtik

This comment has been minimized.

Copy link
Author

commented Aug 22, 2019

Even though my main issue is resolved, I should mention, I am still seeing the warning I posted in OP.

@parsiya

This comment has been minimized.

Copy link
Owner

commented Aug 22, 2019

Thanks for checking. The warning is probably because I have messed up the min_version in theme.toml. It's currently set to min_version = 0.572 which is probably wrong.

I do not know how Hugo numbers minor versions but I cannot go with 0.57 because it has a bug that will stop the theme.

@parsiya

This comment has been minimized.

Copy link
Owner

commented Aug 22, 2019

I am reopening this until I can figure it out.

@parsiya parsiya reopened this Aug 22, 2019
@parsiya parsiya self-assigned this Aug 22, 2019
@parsiya parsiya added the bug label Aug 22, 2019
@onedrawingperday

This comment has been minimized.

Copy link

commented Aug 23, 2019

@parsiya

Hugo uses semver versions so it should be: min_version = "0.57.2"

@parsiya

This comment has been minimized.

Copy link
Owner

commented Aug 23, 2019

Thanks @onedrawingperday. I appreciate your help.

@parsiya parsiya closed this in 5bce87e Aug 25, 2019
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
3 participants
You can’t perform that action at this time.