Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Fix LED indication when clearing network credentials #1316

Merged
merged 1 commit into from May 4, 2017

Conversation

@sergeuz
Copy link
Member

commented Apr 30, 2017

Problem

The LED doesn't blink rapidly when clearing network credentials.

Note: This regression doesn't present in any of the releases, so there's no need to update the change log.

Solution

Use higher priority for the LED indication.

Steps to Test

Ensure the device has some network credentials configured, then hold SETUP button for ~10 seconds.

Example App

N/A

References

https://docs.particle.io/guide/getting-started/modes/photon/#wi-fi-network-reset


Completeness

  • User is totes amazing for contributing!
  • Contributor has signed CLA (Info here)
  • Problem and Solution clearly stated
  • Run unit/integration/application tests on device
  • Added documentation
  • Added to CHANGELOG.md after merging (add links to docs and issues)

Bugfix

  • [PR #1316] Fixes LED indication when network credentials are cleared by holding the SETUP button for >10 seconds.

@sergeuz sergeuz added this to the 0.7.0 milestone Apr 30, 2017

@technobly technobly merged commit 10cdcbf into develop May 4, 2017

2 checks passed

continuous-integration/travis-ci/pr The Travis CI build passed
Details
continuous-integration/travis-ci/push The Travis CI build passed
Details

@technobly technobly deleted the fix/led_clear_network_cred branch May 4, 2017

@technobly technobly added the bug label Jun 14, 2017

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
2 participants
You can’t perform that action at this time.