Skip to content
Permalink
Branch: master
Commits on Jun 29, 2019
  1. Merge pull request #103 from passsy/feature/cont_where_possible

    passsy committed Jun 29, 2019
    Embrace const where possible
  2. Remove .empty() const constructors for dart 2.0 and 2.1 support

    passsy committed Jun 29, 2019
  3. Use const where possible

    passsy committed Jun 29, 2019
  4. Reformat

    passsy committed Jun 29, 2019
  5. Test tuples can be const

    passsy committed Jun 29, 2019
  6. Tuples can be const

    passsy committed Jun 29, 2019
  7. Add const where possible

    passsy committed Jun 29, 2019
  8. Test const constructor and generic return types

    passsy committed Jun 29, 2019
    This prevents somebody changing the return type to a const where T == dynamic
  9. Fix empty list generic type

    passsy committed Jun 29, 2019
  10. Remove properties from mixins to allow const constructors

    passsy committed Jun 29, 2019
    Moved lastIndex out of extensions
  11. Make exceptions const

    passsy committed Jun 29, 2019
  12. Merge pull request #102 from passsy/feature/dart_2.4

    passsy committed Jun 29, 2019
    Support for dart 2.4
  13. Don't error when if check fails, but error when cases fail

    passsy committed Jun 29, 2019
  14. Add dart 2.4.0 to supported versions

    passsy committed Jun 29, 2019
    Run coverage only on dart 2.2
  15. prefer ?? operator

    passsy committed Jun 29, 2019
  16. Disable flutter/web lints

    passsy committed Jun 29, 2019
  17. Disable assert with messages

    passsy committed Jun 29, 2019
  18. Double quotes everywhere

    passsy committed Jun 29, 2019
Commits on Jun 11, 2019
  1. Fix pub publish: Remove analyzer exclusions (#101)

    passsy committed Jun 11, 2019
    Fix pub publish: Remove analyzer exclusions
  2. Report to codecov with only a single dart version #2

    passsy committed Jun 11, 2019
  3. Report to codecov with only a single dart version

    passsy committed Jun 11, 2019
  4. Prevent running coverage on dart 2.3

    passsy committed Jun 11, 2019
  5. Run on all supported dart versions

    passsy committed Jun 11, 2019
  6. Remove manual xvfb setup

    passsy committed Jun 11, 2019
  7. Reformat

    passsy committed Jun 11, 2019
  8. Remove analyzer exclusions by applying fixes

    passsy committed Jun 11, 2019
    This fix allows running pub publish with dart 2.2 and 2.3 again
You can’t perform that action at this time.