New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Changing a profile after a password has been entered causes wrong generated password #37

Closed
specialforest opened this Issue Aug 26, 2011 · 11 comments

Comments

Projects
None yet
3 participants
@specialforest

specialforest commented Aug 26, 2011

Sometimes generates wrong password for the first time. I have to close popup window, open it, and enter password again.

@bitboxer

This comment has been minimized.

Show comment
Hide comment
@bitboxer

bitboxer Aug 26, 2011

Contributor

I can't reproduce this on my chrome. Can you explain what you are doing and how to reproduce it?

Contributor

bitboxer commented Aug 26, 2011

I can't reproduce this on my chrome. Can you explain what you are doing and how to reproduce it?

@specialforest

This comment has been minimized.

Show comment
Hide comment
@specialforest

specialforest Aug 26, 2011

It seems that changing profile causes this bug. If I open popup window, enter my password and select different profile, then generated password will be invalid.

specialforest commented Aug 26, 2011

It seems that changing profile causes this bug. If I open popup window, enter my password and select different profile, then generated password will be invalid.

@bitboxer

This comment has been minimized.

Show comment
Hide comment
@bitboxer

bitboxer Aug 26, 2011

Contributor

Nope, it is working fine on my chrome. What chrome under what os do you use?

Contributor

bitboxer commented Aug 26, 2011

Nope, it is working fine on my chrome. What chrome under what os do you use?

@specialforest

This comment has been minimized.

Show comment
Hide comment
@specialforest

specialforest Aug 26, 2011

13.0.782.215 m and extension version is 0.2.0

specialforest commented Aug 26, 2011

13.0.782.215 m and extension version is 0.2.0

@bitboxer

This comment has been minimized.

Show comment
Hide comment
@bitboxer

bitboxer Aug 26, 2011

Contributor

I am using that version under mac os. Here everything is fine, can't reproduce the problem. Under what OS are you using this?

Contributor

bitboxer commented Aug 26, 2011

I am using that version under mac os. Here everything is fine, can't reproduce the problem. Under what OS are you using this?

@specialforest

This comment has been minimized.

Show comment
Hide comment
@specialforest

specialforest Aug 26, 2011

Windows, see example video http://bit.ly/oPOHGy

specialforest commented Aug 26, 2011

Windows, see example video http://bit.ly/oPOHGy

@bitboxer

This comment has been minimized.

Show comment
Hide comment
@bitboxer

bitboxer Aug 26, 2011

Contributor

I hope that wasn't your real password :) . I will try to test this und Windows...

Contributor

bitboxer commented Aug 26, 2011

I hope that wasn't your real password :) . I will try to test this und Windows...

@miquelfire

This comment has been minimized.

Show comment
Hide comment
@miquelfire

miquelfire Aug 26, 2011

Member

I seen this bug before. I would really like to know what causes it (I generate a random password first in the Bookmarklet version because of this bug IIRC)

Member

miquelfire commented Aug 26, 2011

I seen this bug before. I would really like to know what causes it (I generate a random password first in the Bookmarklet version because of this bug IIRC)

@bitboxer

This comment has been minimized.

Show comment
Hide comment
@bitboxer

bitboxer Aug 26, 2011

Contributor

The bookmarklet version is not the same as this version. You can't compare them. And because of that the bug you see in the bookmarklet version can be a very different one.

Contributor

bitboxer commented Aug 26, 2011

The bookmarklet version is not the same as this version. You can't compare them. And because of that the bug you see in the bookmarklet version can be a very different one.

@miquelfire

This comment has been minimized.

Show comment
Hide comment
@miquelfire

miquelfire Aug 26, 2011

Member

I have reason to believe that there's a bug in the way PasswordMaker (Firefox and On-line versions at least, and that's where the bookmarklet code comes from) generate it's passwords that causes an incorrect hash the first time you generate a password. It might be some value needs to be set to something the first time it runs, but is set correctly after that first time.

The bug may be masked in other versions by factors that causes the hasher to run behind the user's back before they enter their password.

Member

miquelfire commented Aug 26, 2011

I have reason to believe that there's a bug in the way PasswordMaker (Firefox and On-line versions at least, and that's where the bookmarklet code comes from) generate it's passwords that causes an incorrect hash the first time you generate a password. It might be some value needs to be set to something the first time it runs, but is set correctly after that first time.

The bug may be masked in other versions by factors that causes the hasher to run behind the user's back before they enter their password.

@bitboxer

This comment has been minimized.

Show comment
Hide comment
@bitboxer

bitboxer Aug 26, 2011

Contributor

Please stop talking about that in this bug entry. I don't think that this is related to this.

Contributor

bitboxer commented Aug 26, 2011

Please stop talking about that in this bug entry. I don't think that this is related to this.

specialforest pushed a commit to specialforest/chrome-passwordmaker that referenced this issue Jan 29, 2012

bitboxer pushed a commit that referenced this issue Jan 29, 2012

@bitboxer bitboxer closed this Jan 29, 2012

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment