Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP
Browse files

Updating version, readme and gemspec - it's time for a new release.

  • Loading branch information...
commit 3f683bf071075bfc69ebdeafada2fae24153186b 1 parent 6a2488b
@pat authored
Showing with 11 additions and 9 deletions.
  1. +1 −0  README.textile
  2. +1 −1  VERSION
  3. +9 −8 after_commit.gemspec
View
1  README.textile
@@ -59,3 +59,4 @@ This version (maintained by Pat Allan) includes the following patches:
* Exception propagation ("George Ogata":http://github.com/oggy/)
* Keeping callbacks focused on the correct transactions ("Benjamin Stein":http://benjaminste.in/)
* Using savepoints for test helper ("Lars Klevan":http://www.linkedin.com/in/larsklevan and "Joel Chippindale":http://blog.monkeysthumb.org/)
+* Only tracking objects from classes that have appropriate callbacks; Adding @after/before_commit_on_save@ to cover creates and updates but not destroys ("Jason Weathered":http://jasoncodes.com/)
View
2  VERSION
@@ -1 +1 @@
-1.0.6
+1.0.7
View
17 after_commit.gemspec
@@ -5,11 +5,11 @@
Gem::Specification.new do |s|
s.name = %q{after_commit}
- s.version = "1.0.6"
+ s.version = "1.0.7"
s.required_rubygems_version = Gem::Requirement.new(">= 0") if s.respond_to? :required_rubygems_version=
s.authors = ["Nick Muerdter", "David Yip", "Pat Allan"]
- s.date = %q{2010-02-16}
+ s.date = %q{2010-05-20}
s.description = %q{
A Ruby on Rails plugin to add an after_commit callback. This can be used to trigger methods only after the entire transaction is complete.
}
@@ -22,13 +22,14 @@ Gem::Specification.new do |s|
"LICENSE",
"lib/after_commit.rb",
"lib/after_commit/active_record.rb",
- "lib/after_commit/connection_adapters.rb",
- "lib/after_commit/test_bypass.rb"
+ "lib/after_commit/active_support_callbacks.rb",
+ "lib/after_commit/after_savepoint.rb",
+ "lib/after_commit/connection_adapters.rb"
]
s.homepage = %q{http://github.com/freelancing-god/after_commit}
s.rdoc_options = ["--charset=UTF-8"]
s.require_paths = ["lib"]
- s.rubygems_version = %q{1.3.5}
+ s.rubygems_version = %q{1.3.6}
s.summary = %q{after_commit callback for ActiveRecord}
s.test_files = [
"test/after_commit_test.rb",
@@ -42,14 +43,14 @@ Gem::Specification.new do |s|
if Gem::Version.new(Gem::RubyGemsVersion) >= Gem::Version.new('1.2.0') then
s.add_runtime_dependency(%q<activerecord>, [">= 0"])
- s.add_development_dependency(%q<shoulda>, [">= 0"])
+ s.add_development_dependency(%q<sqlite3-ruby>, [">= 0"])
else
s.add_dependency(%q<activerecord>, [">= 0"])
- s.add_dependency(%q<shoulda>, [">= 0"])
+ s.add_dependency(%q<sqlite3-ruby>, [">= 0"])
end
else
s.add_dependency(%q<activerecord>, [">= 0"])
- s.add_dependency(%q<shoulda>, [">= 0"])
+ s.add_dependency(%q<sqlite3-ruby>, [">= 0"])
end
end
Please sign in to comment.
Something went wrong with that request. Please try again.