Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

Already on GitHub? Sign in to your account

Release 1.1.3 breaks compatibility with Rails 2.3 #21

Closed
ledermann opened this Issue Mar 2, 2012 · 2 comments

Comments

Projects
None yet
2 participants
Contributor

ledermann commented Mar 2, 2012

Today's release 1.1.3 includes a commit (ae47c81) which breaks compatibility with DelayedJob 2.0.7 (which is needed for using it with Rails 2.3).

It's a small thing about setting priority as integer vs. hash.

Owner

pat commented Mar 2, 2012

I would prefer backwards compatibility, but it's a pain determining which version of DJ is in play. I actually thought 1.1.2 had this broken as well - I think if you're using Rails 2, you're stuck with 1.1.1, but I'm certainly open to patches that allow for both method calls.

Contributor

ledermann commented Mar 2, 2012

What about using this:

Gem.loaded_specs['delayed_job'].version

@ledermann ledermann added a commit to ledermann/ts-delayed-delta that referenced this issue Mar 2, 2012

@ledermann ledermann Fixed compatibility issue #21 with DelayedJob 2.0.7 (needed with Rail…
…s 2.3.x)
6b286ef

@ledermann ledermann closed this Mar 2, 2012

@ledermann ledermann reopened this Mar 2, 2012

@ledermann ledermann closed this Mar 2, 2012

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment