Skip to content
Browse files

Prepare for 3.0.8 release supporting ActiveRecord v3.0.3 with ARel v2…

….0.7
  • Loading branch information...
1 parent 89d14f3 commit 703a73c43b136a3e48e0dd8d1bea241a06ee115f @metaskills metaskills committed
View
5 CHANGELOG
@@ -1,4 +1,9 @@
+* 3.0.8 *
+
+* Support for ActiveRecord v3.0.3 and ARel v2.0.7
+
+
* 3.0.7 *
* Properly quote table names when reflecting on views.
View
6 activerecord-sqlserver-adapter.gemspec
@@ -2,7 +2,7 @@
Gem::Specification.new do |s|
s.platform = Gem::Platform::RUBY
s.name = "activerecord-sqlserver-adapter"
- s.version = "3.0.7"
+ s.version = "3.0.8"
s.summary = "SQL Server 2005 and 2008 Adapter For ActiveRecord."
s.description = "SQL Server 2005 and 2008 Adapter For ActiveRecord"
@@ -17,7 +17,7 @@ Gem::Specification.new do |s|
s.rdoc_options.concat ['--main', 'README.rdoc']
s.rubyforge_project = 'activerecord-sqlserver-adapter'
- s.add_dependency('activerecord', '~> 3.0.0')
- s.add_dependency('arel', '~> 1.0.0')
+ s.add_dependency('activerecord', '~> 3.0.3')
+ s.add_dependency('arel', '~> 2.0.7')
end
View
2 lib/active_record/connection_adapters/sqlserver_adapter.rb
@@ -164,7 +164,7 @@ class SQLServerAdapter < AbstractAdapter
include Sqlserver::Errors
ADAPTER_NAME = 'SQLServer'.freeze
- VERSION = '3.0.7'.freeze
+ VERSION = '3.0.8'.freeze
DATABASE_VERSION_REGEXP = /Microsoft SQL Server\s+(\d{4})/
SUPPORTED_VERSIONS = [2005,2008].freeze

0 comments on commit 703a73c

Please sign in to comment.
Something went wrong with that request. Please try again.