Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP
Browse files

update gemspec

  • Loading branch information...
commit f0948ccc988209987b8d8bbcfb419e4c5cfb58ca 1 parent c9dedd6
@patmaddox authored
Showing with 40 additions and 48 deletions.
  1. +1 −0  .gitignore
  2. +3 −3 Rakefile
  3. +36 −45 giternal.gemspec
View
1  .gitignore
@@ -4,3 +4,4 @@ features/tmp
test_repos
.idea
.rvmrc
+*.gem
View
6 Rakefile
@@ -8,10 +8,10 @@ begin
gem.summary = %Q{Non-sucky git externals}
gem.description = %Q{Giternal provides dead-simple management of external git dependencies. It only stores a small bit of metadata, letting you actively develop in any of the repos. Come deploy time, you can easily freeze freeze all the dependencies to particular versions}
gem.email = "pat.maddox@gmail.com"
- gem.homepage = "http://github.com/pat-maddox/giternal"
+ gem.homepage = "http://github.com/patmaddox/giternal"
gem.authors = ["Pat Maddox"]
- gem.add_development_dependency "rspec"
- gem.add_development_dependency "cucumber"
+ gem.add_development_dependency "rspec", "~> 2"
+ gem.add_development_dependency "cucumber", "~> 1"
# gem is a Gem::Specification... see http://www.rubygems.org/read/chapter/20 for additional settings
end
rescue LoadError
View
81 giternal.gemspec
@@ -1,6 +1,6 @@
# Generated by jeweler
-# DO NOT EDIT THIS FILE
-# Instead, edit Jeweler::Tasks in Rakefile, and run `rake gemspec`
+# DO NOT EDIT THIS FILE DIRECTLY
+# Instead, edit Jeweler::Tasks in Rakefile, and run 'rake gemspec'
# -*- encoding: utf-8 -*-
Gem::Specification.new do |s|
@@ -9,66 +9,57 @@ Gem::Specification.new do |s|
s.required_rubygems_version = Gem::Requirement.new(">= 0") if s.respond_to? :required_rubygems_version=
s.authors = ["Pat Maddox"]
- s.date = %q{2009-10-10}
- s.default_executable = %q{giternal}
+ s.date = %q{2011-06-23}
s.description = %q{Giternal provides dead-simple management of external git dependencies. It only stores a small bit of metadata, letting you actively develop in any of the repos. Come deploy time, you can easily freeze freeze all the dependencies to particular versions}
s.email = %q{pat.maddox@gmail.com}
s.executables = ["giternal"]
s.extra_rdoc_files = [
"LICENSE",
- "README.rdoc"
+ "README.rdoc"
]
s.files = [
".emacs-project",
- ".gitignore",
- "LICENSE",
- "README.rdoc",
- "Rakefile",
- "VERSION.yml",
- "bin/giternal",
- "features/checking_out_externals.feature",
- "features/freeze_externals.feature",
- "features/steps/repository_steps.rb",
- "features/unfreeze_externals.feature",
- "giternal.gemspec",
- "giternal_helper.rb",
- "lib/giternal.rb",
- "lib/giternal/app.rb",
- "lib/giternal/repository.rb",
- "lib/giternal/version.rb",
- "lib/giternal/yaml_config.rb",
- "spec/giternal/app_spec.rb",
- "spec/giternal/repository_spec.rb",
- "spec/giternal/yaml_config_spec.rb",
- "spec/spec.opts",
- "spec/spec_helper.rb",
- "test_trackers.rb"
+ ".rspec",
+ "LICENSE",
+ "README.rdoc",
+ "Rakefile",
+ "VERSION.yml",
+ "bin/giternal",
+ "features/checking_out_externals.feature",
+ "features/freeze_externals.feature",
+ "features/steps/repository_steps.rb",
+ "features/unfreeze_externals.feature",
+ "giternal.gemspec",
+ "lib/giternal.rb",
+ "lib/giternal/app.rb",
+ "lib/giternal/repository.rb",
+ "lib/giternal/version.rb",
+ "lib/giternal/yaml_config.rb",
+ "spec/giternal/app_spec.rb",
+ "spec/giternal/repository_spec.rb",
+ "spec/giternal/yaml_config_spec.rb",
+ "spec/giternal_helper.rb",
+ "spec/spec_helper.rb",
+ "test_trackers.rb"
]
- s.homepage = %q{http://github.com/pat-maddox/giternal}
- s.rdoc_options = ["--charset=UTF-8"]
+ s.homepage = %q{http://github.com/patmaddox/giternal}
s.require_paths = ["lib"]
- s.rubygems_version = %q{1.3.5}
+ s.rubygems_version = %q{1.7.2}
s.summary = %q{Non-sucky git externals}
- s.test_files = [
- "spec/giternal/app_spec.rb",
- "spec/giternal/repository_spec.rb",
- "spec/giternal/yaml_config_spec.rb",
- "spec/spec_helper.rb"
- ]
if s.respond_to? :specification_version then
- current_version = Gem::Specification::CURRENT_SPECIFICATION_VERSION
s.specification_version = 3
- if Gem::Version.new(Gem::RubyGemsVersion) >= Gem::Version.new('1.2.0') then
- s.add_development_dependency(%q<rspec>, [">= 0"])
- s.add_development_dependency(%q<cucumber>, [">= 0"])
+ if Gem::Version.new(Gem::VERSION) >= Gem::Version.new('1.2.0') then
+ s.add_development_dependency(%q<rspec>, ["~> 2"])
+ s.add_development_dependency(%q<cucumber>, ["~> 1"])
else
- s.add_dependency(%q<rspec>, [">= 0"])
- s.add_dependency(%q<cucumber>, [">= 0"])
+ s.add_dependency(%q<rspec>, ["~> 2"])
+ s.add_dependency(%q<cucumber>, ["~> 1"])
end
else
- s.add_dependency(%q<rspec>, [">= 0"])
- s.add_dependency(%q<cucumber>, [">= 0"])
+ s.add_dependency(%q<rspec>, ["~> 2"])
+ s.add_dependency(%q<cucumber>, ["~> 1"])
end
end
+
Please sign in to comment.
Something went wrong with that request. Please try again.