Crash on Arch #2

Closed
webaake opened this Issue Nov 24, 2012 · 13 comments

Projects

None yet

5 participants

@webaake

New version crashes. Stabele version and earlier version from svn worked fine. Ooops. stable 0.2.4-2 crashes too! Messages:
Traceback (most recent call last):
File "/usr/bin/periscope", line 25, in
import periscope
File "/usr/lib/python2.7/site-packages/periscope-dev-py2.7.egg/periscope/init.py", line 20, in
from periscope import *
File "/usr/lib/python2.7/site-packages/periscope-dev-py2.7.egg/periscope/periscope.py", line 36, in
import plugins
File "/usr/lib/python2.7/site-packages/periscope-dev-py2.7.egg/periscope/plugins/init.py", line 24, in
from BierDopje import BierDopje
File "/usr/lib/python2.7/site-packages/periscope-dev-py2.7.egg/periscope/plugins/BierDopje.py", line 29, in
import version
ImportError: No module named version

All deps installed:
python2-beautifulsoup3 python2-notify

@patrickdessalle

A version.py file is missing somewhere. I'll double check if I didn't forget to commit a file

@dinojr

Building latest trunk also complains :

sudo python ./setup.py build
running build
running build_py
file periscope.py (for module periscope) not found
file periscope.py (for module periscope) not found

@Essad

The version.py is missing from the plugin directory...

(/periscope/plugins/)

You can copy the version.py from the root to the plugin directory (before or even after installation)...

@dinojr

I did what you suggested and now I can run
periscope --help

but it still crashes :

periscope The.Walking.Dead.S03E07.720p.HDTV.x264-EVOLVE.mkv
Traceback (most recent call last):
File "/usr/local/bin/periscope", line 5, in
pkg_resources.run_script('periscope==dev', 'periscope')
File "/usr/lib/python2.7/dist-packages/pkg_resources.py", line 499, in run_script
self.require(requires)[0].run_script(script_name, ns)
File "/usr/lib/python2.7/dist-packages/pkg_resources.py", line 1239, in run_script
execfile(script_filename, namespace, namespace)
File "/usr/local/lib/python2.7/dist-packages/periscope-dev-py2.7.egg/EGG-INFO/scripts/periscope", line 134, in
main()
File "/usr/local/lib/python2.7/dist-packages/periscope-dev-py2.7.egg/EGG-INFO/scripts/periscope", line 70, in main
periscope_client = periscope.Periscope(options.cache_folder)
TypeError: init() takes exactly 1 argument (2 given)

@patrickdessalle

The version I've put on github seems to be an old one for some files.

I'll fix it in the next 24h.

@Essad

Yup... It's broken ;)

For the time being, just use the tar.gz file from http://code.google.com/p/periscope/downloads/list
It seems to work... (althou I have some issues with that one also...) But it downloads!

@patrickdessalle Thanks for the god work...

@webaake

Yes, thanks! Appreciate it!

@patrickdessalle

I've fixed the version.py issue and the old code. I've tested it in a virtual env.

Does it work for you guys ?

@dinojr

Yes it does for me, thanks.

@ludwich

Works like a charm =)

@Essad

Yup.. Works..

If I could suggest one more thing...
For the people not using Ubuntu ;)


README:
How to install from source...

Extract the tar to a location and run:

sudo python setup.py build
sudo python setup.py install

Otherwise it's great... thnx..

@patrickdessalle
@webaake

The latest git version compiles fine AND works fine on Arch. Installed periscope-git from AUR. Great! Thanks a lot mate!!!

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment