Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

SyntaxError: Unexpected token #3

Closed
Karl-Webster opened this issue Jul 3, 2017 · 12 comments
Closed

SyntaxError: Unexpected token #3

Karl-Webster opened this issue Jul 3, 2017 · 12 comments

Comments

@Karl-Webster
Copy link

@Karl-Webster Karl-Webster commented Jul 3, 2017

http://imgur.com/a/TnXNz

This is a link to my error. I am trying to install this on Fedora 25. I have installed Async and Await. I am still unable to install.

@p3x-robot
Copy link
Member

@p3x-robot p3x-robot commented Jul 3, 2017

no idea,
https://github.com/patrikx3/onenote/releases or sudo npm install -g p3x-onenote --unsafe-perm=true --allow-root ?

@Karl-Webster
Copy link
Author

@Karl-Webster Karl-Webster commented Jul 3, 2017

Nope that CMDline did not work. I dont mean to waste your time but how do i go about installing the release from that link. I have given it a go but I cant work it out?

@p3x-robot
Copy link
Member

@p3x-robot p3x-robot commented Jul 3, 2017

for node, you need the latest the best. which shows like node 8.1.3
the release you just download the app image and execute, thats all

@p3x-robot
Copy link
Member

@p3x-robot p3x-robot commented Jul 3, 2017

sudo -i
curl --silent --location https://rpm.nodesource.com/setup_8.x | bash -
yum -y install nodejs gcc-c++ make libXScrnSaver

node -v
# make sure it is above 7.8 !!!!

npm install -g p3x-onenote --unsafe-perm=true --allow-root
exit
p3x-onenote

image

@p3x-robot p3x-robot closed this Jul 3, 2017
@Valdenirmezadri
Copy link

@Valdenirmezadri Valdenirmezadri commented Aug 7, 2017

Same error

@p3x-robot
Copy link
Member

@p3x-robot p3x-robot commented Aug 7, 2017

sudo -i
curl --silent --location https://rpm.nodesource.com/setup_8.x | bash -
yum -y install nodejs gcc-c++ make libXScrnSaver
npm install -g p3x-onenote --unsafe-perm=true --allow-root
exit
p3x-onenote
@Valdenirmezadri
Copy link

@Valdenirmezadri Valdenirmezadri commented Aug 7, 2017

error persist
image

@p3x-robot
Copy link
Member

@p3x-robot p3x-robot commented Aug 7, 2017

your nodejs is below 7.8

@p3x-robot
Copy link
Member

@p3x-robot p3x-robot commented Aug 7, 2017

please read the github info or npm, it requires above 7.8. but it shows which build i use, but you can always just use https://github.com/patrikx3/onenote/releases. this is binary and uses the proper nodejs version, nothing to do. it is like an exe just linux.

patrikx3@workstation:~/Projects/lede-node$ node -v
v8.2.1
patrikx3@workstation:~/Projects/lede-node$ 

If the latest NodeJs is bad, use the AppImage as I said:
https://github.com/patrikx3/onenote/releases/download/1.0.143-46/p3x-onenote-1.0.143-46-x86_64.AppImage

Execute and works as well...

@Valdenirmezadri
Copy link

@Valdenirmezadri Valdenirmezadri commented Aug 7, 2017

Thanks! now its working!

@p3x-robot
Copy link
Member

@p3x-robot p3x-robot commented Aug 7, 2017

You are welcome

@p3x-robot
Copy link
Member

@p3x-robot p3x-robot commented Nov 13, 2017

Now the requirement is Node v8.9.0.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
Linked pull requests

Successfully merging a pull request may close this issue.

None yet
3 participants