Skip to content
This repository

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP
Fetching contributors…

Cannot retrieve contributors at this time

file 60 lines (56 sloc) 2.218 kb
1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60
# Generated by jeweler
# DO NOT EDIT THIS FILE DIRECTLY
# Instead, edit Jeweler::Tasks in Rakefile, and run the gemspec command
# -*- encoding: utf-8 -*-

Gem::Specification.new do |s|
  s.name = %q{configurable_engine}
  s.version = "0.2.9"

  s.required_rubygems_version = Gem::Requirement.new(">= 0") if s.respond_to? :required_rubygems_version=
  s.authors = [%q{Paul Campbell}]
  s.date = %q{2011-08-29}
  s.description = %q{Configurable is a Rails 3 engine that allows you to set up config variables in a config file, specifying default values for all environments. These variables can then be set on a per-app basis using a user facing configuration screen. }
  s.email = %q{paul@rslw.com}
  s.extra_rdoc_files = [
    "LICENSE.txt",
     "README.md"
  ]
  s.files = [
    "CHANGELOG",
     "Gemfile",
     "Gemfile.lock",
     "LICENSE.txt",
     "README.md",
     "Rakefile",
     "VERSION",
     "app/controllers/admin/configurables_controller.rb",
     "app/models/configurable.rb",
     "app/views/admin/configurables/show.html.erb",
     "config/routes.rb",
     "configurable_engine.gemspec",
     "lib/configurable_engine.rb",
     "lib/configurable_engine/configurables_controller.rb",
     "lib/configurable_engine/engine.rb",
     "lib/generators/configurable_engine/install_generator.rb",
     "lib/generators/configurable_engine/templates/configurable.yml",
     "lib/generators/configurable_engine/templates/migration.rb"
  ]
  s.homepage = %q{http://github.com/paulca/configurable_engine}
  s.licenses = [%q{MIT}]
  s.rdoc_options = [%q{--charset=UTF-8}]
  s.require_paths = [%q{lib}]
  s.rubygems_version = %q{1.8.6}
  s.summary = %q{Database-backed configuration for Rails 3, with defaults from config file.}

  if s.respond_to? :specification_version then
    s.specification_version = 3

    if Gem::Version.new(Gem::VERSION) >= Gem::Version.new('1.2.0') then
      s.add_runtime_dependency(%q<rails>, ["~> 3"])
      s.add_runtime_dependency(%q<activerecord>, ["~> 3"])
    else
      s.add_dependency(%q<rails>, ["~> 3"])
      s.add_dependency(%q<activerecord>, ["~> 3"])
    end
  else
    s.add_dependency(%q<rails>, ["~> 3"])
    s.add_dependency(%q<activerecord>, ["~> 3"])
  end
end
Something went wrong with that request. Please try again.