Permalink
Browse files

Force ActiveModel 3.0 in gemfile (yes, we need to update this...)

Also recommend using 'bundle exec autotest' in README
  • Loading branch information...
1 parent 235ed49 commit bc53ca926fe6f739dd35304c8c95f246b4bad49e @pauldowman committed Sep 30, 2012
Showing with 19 additions and 16 deletions.
  1. +15 −13 Gemfile.lock
  2. +1 −1 README.md
  3. +3 −2 gitmodel.gemspec
View
@@ -2,35 +2,37 @@ PATH
remote: .
specs:
gitmodel (0.0.7)
- activemodel (>= 3.0.1)
- activesupport (>= 3.0.1)
+ activemodel (~> 3.0.1)
+ activesupport (~> 3.0.1)
grit (>= 2.3.0)
lockfile (>= 1.4.3)
memcache-client (>= 1.8.5)
+ rake
yajl-ruby (>= 0.8.2)
GEM
remote: http://rubygems.org/
specs:
ZenTest (4.6.2)
- activemodel (3.1.3)
- activesupport (= 3.1.3)
- builder (~> 3.0.0)
- i18n (~> 0.6)
- activesupport (3.1.3)
- multi_json (~> 1.0)
+ activemodel (3.0.17)
+ activesupport (= 3.0.17)
+ builder (~> 2.1.2)
+ i18n (~> 0.5.0)
+ activesupport (3.0.17)
autotest (4.4.6)
ZenTest (>= 4.4.1)
- builder (3.0.0)
+ builder (2.1.2)
diff-lcs (1.1.3)
- grit (2.4.1)
+ grit (2.5.0)
diff-lcs (~> 1.1)
mime-types (~> 1.15)
- i18n (0.6.0)
+ posix-spawn (~> 0.3.6)
+ i18n (0.5.0)
lockfile (2.1.0)
memcache-client (1.8.5)
- mime-types (1.17.2)
- multi_json (1.0.4)
+ mime-types (1.19)
+ posix-spawn (0.3.6)
+ rake (0.9.2.2)
rspec (2.7.0)
rspec-core (~> 2.7.0)
rspec-expectations (~> 2.7.0)
View
@@ -181,7 +181,7 @@ Contributing
Do you have an improvement to make? Please submit a pull request on GitHub or a
patch, including a test written with RSpec. To run all tests simply run
-`autotest`.
+`bundle exec autotest`.
The main author is [Paul Dowman](http://pauldowman.com/about) ([@pauldowman](http://twitter.com/pauldowman)).
View
@@ -17,11 +17,12 @@ Gem::Specification.new do |s|
of all changes.
DESC
- s.add_dependency 'activemodel', '>= 3.0.1'
- s.add_dependency 'activesupport', '>= 3.0.1'
+ s.add_dependency 'activemodel', '~> 3.0.1'
+ s.add_dependency 'activesupport', '~> 3.0.1'
s.add_dependency 'grit', '>= 2.3.0'
s.add_dependency 'lockfile', '>= 1.4.3'
s.add_dependency 'memcache-client', '>= 1.8.5'
+ s.add_dependency 'rake'
s.add_dependency 'yajl-ruby', '>= 0.8.2'
s.add_development_dependency 'ZenTest', '>= 4.4.0'

2 comments on commit bc53ca9

how extensive is the incompatibility with activemodel 3.2?

Owner

pauldowman replied Oct 11, 2012

I don't know, I doubt much has changed but I haven't tested it.

Please sign in to comment.