Skip to content
This repository

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP
Browse code

Replace ruby-debug with pry

  • Loading branch information...
commit 284234c74304f371d7ac4d7089b8a03f8bc61114 1 parent e1fe2cb
Paul Elliott authored February 10, 2012
3  Gemfile
... ...
@@ -1,6 +1,3 @@
1 1
 source :rubygems
2 2
 
3 3
 gemspec
4  
-
5  
-gem "ruby-debug",   :platform => :mri_18
6  
-gem "ruby-debug19", :platform => :mri_19, :require => 'ruby-debug'
32  Gemfile.lock
@@ -17,12 +17,11 @@ GEM
17 17
       tzinfo (~> 0.3.29)
18 18
     activesupport (3.1.3)
19 19
       multi_json (~> 1.0)
20  
-    archive-tar-minitar (0.5.2)
21 20
     arel (2.2.1)
22 21
     bson (1.3.1)
23 22
     bson_ext (1.3.1)
24 23
     builder (3.0.0)
25  
-    columnize (0.3.5)
  24
+    coderay (1.0.5)
26 25
     cucumber (1.1.4)
27 26
       builder (>= 2.1.2)
28 27
       diff-lcs (>= 1.1.2)
@@ -42,10 +41,7 @@ GEM
42 41
       json (>= 1.4.6)
43 42
     i18n (0.6.0)
44 43
     json (1.6.3)
45  
-    linecache (0.46)
46  
-      rbx-require-relative (> 0.0.4)
47  
-    linecache19 (0.5.12)
48  
-      ruby_core_source (>= 0.1.4)
  44
+    method_source (0.7.0)
49 45
     mongo (1.3.1)
50 46
       bson (>= 1.3.1)
51 47
     mongoid (2.1.4)
@@ -53,8 +49,11 @@ GEM
53 49
       mongo (~> 1.3)
54 50
       tzinfo (~> 0.3.22)
55 51
     multi_json (1.0.4)
  52
+    pry (0.9.8.2)
  53
+      coderay (~> 1.0.5)
  54
+      method_source (~> 0.7)
  55
+      slop (< 3, >= 2.4.4)
56 56
     rake (0.8.7)
57  
-    rbx-require-relative (0.0.5)
58 57
     rspec (2.7.0)
59 58
       rspec-core (~> 2.7.0)
60 59
       rspec-expectations (~> 2.7.0)
@@ -64,23 +63,9 @@ GEM
64 63
       diff-lcs (~> 1.1.2)
65 64
     rspec-instafail (0.1.9)
66 65
     rspec-mocks (2.7.0)
67  
-    ruby-debug (0.10.4)
68  
-      columnize (>= 0.1)
69  
-      ruby-debug-base (~> 0.10.4.0)
70  
-    ruby-debug-base (0.10.4)
71  
-      linecache (>= 0.3)
72  
-    ruby-debug-base19 (0.11.25)
73  
-      columnize (>= 0.3.1)
74  
-      linecache19 (>= 0.5.11)
75  
-      ruby_core_source (>= 0.1.4)
76  
-    ruby-debug19 (0.11.6)
77  
-      columnize (>= 0.3.1)
78  
-      linecache19 (>= 0.5.11)
79  
-      ruby-debug-base19 (>= 0.11.19)
80 66
     ruby-progressbar (0.0.10)
81  
-    ruby_core_source (0.1.5)
82  
-      archive-tar-minitar (>= 0.5.2)
83 67
     sequel (3.30.0)
  68
+    slop (2.4.4)
84 69
     sqlite3 (1.3.5)
85 70
     term-ansicolor (1.0.7)
86 71
     turnip (0.3.0)
@@ -102,10 +87,9 @@ DEPENDENCIES
102 87
   fuubar-cucumber
103 88
   mongo (~> 1.3.1)
104 89
   mongoid (= 2.1.4)
  90
+  pry
105 91
   rake (~> 0.8.7)
106 92
   rspec
107  
-  ruby-debug
108  
-  ruby-debug19
109 93
   sequel
110 94
   sqlite3
111 95
   turnip (>= 0.3)
1  fabrication.gemspec
@@ -27,6 +27,7 @@ Gem::Specification.new do |s|
27 27
   s.add_development_dependency("fuubar-cucumber")
28 28
   s.add_development_dependency("mongo", ["~> 1.3.1"])
29 29
   s.add_development_dependency("mongoid", ["2.1.4"])
  30
+  s.add_development_dependency("pry")
30 31
   s.add_development_dependency("rake", ['~> 0.8.7'])
31 32
   s.add_development_dependency("rspec")
32 33
   s.add_development_dependency("sequel")

0 notes on commit 284234c

Please sign in to comment.
Something went wrong with that request. Please try again.