Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Allow use of `page_template` in `ContentElement` #239

Closed
codereviewvideos opened this issue Apr 9, 2019 · 2 comments

Comments

Projects
None yet
2 participants
@codereviewvideos
Copy link
Contributor

commented Apr 9, 2019

Expected behaviour

When defining a Page via a Behat feature, I would like to be able to set a Page Template.

Current behaviour

page_template is not in the whitelisted CLI args.

https://github.com/paulgibbs/behat-wordpress-extension/blob/master/src/Driver/Element/Wpcli/ContentElement.php#L49

Possible solution

Add page_template to the white list.

Steps to reproduce

  Background:
    Given there are pages:
      | slug   | title   | content      | status  | template                       |
      | slug-1 | My Page | content here | publish | page-templates/my-template.php |

Context

Everything works as expected, but I cannot set the Page Template when creating new Pages in WordHat.

Your environment

"paulgibbs/behat-wordpress-extension": "^3.1",

@paulgibbs paulgibbs added the bug label Apr 9, 2019

@paulgibbs

This comment has been minimized.

Copy link
Owner

commented Apr 9, 2019

Fixed!

@paulgibbs paulgibbs closed this Apr 9, 2019

@paulgibbs

This comment has been minimized.

Copy link
Owner

commented Jun 5, 2019

This is going into 3.2.0, sorry it took so long to be released. Thanks again!

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
You can’t perform that action at this time.