Remove support for anything before the IE9 release #107

Open
jonathantneal opened this Issue Aug 30, 2012 · 4 comments

5 participants

@jonathantneal
Collaborator

Based on the removal of support for IE<9, I recommend:

  1. We remove support for any browser released before Internet Explorer 9, including Safari 5.0.4, Opera 11, Firefox 3.6.15, iOS 4.3, and Android (Froyo 2.2.2 / Gingerbread 2.3.3 / Honeycomb 3.0).

  2. We remove any references to the aforementioned browser versions. Safari ≤5 would be Safari, Opera ≤11 would be Opera, Firefox ≤3.6.15 would be Firefox, iOS ≤4.3 would be iOS, and you get the picture for Android.

  3. We include a brief note about these base versions in the notes section.

What do you think?

@paulirish
Owner
@AlecRaeside

I don't think IE6-8 support should be removed, as IE8 still has a decent market share. Maybe have option at the top of the page to toggle inclusion of IE6-8 code?

@nessthehero

I would like a toggle as well. Despite the freedom of most of the contributors and users of this resource to drop browser support at whim, some of us are still required to support older versions by our clients and employers. It was nice to have a reference handy, and now we have to look elsewhere.

@mathiasbynens
Collaborator

+1 to what @AlecRaeside and @nessthehero said. (I suggested the same thing before, but sadly it got ignored.)

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment