Permalink
Browse files

Release 0.6.1.

  • Loading branch information...
paulmillr committed Mar 19, 2013
1 parent a3ea702 commit 84162cef3faca148b81edaee4d3fdec62bce9747
Showing with 21 additions and 21 deletions.
  1. +19 −16 CHANGELOG.md
  2. +2 −5 package.json
View
@@ -1,60 +1,63 @@
-# Chokidar 0.6.0 (March 10, 2012)
+# Chokidar 0.6.1 (19 March 2013)
+* Added node.js 0.10 support.
+
+# Chokidar 0.6.0 (10 March 2013)
* File attributes (stat()) are now passed to `add` and `change` events
as second arguments.
* Changed default polling interval for binary files to 300ms.
-# Chokidar 0.5.3 (January 13, 2012)
+# Chokidar 0.5.3 (13 January 2013)
* Removed emitting of `change` events before `unlink`.
-# Chokidar 0.5.2 (January 13, 2012)
+# Chokidar 0.5.2 (13 January 2013)
* Removed postinstall script to prevent various npm bugs.
-# Chokidar 0.5.1 (January 6, 2012)
+# Chokidar 0.5.1 (6 January 2013)
* When starting to watch non-existing paths, chokidar will no longer throw
ENOENT error.
* Fixed bug with absolute path.
-# Chokidar 0.5.0 (December 9, 2012)
+# Chokidar 0.5.0 (9 December 2012)
* Added a bunch of new options:
* `ignoreInitial` that allows to ignore initial `add` events.
* `ignorePermissionErrors` that allows to ignore ENOENT etc perm errors.
* `interval` and `binaryInterval` that allow to change default
fs polling intervals.
-# Chokidar 0.4.0 (July 26, 2012)
+# Chokidar 0.4.0 (26 July 2012)
* Added `all` event that receives two args (event name and path) that
combines `add`, `change` and `unlink` events.
* Switched to `fs.watchFile` on node.js 0.8 on windows.
* Files are now correctly unwatched after unlink.
-# Chokidar 0.3.0 (June 24, 2012)
+# Chokidar 0.3.0 (24 June 2012)
* `unlink` event are no longer emitted for directories, for consistency
with `add`.
-# Chokidar 0.2.6 (June 8, 2012)
+# Chokidar 0.2.6 (8 June 2012)
* Prevented creating of duplicate 'add' events.
-# Chokidar 0.2.5 (June 8, 2012)
+# Chokidar 0.2.5 (8 June 2012)
* Fixed a bug when new files in new directories hadn't been added.
-# Chokidar 0.2.4 (June 7, 2012)
+# Chokidar 0.2.4 (7 June 2012)
* Fixed a bug when unlinked files emitted events after unlink.
-# Chokidar 0.2.3 (May 12, 2012)
+# Chokidar 0.2.3 (12 May 2012)
* Fixed watching of files on windows.
-# Chokidar 0.2.2 (May 4, 2012)
+# Chokidar 0.2.2 (4 May 2012)
* Fixed watcher signature.
-# Chokidar 0.2.1 (May 4, 2012)
+# Chokidar 0.2.1 (4 May 2012)
* Fixed invalid API bug when using `watch()`.
-# Chokidar 0.2.0 (May 4, 2012)
+# Chokidar 0.2.0 (4 May 2012)
* Rewritten in js.
-# Chokidar 0.1.1 (April 26, 2012)
+# Chokidar 0.1.1 (26 April 2012)
* Changed api to `chokidar.watch()`.
* Fixed compilation on windows.
-# Chokidar 0.1.0 (April 20, 2012)
+# Chokidar 0.1.0 (20 April 2012)
* Initial release.
View
@@ -1,7 +1,7 @@
{
"name": "chokidar",
"description": "A neat wrapper around node.js fs.watch / fs.watchFile.",
- "version": "0.6.0",
+ "version": "0.6.1",
"keywords": [
"fs",
"watch",
@@ -25,9 +25,6 @@
}
],
"main": "./lib/index",
- "engines": {

This comment has been minimized.

Show comment Hide comment
@vojtajina

vojtajina Apr 1, 2013

Contributor

@paulmillr Any reason for removing engine version ?

Chokidar is compatible with all the current versions of node, but maybe 0.11 will bring some breaking change that breaks chokidar and so you will release a new version of chokidar that fixes that issue, however you won't fix already released versions so they won't be compatible.

@vojtajina

vojtajina Apr 1, 2013

Contributor

@paulmillr Any reason for removing engine version ?

Chokidar is compatible with all the current versions of node, but maybe 0.11 will bring some breaking change that breaks chokidar and so you will release a new version of chokidar that fixes that issue, however you won't fix already released versions so they won't be compatible.

This comment has been minimized.

Show comment Hide comment
@paulmillr

paulmillr Apr 1, 2013

Owner

npm init now creates projects without this directive. I think this is reasonable. I have like 30 packages and it’s tough to update engine versions in all of them because they still work on 0.10. And they may be installed on 0.10, npm does not prohibit this. So basically field is useless.

@paulmillr

paulmillr Apr 1, 2013

Owner

npm init now creates projects without this directive. I think this is reasonable. I have like 30 packages and it’s tough to update engine versions in all of them because they still work on 0.10. And they may be installed on 0.10, npm does not prohibit this. So basically field is useless.

This comment has been minimized.

Show comment Hide comment
@vojtajina

vojtajina Apr 1, 2013

Contributor

Interesting, but I don't think npm ignores it:

$ node --version
v0.6.18
$ npm install -g karma
npm http GET https://registry.npmjs.org/karma
npm http 304 https://registry.npmjs.org/karma

npm ERR! Error: No compatible version found: karma
npm ERR! No valid targets found.
npm ERR! Perhaps not compatible with your version of node?
...
@vojtajina

vojtajina Apr 1, 2013

Contributor

Interesting, but I don't think npm ignores it:

$ node --version
v0.6.18
$ npm install -g karma
npm http GET https://registry.npmjs.org/karma
npm http 304 https://registry.npmjs.org/karma

npm ERR! Error: No compatible version found: karma
npm ERR! No valid targets found.
npm ERR! Perhaps not compatible with your version of node?
...

This comment has been minimized.

Show comment Hide comment
@paulmillr

paulmillr Apr 1, 2013

Owner

it’s 0.6; newer version just print warns: npm WARN engine test@0.0.0: wanted: {"node":"2.0"} (current: {"node":"v0.10.0","npm":"1.2.14"})

@paulmillr

paulmillr Apr 1, 2013

Owner

it’s 0.6; newer version just print warns: npm WARN engine test@0.0.0: wanted: {"node":"2.0"} (current: {"node":"v0.10.0","npm":"1.2.14"})

This comment has been minimized.

Show comment Hide comment
@vojtajina

vojtajina Apr 2, 2013

Contributor

Woow, you are right. Is there any reasoning behind it ? If libraries (like chokidar) don't specify which versions of Node they work with, how are we gonna cope with breaking changes in Node ?

I started an issue for it isaacs/npm#3305

@vojtajina

vojtajina Apr 2, 2013

Contributor

Woow, you are right. Is there any reasoning behind it ? If libraries (like chokidar) don't specify which versions of Node they work with, how are we gonna cope with breaking changes in Node ?

I started an issue for it isaacs/npm#3305

- "node": "~0.6.10 || 0.7 || 0.8 || 0.9"
- },
"scripts": {
"prepublish": "coffee -o lib/ src/",
"test": "mocha --compilers coffee:coffee-script --require test/common.js --colors"
@@ -38,6 +35,6 @@
"chai": "~1.4.0",
"sinon": "~1.5.2",
"sinon-chai": "2.2.0",
- "coffee-script": "~1.4.0"
+ "coffee-script": "~1.6.0"
}
}

0 comments on commit 84162ce

Please sign in to comment.