Skip to content
A Gmail extension-aware accessory to Net::IMAP.
Ruby
Find file
Latest commit 2b8ba73 Sep 14, 2014 @paulrosania Bump version to 1.1.0
* Supports Ruby 2.0 (davidbalbert)
Failed to load latest commit information.
lib Bump version to 1.1.0 Sep 14, 2014
test Update mocha dependency Sep 14, 2014
.gitignore Initial commit Jun 30, 2012
Gemfile Initial commit Jul 1, 2012
LICENSE Initial commit Jul 1, 2012
README.md Initial commit Jul 1, 2012
Rakefile Initial commit Jul 1, 2012
gmail-imap.gemspec Update mocha dependency Sep 15, 2014

README.md

gmail-imap

A Gmail extension-aware accessory to Net::IMAP.

Installation

Add this line to your application's Gemfile:

gem 'gmail-imap'

And then execute:

$ bundle

Or install it yourself as:

$ gem install gmail-imap

Usage

require 'net/imap/gmail'

Replace calls to Net::IMAP with Net::IMAP::Gmail.

Contributing

  1. Fork it
  2. Create your feature branch (git checkout -b my-new-feature)
  3. Commit your changes (git commit -am 'Added some feature')
  4. Push to the branch (git push origin my-new-feature)
  5. Create new Pull Request
Something went wrong with that request. Please try again.