Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Plugins compilation error under Linux #3572

Open
warepilot opened this issue Sep 11, 2019 · 2 comments

Comments

@warepilot
Copy link

commented Sep 11, 2019

Details

I have this error after following given instructions for compilation under linux:
[...]
Everything OK up here
[...]

cd DbSqlite2/ && ( test -e Makefile || /usr/lib/qt5/bin/qmake -o Makefile /[...]/SQLiteStudio321/Plugins/DbSqlite2/DbSqlite2.pro ) && make -f Makefile 
make[1]: entering directory '/.../SQLiteStudio 321/output/build/Plugins/DbSqlite2'
g++ -c -pipe -O2 -std=gnu++11 -Wall -W -D_REENTRANT -fPIC -DDBSQLITE2_LIBRARY -DQT_NO_DEBUG -DQT_PLUGIN -DQT_CORE_LIB -I../../../../Plugins/DbSqlite2 -I. -I../../../../SQLiteStudio3/coreSQLiteStudio -I../../../../SQLiteStudio3/coreSQLiteStudio -I../../../../Plugins -isystem /usr/include/i386-linux-gnu/qt5 -isystem /usr/include/i386-linux-gnu/qt5/QtCore -I../../../build -I/usr/lib/i386-linux-gnu/qt5/mkspecs/linux-g++ -o ../../../build/dbsqlite2.o ../../../../Plugins/DbSqlite2/dbsqlite2.cpp
In file included from ../../../../Plugins/DbSqlite2/dbsqlite2instance.h:4:0,
                 from ../../../../Plugins/DbSqlite2/dbsqlite2.cpp:2:
../../../../SQLiteStudio3/coreSQLiteStudio/db/abstractdb2.h:11:10: fatal error: sqlite.h: no such file or directory
 #include <sqlite.h>
          ^~~~~~~~~~
compilation terminated.
Makefile:460: recipe for target '../../../build/dbsqlite2.o' failed
make[1]: *** [../../../build/dbsqlite2.o] Error 1
make[1]: Going outside directory '/.../SQLiteStudio 321/output/build/Plugins/DbSqlite2'
Makefile:111: recipe for target 'sub-DbSqlite2-make_first' failed
make: *** [sub-DbSqlite2-make_first] Error 2

What could be the problem? Laking libraries?
I've downloaded source code again and that file is not there.

Operating system

Linux

SQLiteStudio version

3.2.1

@pawelsalawa

This comment has been minimized.

Copy link
Owner

commented Sep 12, 2019

You're missing SQLite (version 2, not 3) header. Probably you need to install a package sqlite-dev or something like that. It depends on your distribution. You can easily google it.

@warepilot

This comment has been minimized.

Copy link
Author

commented Sep 29, 2019

Looking for packages... Trying to solve dang Linux dependencies for installing required libraries.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
2 participants
You can’t perform that action at this time.