pip 1.5 error - need more than 2 values to unpack error #23

Closed
robbyt opened this Issue Jan 4, 2014 · 1 comment

Projects

None yet

2 participants

@robbyt
robbyt commented Jan 4, 2014

pip-accel seems incompatible with pip v1.5

$ pip-accel install -r requirements.txt
INFO Unpacking local source distributions ..
INFO Executing command: pip install --download-cache=/root/.pip/download-cache --find-links=file:///var/cache/pip-accel/sources --build-directory=/tmp/tmpLyTF4T --no-index -r requirements.txt --no-install
Traceback (most recent call last):
File "/srv/virtualenv/1388883995/bin/pip-accel", line 9, in <module>
  load_entry_point('pip-accel==0.11', 'console_scripts', 'pip-accel')()
File "/srv/virtualenv/1388883995/local/lib/python2.7/site-packages/pip_accel/__init__.py", line 99, in main
  requirements = unpack_source_dists(arguments, build_directory)
File "/srv/virtualenv/1388883995/local/lib/python2.7/site-packages/pip_accel/__init__.py", line 175, in unpack_source_dists
  build_directory=build_directory)
File "/srv/virtualenv/1388883995/local/lib/python2.7/site-packages/pip_accel/__init__.py", line 256, in run_pip
    cmd_name, options, args, parser = parseopts(command_line[1:])
ValueError: need more than 2 values to unpack
@xolox xolox added a commit that referenced this issue Jan 6, 2014
@xolox xolox Pin pip-accel to pip < 1.5 (issues #22 and #23)
See issues #22 and #23 on GitHub:

 * --no-install option is deprecated for pip 1.5
   #22

 * pip 1.5 error - need more than 2 values to unpack error
   #23
cf0f272
@xolox
Member
xolox commented Jan 6, 2014

Thanks for reporting the issue. For now I've pinned pip >= 1.4, < 1.5 which takes care of the immediate problem. I'll investigate upgrading to pip 1.5 soon.

@xolox xolox closed this Jan 6, 2014
@xolox xolox referenced this issue in paylogic/py2deb Feb 27, 2015
Merged

+ .gitignore #2

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment