New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Installation fails on Gentoo #163

Closed
jolenzy opened this Issue May 6, 2016 · 6 comments

Comments

Projects
None yet
2 participants
@jolenzy

jolenzy commented May 6, 2016

I've tried to follow the official Gentoo installation instructions, and the installation fails:

>>> Emerging (1 of 1) app-office/qownnotes-16.05.4::qownnotes-overlay
 * qownnotes-16.05.4.tar.xz SHA512 size ;-) ...                                                                                                                                                       [ ok ]
>>> Unpacking source...
>>> Unpacking qownnotes-16.05.4.tar.xz to /var/tmp/portage/app-office/qownnotes-16.05.4/work
>>> Source unpacked in /var/tmp/portage/app-office/qownnotes-16.05.4/work
>>> Preparing source in /var/tmp/portage/app-office/qownnotes-16.05.4/work/qownnotes-16.05.4 ...
>>> Source prepared.
>>> Configuring source in /var/tmp/portage/app-office/qownnotes-16.05.4/work/qownnotes-16.05.4 ...
>>> Source configured.
>>> Compiling source in /var/tmp/portage/app-office/qownnotes-16.05.4/work/qownnotes-16.05.4 ...
 * Running qmake ...
Project MESSAGE: Currently in RELEASE mode.
Project ERROR: Unknown module(s) in QT: xml                                                                                                                                                           [ !! ]

 * Running qmake has failed! (see above for details)
 * This shouldn't happen - please send a bug report to https://bugs.gentoo.org/

 * ERROR: app-office/qownnotes-16.05.4::qownnotes-overlay failed (compile phase):
 *   eqmake5 failed
 * 
 * Call stack:
 *     ebuild.sh, line  133:  Called src_compile
 *   environment, line 2082:  Called eqmake5 'QOwnNotes.pro' '-r'
 *   environment, line  862:  Called die
 * The specific snippet of code:
 *           die "eqmake5 failed";
 * 
 * If you need support, post the output of `emerge --info '=app-office/qownnotes-16.05.4::qownnotes-overlay'`,
 * the complete build log and the output of `emerge -pqv '=app-office/qownnotes-16.05.4::qownnotes-overlay'`.
 * The complete build log is located at '/var/tmp/portage/app-office/qownnotes-16.05.4/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/app-office/qownnotes-16.05.4/temp/environment'.
 * Working directory: '/var/tmp/portage/app-office/qownnotes-16.05.4/work/qownnotes-16.05.4'
 * S: '/var/tmp/portage/app-office/qownnotes-16.05.4/work/qownnotes-16.05.4'

>>> Failed to emerge app-office/qownnotes-16.05.4, Log file:

>>>  '/var/tmp/portage/app-office/qownnotes-16.05.4/temp/build.log'

 * Messages for package app-office/qownnotes-16.05.4:

 * Running qmake has failed! (see above for details)
 * This shouldn't happen - please send a bug report to https://bugs.gentoo.org/
 * ERROR: app-office/qownnotes-16.05.4::qownnotes-overlay failed (compile phase):
 *   eqmake5 failed
 * 
 * Call stack:
 *     ebuild.sh, line  133:  Called src_compile
 *   environment, line 2082:  Called eqmake5 'QOwnNotes.pro' '-r'
 *   environment, line  862:  Called die
 * The specific snippet of code:
 *           die "eqmake5 failed";
 * 
 * If you need support, post the output of `emerge --info '=app-office/qownnotes-16.05.4::qownnotes-overlay'`,
 * the complete build log and the output of `emerge -pqv '=app-office/qownnotes-16.05.4::qownnotes-overlay'`.
 * The complete build log is located at '/var/tmp/portage/app-office/qownnotes-16.05.4/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/app-office/qownnotes-16.05.4/temp/environment'.
 * Working directory: '/var/tmp/portage/app-office/qownnotes-16.05.4/work/qownnotes-16.05.4'
 * S: '/var/tmp/portage/app-office/qownnotes-16.05.4/work/qownnotes-16.05.4'

@pbek

This comment has been minimized.

Owner

pbek commented May 6, 2016

Thank you for your report!

I tested it myself and I let an other party test it and it worked both times so it seems we already had the Qt QML package installed.

QML should come with dev-qt/qtdeclarative from https://github.com/pbek/qownnotes-overlay/blob/master/app-office/qownnotes/qownnotes-16.05.4.ebuild.

Do you have any idea what package should do the trick?

@jolenzy

This comment has been minimized.

jolenzy commented May 7, 2016

Thanks for quick reply! So, I do already have installed dev-qt/qtdeclarative. I'm still trying to figure our what's the problem.

@jolenzy

This comment has been minimized.

jolenzy commented May 7, 2016

Solved it. Installing dev-qt/qtxml solved the problem. So I would say that it's necessary to add dev-qt/qtxml:5 as dependency in the ebuild.

@pbek

This comment has been minimized.

Owner

pbek commented May 7, 2016

Thanks a lot for finding out! I will add it to my ebuild release template! Have a wonderful weekend!

@pbek

This comment has been minimized.

Owner

pbek commented May 7, 2016

The ebuild file should now be fixed. Thanks again!

@jolenzy

This comment has been minimized.

jolenzy commented May 7, 2016

Great. Cheers ;)

@jolenzy jolenzy closed this May 7, 2016

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment