New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Feature-Request: Show warnings on outdated QOwnNotesAPI version #564

Closed
jd666 opened this Issue Apr 17, 2017 · 3 comments

Comments

Projects
None yet
2 participants
@jd666

jd666 commented Apr 17, 2017

Expected behaviour

When the necessary QOwnNotesAPI server extensions is outdated a warning message should pop up. (Maybe not for every release, but when it is two major versions behind)

Possible Bonus: check the owncloud/nextcloud server version as well ?

Actual behaviour

No warning. (excellent for backwards compatibility though)

Steps to reproduce

Leave server side QOwnNotesAPI on ancient version.

Output from the debug settings

Just lists the version.

Relevant log output (you have to enable enable the log widget)

@pbek pbek added the enhancement label Apr 17, 2017

@pbek

This comment has been minimized.

Owner

pbek commented Apr 17, 2017

Thank you for your suggestion.

@pbek

This comment has been minimized.

Owner

pbek commented Apr 30, 2017

17.05.0

  • if the version of your QOwnNotesAPI app on your ownCloud / Nextcloud server
    is too low a warning will now be shown when the app starts

@pbek pbek added this to the 17.05.0 milestone Apr 30, 2017

@pbek

This comment has been minimized.

Owner

pbek commented Apr 30, 2017

I guess you have already updated your app so you will not be able to test it...

@pbek pbek closed this Apr 30, 2017

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment