Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with
or
.
Download ZIP
Continuous Integration server
Ruby
Pull request Compare This branch is even with integrity:0.1.X.

Fetching latest commit…

Cannot retrieve the latest commit at this time

Failed to load latest commit information.
bin
config
lib
public
test
views
.gitignore
AUTHORS
CHANGES
LICENSE
README.md
Rakefile
integrity.gemspec

README.md

Integrity

Integrity is your friendly automated Continuous Integration server.

  • See our website for documentation and a live demo
  • Report bugs and submit features request on our Lighthouse account
  • Join us on #integrity for ideas, help, patches or something
  • Get the code on GitHub

Run the test suite

  1. Ensure you have gems.github.com in your gem sources: gem sources -a http://gems.github.com
  2. Install the runtime and development dependencies: gem build integrity.gemspec && gem install *.gem --development.
  3. Run the test suite: rake test

Why we don't require "rubygems"

We decided to leave that choice up to the user. For more information, please see Why "require 'rubygems'" In Your Library/App/Tests Is Wrong by Ryan Tomayko.

Something went wrong with that request. Please try again.