New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

ssa output subs don't include linebreaks #692

Closed
jdragojevic opened this Issue Jul 15, 2013 · 9 comments

Comments

Projects
None yet
4 participants
@jdragojevic
Contributor

jdragojevic commented Jul 15, 2013

Download multi-line subtitles in ssa format.

Resulting output subtitles do not include linebreaks and the lines are squashed together.

Ex:

upload srt:

99:59:59,999 --> 99:59:59,999
this is line 1
this is line 2

output ssa:
Dialogue: 0,9:59:59.99,9:59:59.99,Default,,0000,0000,0000,,this is line 1this is line 2

Recognized linebreak tag for ssa is \n. See http://aegisub.cellosoft.com/docs/ASS_Tags

@bendk

This comment has been minimized.

Member

bendk commented Jul 15, 2013

We may want to consider using "\N" for linebreaks. I think the difference is that "\N" will force a linebreak under some circumstances where "\n" won't.

@franontanaya

This comment has been minimized.

Contributor

franontanaya commented Apr 18, 2018

Bumping this due to the inquiry about Advanced Sub Station Alpha support. The line break needed is literal \N with capital N. \n won't work or it'll be mistaken with the line break control character.

@bendk bendk self-assigned this Apr 18, 2018

@bendk bendk added this to the Sprint 37 milestone Apr 18, 2018

bendk added a commit that referenced this issue Apr 18, 2018

@bendk

This comment has been minimized.

Member

bendk commented Apr 18, 2018

This was a really simple fix, I tested with VLC and the newlines work. I'm just going to push it directly to dev. It'll get to staging/production with our next deploy.

@PCF-Testing

This comment has been minimized.

Member

PCF-Testing commented Apr 19, 2018

I don't see this work either on dev or on staging. Tested by downloading and checking SSA subtitles from:
https://dev.amara.org/en/videos/WHxkeEcrDUeS/en/8/
https://staging.amara.org/en/videos/39Bt6wdBpRXD/en/813206/

The downloaded subtitles don't have line break symbols in them.

@bendk

This comment has been minimized.

Member

bendk commented Apr 19, 2018

I only deployed to dev, and the build failed there because of the DB issue. I think it should be working now, I just tested with that link on staging and it looked good to me.

@PCF-Testing

This comment has been minimized.

Member

PCF-Testing commented Apr 20, 2018

Confirming SSA files are downloadable with \N separator for like breaks.

Uploading subtitles from SSA files, however, does not honor the separator. Subtitles are uploaded as shown on the screenshot below:

screenshot from 2018-04-20 03 24 25

Will we fix that as well?

@bendk

This comment has been minimized.

Member

bendk commented Apr 24, 2018

Just implemented this one. Since it was less urgent I made a branch this time -- gh-692.

@PCF-Testing

This comment has been minimized.

Member

PCF-Testing commented Apr 25, 2018

Verified.

asabine added a commit that referenced this issue Apr 25, 2018

@PCF-Testing

This comment has been minimized.

Member

PCF-Testing commented May 3, 2018

Deployed.

@PCF-Testing PCF-Testing closed this May 3, 2018

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment