Does not generate pdf if supplied with long url #144

Closed
bagwanpankaj opened this Issue Aug 1, 2012 · 1 comment

Projects

None yet

2 participants

@bagwanpankaj

Hi there,

PDF generation takes very long or say it does not generate pdf when supplied long url like

"/usr/bin/wkhtmltopdf" "--disable-external-links" "--disable-internal-links" "--page-size" "A4" "--margin-right" "18" "--margin-left" "18" "--margin-top" "20" "--margin-bottom" "18" "--page-width" "209.9" "--page-height" "297" "--orientation" "portrait" "--header-html" "/xxx/public/assets/report_header.html" "--footer-html" "/xxxn/public/assets/report_footer.html" "--quiet" "http://localhost:3000/reports?utf8=%E2%9C%93&risk_report%5Bs%5D=&risk_report%5Bstatus_id%5D=&risk_report%5Brisk_category%5D=&risk_report%5Brisk_category_id%5D=&risk_report%5Bminimum_risk_rating%5D=&risk_report%5Binherent_rating_level_operator%5D=gte&risk_report%5Binherent_rating_level%5D=&risk_report%5Brisk_context_operator%5D=siblings&risk_report%5Brisk_context_id%5D=&risk_report%5Brisk_level_id%5D=&risk_report%5Brisk_level_rollup%5D=0&risk_report%5Brisk_context_operator%5D=siblings&risk_report&print=true" "-"

I also tried directly running wkhtmltopdf from terminal but it breaks url into parts and tries them

wkhtmltopdf http://l:3000/reports?utf8=%E2%9C%93&risk_report%5Bs%5D=&risk_report%5Bstatus_id%5D=&risk_report%5Brisk_category%5D=&risk_report%5Brisk_category_id%5D=&risk_report%5Bminimum_risk_rating%5D=&risk_report%5Binherent_rating_level_operator%5D=gte&risk_report&print=true justlt.pdf
@sigmavirus24
Member

This seems like a bug in wkhtmltopdf and not PDFKit and has seen no activity from anyone else with the same problem. I'm closing until others come and report something similar.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment