Skip to content
Browse files

improve error messages about not being capable of running via phpunit…

…; fix references to non-existent v1.1.5 release;

git-svn-id: http://svn.php.net/repository/pear/packages/XML_Util/trunk@260127 c90b9560-bf6c-de11-be94-00142212c4b1
  • Loading branch information...
1 parent 5fffcf1 commit c57ab010cf1c9a725bf36d991e08526757f9212a Chuck Burgess committed May 22, 2008
Showing with 6 additions and 4 deletions.
  1. +6 −4 tests/AllTests.php
View
10 tests/AllTests.php
@@ -17,7 +17,7 @@
* @license http://www.opensource.org/licenses/bsd-license.php New BSD License
* @version CVS: $Id$
* @link http://pear.php.net/package/XML_Util
- * @since 1.1.5
+ * @since 1.2.0a1
*/
@@ -26,7 +26,9 @@
*/
if (version_compare(PHP_VERSION, "5.1.4") < 0) {
// Cannnot run test suites
- echo "Cannot run test suites... requires at least PHP v5.1.4.\n";
+ echo 'Cannot run test suite via PhpUnit... requires at least PHP v5.1.4.' . PHP_EOL;
+ echo 'Use "pear run-tests -p xml_util" to run the PHPT tests directly.' . PHP_EOL
+;
exit(1);
}
@@ -64,7 +66,7 @@
* This top-level test suite class organizes
* all class test suite files,
* so that the full suite can be run
- * by PhpUnit or via "pear run-tests -u".
+ * by PhpUnit or via "pear run-tests -up xml_util".
*
* @category XML
* @package XML_Util
@@ -73,7 +75,7 @@
* @license http://www.opensource.org/licenses/bsd-license.php New BSD License
* @version Release: @package_version@
* @link http://pear.php.net/package/XML_Util
- * @since 1.1.5
+ * @since 1.2.0a1
*/
class XML_Util_AllTests
{

0 comments on commit c57ab01

Please sign in to comment.
Something went wrong with that request. Please try again.