Compatibility with PHP 5.3.2+. #23

Merged
merged 1 commit into from Aug 12, 2012

2 participants

@boenrobot
PEAR2 member

First stop, I'm sorry for this whole sequence of unfortunate oversights. I'm probably being a burden or something.

Although #22 worked with 5.4.4 on my copy, it doesn't work on the site (as in, the links are never displayed for any package). The README says PHP 5.3.2+ is required. I tried the site on my copy with 5.3.2, and indeed it didn't worked. This fixes this... assuming the site uses 5.3.2.

I don't know what else could possibly go wrong, but I'm starting to think that, by Murphy's law, if there is such a thing, it will go wrong :-D .

NOTE: You may have to clear the Cache_Lite cache.

@saltybeagle saltybeagle merged commit 2e43235 into pear2:master Aug 12, 2012
@saltybeagle
PEAR2 member

Well, here's the fundamental issue: we're using 5.3.7, but openssl is not compiled in.

If I could find where it was built from before, I'd just enable ssl and re-install, but I'm not having luck finding where @cweiske installed it from.

Upgrading will take quite a bit of time to test, since this server runs pear.php.net, pear2 etc etc.

@saltybeagle
PEAR2 member

Nevermind, I found it at /usr/local/src/php-5.3.6 things appear to be working now.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment