Permalink
Browse files

use release plugin now

  • Loading branch information...
1 parent 50536b5 commit 569c42699c63269d6c5a1489c87f89bf22a24866 Predrag Knezevic committed May 23, 2011
Showing with 36 additions and 9 deletions.
  1. +25 −0 .classpath
  2. +1 −1 .project
  3. +1 −3 ForceResponseDownloadGrailsPlugin.groovy
  4. +5 −3 application.properties
  5. +4 −2 grails-app/conf/BuildConfig.groovy
View
25 .classpath
@@ -12,6 +12,31 @@
<classpathentry kind="src" path="test/unit"/>
<classpathentry kind="con" path="org.eclipse.jdt.launching.JRE_CONTAINER"/>
<classpathentry kind="con" path="com.springsource.sts.grails.core.CLASSPATH_CONTAINER"/>
+ <classpathentry excluding="BuildConfig.groovy|*DataSource.groovy|UrlMappings.groovy|Config.groovy|BootStrap.groovy|spring/resources.groovy" kind="src" path=".link_to_grails_plugins/svn-1.0.0.M1/grails-app/conf">
+ <attributes>
+ <attribute name="com.springsource.sts.grails.core.SOURCE_FOLDER" value="true"/>
+ </attributes>
+ </classpathentry>
+ <classpathentry kind="src" path=".link_to_grails_plugins/svn-1.0.0.M1/src/groovy">
+ <attributes>
+ <attribute name="com.springsource.sts.grails.core.SOURCE_FOLDER" value="true"/>
+ </attributes>
+ </classpathentry>
+ <classpathentry kind="src" path=".link_to_grails_plugins/tomcat-1.3.7/src/groovy">
+ <attributes>
+ <attribute name="com.springsource.sts.grails.core.SOURCE_FOLDER" value="true"/>
+ </attributes>
+ </classpathentry>
+ <classpathentry kind="src" path=".link_to_grails_plugins/release-1.0.0.M2/src/java">
+ <attributes>
+ <attribute name="com.springsource.sts.grails.core.SOURCE_FOLDER" value="true"/>
+ </attributes>
+ </classpathentry>
+ <classpathentry kind="src" path=".link_to_grails_plugins/release-1.0.0.M2/src/groovy">
+ <attributes>
+ <attribute name="com.springsource.sts.grails.core.SOURCE_FOLDER" value="true"/>
+ </attributes>
+ </classpathentry>
<classpathentry kind="src" path=".link_to_grails_plugins/browser-detection-0.1/grails-app/taglib">
<attributes>
<attribute name="com.springsource.sts.grails.core.SOURCE_FOLDER" value="true"/>
View
2 .project
@@ -26,7 +26,7 @@
<link>
<name>.link_to_grails_plugins</name>
<type>2</type>
- <locationURI>GRAILS_ROOT/1.3.5/projects/grails-force-response-download/plugins</locationURI>
+ <locationURI>GRAILS_ROOT/1.3.7/projects/grails-force-response-download/plugins</locationURI>
</link>
</linkedResources>
</projectDescription>
View
4 ForceResponseDownloadGrailsPlugin.groovy
@@ -4,8 +4,6 @@ class ForceResponseDownloadGrailsPlugin {
// the version or versions of Grails the plugin is designed for
def grailsVersion = "1.1 > *"
// the other plugins this plugin depends on
- // the plugin depends on browser-detection plugin, but if I specify it here, grails looks for browserdetection plugin (removes '-')
- // and it does not find it. Thus, only dependency in BuildConfig remains...
def dependsOn = ["browserDetection":'0.1']
// resources that are excluded from plugin packaging
def pluginExcludes = [
@@ -20,7 +18,7 @@ class ForceResponseDownloadGrailsPlugin {
def license = "APACHE"
- def scm = "http://github.com/pedjak/grails-force-response-download"
+ def scm = [url: "http://github.com/pedjak/grails-force-response-download"]
def description = '''\\
The plugin forces browser to open a dialog for downloading content produced within controller's action.
View
8 application.properties
@@ -1,5 +1,7 @@
#Grails Metadata file
-#Mon May 16 13:52:28 CEST 2011
+#Mon May 23 11:47:50 CEST 2011
app.grails.version=1.3.7
-app.name=force-response-download
-plugins.release=1.0.0.M1
+app.name=force-response-download-plugin
+plugins.hibernate=1.3.7
+plugins.release=1.0.0.M2
+plugins.tomcat=1.3.7
View
6 grails-app/conf/BuildConfig.groovy
@@ -17,7 +17,7 @@ grails.project.dependency.resolution = {
// uncomment the below to enable remote dependency resolution
// from public Maven repositories
//mavenLocal()
- //mavenCentral()
+ mavenCentral()
//mavenRepo "http://snapshots.repository.codehaus.org"
//mavenRepo "http://repository.codehaus.org"
//mavenRepo "http://download.java.net/maven/2/"
@@ -33,5 +33,7 @@ grails.project.dependency.resolution = {
// runtime 'mysql:mysql-connector-java:5.1.13'
}
- grails.release.scm.enabled = false
+
}
+
+grails.release.scm.enabled = false

0 comments on commit 569c426

Please sign in to comment.