New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Adicionados novos códigos de serviço #229

Merged
merged 2 commits into from May 6, 2017

Conversation

Projects
None yet
7 participants
@rafaelpatro
Contributor

rafaelpatro commented May 5, 2017

  • Adicionados os códigos de serviço 04510 e 04014
  • Adicionadas regras de validação para os novos códigos, e para outros códigos que estavam sem regras.

Closes #227, closes #228

@rfbastos

This comment has been minimized.

rfbastos commented May 5, 2017

Essa correção já está na Master ?

@rafaelpatro

This comment has been minimized.

Contributor

rafaelpatro commented May 5, 2017

Não. Ainda não está no branch master.
Por enquanto, para testar basta baixar os arquivos do master. Não acesse a loja, para não executar o upgrade. Aplique o patch, e então pode acessar a loja.

@luizgt5

This comment has been minimized.

luizgt5 commented May 5, 2017

Apliquei a correção mas ainda continua o erro do LOG e sem aparecer o frete. O que pode ser?

@rafaelpatro

This comment has been minimized.

Contributor

rafaelpatro commented May 5, 2017

@rfbastos

This comment has been minimized.

rfbastos commented May 5, 2017

@rafaelpatro a versão que rodo no meu cliente é mais antiga, eu fiz uma correção temporária sugerida em outro tópico.

Você acha que o melhor a fazer é remover todo o módulo e colocar a versão 4.8 quando o Pedro fechar a release?

@luizgt5

This comment has been minimized.

luizgt5 commented May 5, 2017

@rafaelpatro Fiz os seguintes passos:

Possuía uma versão mais antiga. Achei que já havia liberado e coloquei a 4.8.0 só que antes de aplicar o patch tentei verificar se estava funcionando. Logo depois instalei o patch e sem sucesso. Recomenda voltar para a versão que estava e aplicar a correção temporária?

@rafaelpatro

This comment has been minimized.

Contributor

rafaelpatro commented May 5, 2017

@lmarquine

This comment has been minimized.

lmarquine commented May 6, 2017

Sempre será necessário essa autenticação, porque nunca pedi acesso ao Sigep

@rfbastos

This comment has been minimized.

rfbastos commented May 6, 2017

Com essa correção, caso eu seja um usuário comum sem contrato, consequentemente sem sigep. Vai funcionar?

@rafaelpatro

This comment has been minimized.

Contributor

rafaelpatro commented May 6, 2017

Se a loja usar algum dos serviços padrão, sim, vai funcionar.

Senão terá que adicionar os serviços que vc usa na tabela correios_postmethods. É mais complicado, mas tb funcionará perfeitamente.

@pedro-teixeira pedro-teixeira added this to the v4.8.0 milestone May 6, 2017

@rafaelpatro

This comment has been minimized.

Contributor

rafaelpatro commented May 6, 2017

@lmarquine, a autenticação é necessária para baixar os serviços disponíveis para seu contrato.
Masssss se vc já sabe o código de cada um dos seus serviços, pode cadastrá-los na tabela correios_postmethods, que vai funcionar também.

@pedro-teixeira pedro-teixeira merged commit ec82e99 into pedro-teixeira:master May 6, 2017

1 check passed

continuous-integration/travis-ci/pr The Travis CI build passed
Details
@pedro-teixeira

This comment has been minimized.

Owner

pedro-teixeira commented May 6, 2017

@rafaelpatro acha que ja está estável suficiente para fazer o release?

@rafaelpatro

This comment has been minimized.

Contributor

rafaelpatro commented May 6, 2017

Boa noite @pedro-teixeira

Segue alguns possíveis problemas:

  • Lojas sem contrato não estão conseguindo os códigos (Ok, resolvido!)
  • Lojas com contrato não tem acesso ao SIGEP (Solução: Cadastrar mais códigos de serviços na tabela)
  • Quem teve alteração no contrato; e, respectivamente nos códigos de serviço; e usa Serviços por Produto, precisará ajustar os produtos (Solução: Descobrir as alterações, e reajustar os produtos durante a atualização).

Os Correios criaram novos serviços, e excluíram outros, sem aviso prévio.
Enfim devido ao susto de hoje, acho que um release será muito bem vindo.

@lmarquine

This comment has been minimized.

lmarquine commented May 6, 2017

O que pode ser o erro "Valor de compra fora do permitido pelos Correios. Por favor entre em contato conosco."?

@rafaelpatro

This comment has been minimized.

Contributor

rafaelpatro commented May 6, 2017

O limite de valor de mercadoria dos Correios é 10 mil no PAC. Outros serviços é diferente.

@rafaelpatro

This comment has been minimized.

Contributor

rafaelpatro commented May 6, 2017

Se não me engano SEDEX é 3 mil

@lmarquine

This comment has been minimized.

lmarquine commented May 6, 2017

Mas Rafael no teste deu R$ 73,80

@rafaelpatro

This comment has been minimized.

Contributor

rafaelpatro commented May 6, 2017

Certeza que configurou o código de serviço correto?

@rafaelpatro

This comment has been minimized.

Contributor

rafaelpatro commented May 6, 2017

@lmarquine

This comment has been minimized.

lmarquine commented May 6, 2017

@rafaelpatro você é o cara, nem precisei testar, eu refiz todo o procedimento que você passou desde o inicio, mexi nas tabelas como colocou, limpei o cache e funcionou, sem palavras para te agradecer, muito obrigado pela atenção...

@rfbastos

This comment has been minimized.

rfbastos commented May 6, 2017

Como o @pedro-teixeira já apareceu aí hoje estamos na torcida pra que ele atualize e gere um release para nossa alegria!

@lmarquine

This comment has been minimized.

lmarquine commented May 6, 2017

@rfbastos Para mim funcionou, não deu certo com você? Comigo tava dando erro então refiz todo o procedimento e funcionou, eu não sou ninja igual o Pedro e o Rafael, muitos anos luz distante disso rs mas se puder ajudar.

@rfbastos

This comment has been minimized.

rfbastos commented May 6, 2017

Então, não tinha dado, eu acabei seguindo uma sugestão em outra issue, Q resolveu temporariamente. Mas amanhã vou refazer o processo para ver.

Hoje eu só queria agradecer aos correios por o que nos fez passar. Kkkk

Brincadeiras a parte, Grato mesmo ao @rafaelpatro pelo esforço e colaboração.

@lmarquine

This comment has been minimized.

lmarquine commented May 6, 2017

@rfbastos Correios, como posso te atrapalhar hoje? Rs

@rafaelpatro rafaelpatro deleted the rafaelpatro:bugfix_new_codes branch May 6, 2017

@lmarquine lmarquine referenced this pull request May 8, 2017

Closed

Modulo parou de funcionar #231

@wiranunes

This comment has been minimized.

wiranunes commented May 8, 2017

Pessoal, Boa tarde!
Sou um pouco leigo na questão e se puderem me ajudar eu agradeço de coração
Tentei ler algumas soluções aqui mas não sei se obtive sucesso

Erro: Aparece a seguinte mensagem:

Não Há Meio de Envio disponível, entre em contato com a loja.

~> Não utilizo contrato com os Correios
~> Eu tenho a versão instalada 4.7.2
~> Vi que o pessoal estava com um erro similar e o Módulo não estava funcionando :(

Dúvidas?
Como eu faço a desinstalação e atualizo para a última versão com uma instalação limpa? Preciso excluir alguma tabela no PHPMyAdmin?

Aguardo resposta

@rafaelpatro

This comment has been minimized.

Contributor

rafaelpatro commented May 8, 2017

Então @wiranunes, sugiro que atualize o módulo, ao invés de instalar uma versão limpa. Se sua loja é nova (nunca instalou o módulo), então sua instalação será limpa. Mas o Magento 1 não tem suporte para desinstalação. Então os campos que o módulo instala poderão ficar duplicados, numa possível reinstalação.

Para atualizar, siga este passo-a-passo.

@wiranunes

This comment has been minimized.

wiranunes commented May 8, 2017

@rafaelpatro desculpe a ignorância mas sou um pouquinho lerdo no assunto rsrs
Eu verifiquei as tabelas do MySQL e estava a versão 4.8.0
Quando você diz "branch master" significa que devo baixar os arquivos onde? :(
A tabela correios_postmethods eu limpei com Truncate é isso?
Onde eu altero esse número que você diz para versão? 4.8.0 para 4.7.0?

desculpe e ignorância novamente :(

@wiranunes

This comment has been minimized.

wiranunes commented May 8, 2017

@rafaelpatro
Não dá para excluir todos os arquivos e fazer uma instalação do zero?

Obrigado pelo suporte e agradeço o Add-On

@rafaelpatro

This comment has been minimized.

Contributor

rafaelpatro commented May 8, 2017

Sim, pode fazer isso. Mas só esclarecendo, isso não seria instalar do zero.
Mas antes de atualizar, na tabela core_resource, altere a versão do módulo para 4.7.0

@wiranunes

This comment has been minimized.

wiranunes commented May 8, 2017

Eu cliquei em Download Zip isso é o branch master?
Pior que quando vi o problema eu baixei os arquivos e subi, tem algum problema? Pois acho que atualizei tudo antes de fazer esse procedimento da tabela
Para alterar a versão do módulo qual seria a varchar correta? precisa selecionar alguma opção para fazer as alterações corretas?

@fabiogonsilva

This comment has been minimized.

fabiogonsilva commented May 16, 2017

Boa Tarde,
Como faço para aplicar o PAC e Sedex a todos os produtos via BD?
Depois de removido a v. 4.7.2 e instalado a 4.8.0, estou tendo que ir produto por produto, "Correios" => "Serviços de Entrega" => Selecionando PAC e Sedex e Salvar
Mesmo tendo limpado o Cache, Indexado e já fui em Sistema=>Configuração=>Formas de Entrega=> Selecionado PAC e Sedex

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment