Permalink
Browse files

chore: update dependencies

  • Loading branch information...
pedronauck committed Dec 26, 2018
1 parent cef3cc4 commit 1329ab7478226eb3cbd8ba593be9b88f8c5d02c8
@@ -10,8 +10,8 @@
"@emotion/core": "^10.0.5",
"@emotion/styled": "^10.0.5",
"prop-types": "^15.6.2",
"react": "^16.6.3",
"react-dom": "^16.6.3"
"react": "^16.7.0",
"react-dom": "^16.7.0"
},
"devDependencies": {
"babel-plugin-emotion": "^10.0.5",
@@ -10,8 +10,8 @@
"@emotion/core": "^10.0.5",
"@emotion/styled": "^10.0.5",
"prop-types": "^15.6.2",
"react": "^16.6.3",
"react-dom": "^16.6.3"
"react": "^16.7.0",
"react-dom": "^16.7.0"
},
"devDependencies": {
"@babel/preset-flow": "^7.0.0",
@@ -8,10 +8,10 @@
},
"dependencies": {
"prop-types": "^15.6.2",
"react": "^16.6.3",
"react-art": "^16.6.3",
"react-dom": "^16.6.3",
"react-native-web": "^0.9.9",
"react": "^16.7.0",
"react-art": "^16.7.0",
"react-dom": "^16.7.0",
"react-native-web": "^0.9.10",
"styled-components": "^4.1.3"
},
"devDependencies": {
@@ -8,8 +8,8 @@
},
"dependencies": {
"prop-types": "^15.6.2",
"react": "^16.6.3",
"react-dom": "^16.6.3",
"react": "^16.7.0",
"react-dom": "^16.7.0",
"styled-components": "^4.1.3"
},
"devDependencies": {
@@ -11,8 +11,8 @@
"@emotion/styled": "^10.0.5",
"docz": "^0.13.5",
"docz-core": "^0.13.5",
"react": "^16.6.3",
"react-dom": "^16.6.3"
"react": "^16.7.0",
"react-dom": "^16.7.0"
},
"devDependencies": {
"babel-plugin-emotion": "^10.0.5"
@@ -23,13 +23,13 @@
},
"dependencies": {
"@babel/core": "7.2.2",
"@babel/plugin-proposal-class-properties": "7.2.1",
"@babel/plugin-proposal-class-properties": "7.2.3",
"@babel/plugin-proposal-object-rest-spread": "7.2.0",
"@babel/plugin-syntax-dynamic-import": "7.2.0",
"@babel/plugin-transform-destructuring": "7.2.0",
"@babel/plugin-transform-regenerator": "7.0.0",
"@babel/plugin-transform-runtime": "7.2.0",
"@babel/preset-env": "7.2.0",
"@babel/preset-env": "7.2.3",
"@babel/preset-flow": "7.0.0",
"@babel/preset-react": "7.0.0",
"@babel/preset-typescript": "7.1.0",
@@ -23,7 +23,7 @@
},
"dependencies": {
"@babel/core": "7.2.2",
"@babel/polyfill": "7.0.0",
"@babel/polyfill": "7.2.5",
"@babel/runtime": "^7.2.0",
"@mdx-js/loader": "^0.16.6",
"@mdx-js/mdx": "^0.16.6",
@@ -34,7 +34,7 @@
"babel-loader": "^8.0.2",
"babel-preset-docz": "^0.13.5",
"babylon": "^6.18.0",
"cache-loader": "^1.2.5",
"cache-loader": "^2.0.0",
"chalk": "^2.4.1",
"chokidar": "^2.0.4",
"common-tags": "^1.8.0",
@@ -43,15 +43,15 @@
"detect-port": "^1.3.0",
"docz-utils": "^0.13.5",
"dotenv": "^6.2.0",
"env-dot-prop": "^1.1.0",
"env-dot-prop": "^2.0.1",
"express": "^4.16.4",
"fast-deep-equal": "^2.0.1",
"fast-glob": "^2.2.4",
"file-loader": "^2.0.0",
"file-loader": "^3.0.1",
"find-up": "^3.0.0",
"friendly-errors-webpack-plugin": "^1.7.0",
"fs-extra": "^7.0.1",
"get-pkg-repo": "^4.0.2",
"get-pkg-repo": "^4.1.0",
"happypack": "^5.0.0",
"html-minifier": "^3.5.21",
"humanize-string": "^1.0.2",
@@ -61,7 +61,7 @@
"mini-html-webpack-plugin": "^0.2.3",
"p-reduce": "^1.0.0",
"progress-estimator": "^0.2.2",
"react-dev-utils": "^6.1.1",
"react-dev-utils": "^7.0.0",
"react-docgen-typescript-loader": "^3.0.0-rc.0",
"react-hot-loader": "^4.6.3",
"rehype-docz": "^0.13.5",
@@ -72,17 +72,24 @@
"resolve": "^1.9.0",
"signale": "^1.3.0",
"source-map-loader": "^0.2.4",
"terser-webpack-plugin": "^1.1.0",
"terser-webpack-plugin": "^1.2.0",
"titleize": "^1.0.1",
"url-loader": "^1.1.2",
"webpack": "^4.28.0",
"webpack": "^4.28.2",
"webpack-bundle-analyzer": "^3.0.3",
"webpack-chain": "^5.0.1",
"webpack-dev-server": "^3.1.10",
"webpack-dev-server": "^3.1.14",
"webpack-hot-client": "^4.1.1",
"webpack-manifest-plugin": "^2.0.4",
"webpackbar": "^3.1.4",
"ws": "^6.1.2",
"yargs": "^12.0.5"
},
"devDependencies": {
"@types/node": "^10.12.18",
"@types/react": "^16.7.18",
"@types/webpack": "^4.4.22",
"@types/yargs": "^12.0.4",
"lerna": "3.8.0"
}
}
@@ -40,8 +40,6 @@ export const loadConfig = async (args: Config): Promise<Config> => {
: load<Config>('docz', defaultConfig)

const reduceAsync = Plugin.reduceFromPluginsAsync<Config>(config.plugins)
return omit<Config>(
toOmit,
await reduceAsync('setConfig', { ...config, paths })
)
const reduced = await reduceAsync('setConfig', { ...config, paths })
return omit<Config>(toOmit, reduced)
}
@@ -23,7 +23,7 @@
"dependencies": {
"@emotion/core": "^10.0.5",
"@emotion/styled": "^10.0.5",
"codemirror": "^5.42.0",
"codemirror": "^5.42.2",
"copy-text-to-clipboard": "^1.0.4",
"docz": "^0.13.5",
"emotion-theming": "^10.0.5",
@@ -36,10 +36,10 @@
"prop-types": "15.6.2",
"rc-tooltip": "^3.7.3",
"re-resizable": "^4.11.0",
"react": "^16.6.3",
"react": "^16.7.0",
"react-codemirror2": "^5.1.0",
"react-dom": "^16.6.3",
"react-feather": "^1.1.4",
"react-dom": "^16.7.0",
"react-feather": "^1.1.5",
"react-live": "^1.12.0",
"react-perfect-scrollbar": "^1.4.2",
"react-powerplug": "^1.0.0",
@@ -31,8 +31,8 @@
},
"dependencies": {
"@babel/generator": "^7.2.2",
"@babel/parser": "^7.2.2",
"@babel/traverse": "^7.2.2",
"@babel/parser": "^7.2.3",
"@babel/traverse": "^7.2.3",
"codesandboxer-fs": "^0.4.7",
"fs-extra": "^7.0.1",
"humanize-string": "^1.0.2",
@@ -37,8 +37,8 @@
"fast-deep-equal": "^2.0.1",
"lodash": "^4.17.11",
"prop-types": "^15.6.2",
"react": "^16.6.3",
"react-dom": "^16.6.3",
"react": "^16.7.0",
"react-dom": "^16.7.0",
"react-imported-component": "^5.2.4",
"react-router": "^4.3.1",
"react-router-dom": "^4.3.1",
Oops, something went wrong.

0 comments on commit 1329ab7

Please sign in to comment.