New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Revert to coffeescript 1.0.17. Version bump to 0.9.0. Closes #13 #14

Closed
wants to merge 4 commits into
base: master
from

Conversation

Projects
None yet
3 participants
@xet7

xet7 commented Feb 14, 2018

Revert to coffeescript 1.0.17.
Version bump to 0.9.0.
Closes #13

Revert to coffeescript 1.0.17.
Version bump to 0.9.0.
Closes #13
@mitar

This comment has been minimized.

Member

mitar commented Feb 14, 2018

Isn't this the same as version 0.7.0?

@xet7

This comment has been minimized.

xet7 commented Feb 14, 2018

@mitar

Yes, this reverts to 0.7.0 and adds downgraded dependency coffeescript to 1.0.17 so that this package works on Meteor 1.6.1.

@xet7

This comment has been minimized.

xet7 commented Feb 14, 2018

@mitar

Without downgraded dependency to coffeescript 1.0.17 etc it is not possible to upgrade Meteor projects to Meteor 1.6.1.

@mitar

This comment has been minimized.

Member

mitar commented Feb 14, 2018

Isn't version 0.7.0 of this package published with coffeescript 1.0.17 already?

@xet7

This comment has been minimized.

xet7 commented Feb 14, 2018

@mitar

No, version 0.7.0 does not specify coffeescript version, so it breaks upgrades.

@mitar

This comment has been minimized.

Member

mitar commented Feb 14, 2018

No, version 0.7.0 does not specify coffeescript version, so it breaks upgrades.

It does by specifying api.versionsFrom.

@xet7

This comment has been minimized.

xet7 commented Feb 14, 2018

@mitar

Specifying api.versionsFrom did not work. Version 0.7.0 is broken. Only specifying coffeescript version 1.0.17 separately fixed this.

@xet7

This comment has been minimized.

xet7 commented Feb 14, 2018

@mitar

Without this fix, everyone needs to manually monkey patch like at #13 (comment)

@mitar

This comment has been minimized.

Member

mitar commented Feb 14, 2018

Why version 1.0.17 and not 1.2.4 of CoffeeScript?

@xet7

This comment has been minimized.

xet7 commented Feb 14, 2018

@mitar

I have not tried 1.2.4 yet. Just a moment I try.

@xet7

This comment has been minimized.

xet7 commented Feb 14, 2018

Yes 1.2.4 works.

@xet7

This comment has been minimized.

xet7 commented Feb 14, 2018

Hmm, seems to still have errors:

This project is already at Meteor 1.6.1, the latest release.
=> Errors while upgrading packages:           
                                              
While selecting package versions:
error: Conflict: Constraint coffeescript@1.2.4 is not satisfied by coffeescript 1.0.17.
Constraints on package "coffeescript":
* coffeescript@1.0.5 <- peerlibrary:blaze-components 0.15.1
* coffeescript@1.0.5 <- peerlibrary:base-component 0.16.0 <- peerlibrary:blaze-components 0.15.1
* coffeescript@1.0.5 <- peerlibrary:reactive-field 0.3.0 <- peerlibrary:base-component 0.16.0 <-
peerlibrary:blaze-components 0.15.1
* coffeescript@1.0.5 <- peerlibrary:reactive-field 0.3.0 <- peerlibrary:blaze-components 0.15.1
* coffeescript@1.2.4 <- peerlibrary:computed-field 0.9.0
* coffeescript@1.0.4 <- softwarerero:accounts-t9n 1.3.11 <- useraccounts:core 1.14.2
* coffeescript@1.0.3 <- 3stack:presence 1.1.2
* coffeescript@1.0.5 <- alethes:pages 1.8.6
* coffeescript@1.0.4 <- arillo:flow-router-helpers 0.5.2
* coffeescript@1.0.4 <- zimme:active-route 2.3.2 <- arillo:flow-router-helpers 0.5.2
* coffeescript@1.0.4 <- tap:i18n 1.8.2
* coffeescript@1.0.4 <- templates:tabs 2.3.0
@xet7

This comment has been minimized.

xet7 commented Feb 14, 2018

Only 1.0.17 works:

$ meteor update
This project is already at Meteor 1.6.1, the latest release.
Your top-level dependencies are at their latest compatible versions.
                                              
The following top-level dependencies were not updated to the very latest version available:
 * aldeed:collection2 2.10.0 (3.0.0 is available)
 * matteodem:easy-search 1.6.4 (2.0.0 is available)
 * ongoworks:speakingurl 1.1.0 (9.0.0 is available)
 * peerlibrary:blaze-components 0.15.1 (0.22.0 is available)
                                              
Newer versions of the following indirect dependencies are available:
 * aldeed:collection2-core 1.2.0 (2.1.2 is available)
 * aldeed:schema-deny 1.1.0 (3.0.0 is available)
 * aldeed:schema-index 1.1.1 (3.0.0 is available)
 * coffeescript 1.0.17 (2.2.1_1 is available) 
 * peerlibrary:reactive-field 0.3.0 (0.4.0 is available)
 * softwarerero:accounts-t9n 1.3.11 (2.2.1 is available)
These versions may not be compatible with your project.
To update one or more of these packages to their latest
compatible versions, pass their names to `meteor update`,
or just run `meteor update --all-packages`.
@xet7

This comment has been minimized.

xet7 commented Feb 14, 2018

With this pull request Wekan works with Meteor 1.6.1, Node 8.9.4 and 5.6.0, as you can see from screenshot below. Wekan is used by single private persons to companies that have thousands of users. We really would like to get rid of all of monkey patches and contribute them upstream, so we don't have to fork so much packages. I did yesterday write blog post about benefits of contributing features and bugfixes to upstream https://blog.wekan.team/2018/02/benefits-of-contributing-your-features-to-upstream-wekan/index.html , like contributing features and bugfixes to Wekan. peerlibrary is upstream library that Wekan uses.

wekan-meteor-1 8 1

@xet7

This comment has been minimized.

xet7 commented Feb 14, 2018

@mitar

Is there still something to fix in this pull request? What prevents merging and releasing this?

@mitar

This comment has been minimized.

Member

mitar commented Feb 14, 2018

As you see from the list above:

* coffeescript@1.0.4 <- softwarerero:accounts-t9n 1.3.11 <- useraccounts:core 1.14.2
* coffeescript@1.0.3 <- 3stack:presence 1.1.2
* coffeescript@1.0.5 <- alethes:pages 1.8.6
* coffeescript@1.0.4 <- arillo:flow-router-helpers 0.5.2
* coffeescript@1.0.4 <- zimme:active-route 2.3.2 <- arillo:flow-router-helpers 0.5.2
* coffeescript@1.0.4 <- tap:i18n 1.8.2
* coffeescript@1.0.4 <- templates:tabs 2.3.0

These packages are forcing your whole app to be in 1.0 CoffeeScript. I would suggest you also send upstream patches to those packages to upgrade to at least 1.2. Then this 0.7.0 version will work.

@xet7

This comment has been minimized.

xet7 commented Feb 14, 2018

@mitar

Thanks! I'll send upstream patches.

@mitar

This comment has been minimized.

Member

mitar commented Feb 14, 2018

Can you list what versions of those packages I listed above you have in your app before you upgrade to Meteor 1.6.1?

@mitar

This comment has been minimized.

Member

mitar commented Feb 14, 2018

So what I do not understand is why having CoffeeScript 1.2 and 1.0 works in the same app before Meteor 1.6.1.

@xet7

This comment has been minimized.

xet7 commented Feb 14, 2018

@mitar

This comment has been minimized.

Member

mitar commented Feb 14, 2018

So what seems to happen is that after upgrade to Meteor 1.6.1 you can choose only between CoffeeScript 2, CoffeeScript 1.2 or CoffeeScript 1.0. Some packages are on 1.0 (listed above), this package 0.7.0 is on CoffeeScript 1.2 and 0.8.0 on CoffeeScript 2. Sadly, the CoffeeScript 1.0 version of this package is broken.

@xet7

This comment has been minimized.

xet7 commented Feb 14, 2018

@mitar

So could these all packages work with CoffeeScript 2 with some package upgrades?

@mitar

This comment has been minimized.

Member

mitar commented Feb 14, 2018

Ehm, in versions you linked above, you have coffeescript@1.12.7_3. This is even newer than 1.2.4 for which this package 0.7.0 was released. So why you cannot keep coffeescript@1.12.7_3 when upgrading to Meteor 1.6.1?

@xet7

This comment has been minimized.

xet7 commented Feb 14, 2018

@mitar

Just a moment I try.

@mitar

This comment has been minimized.

Member

mitar commented Feb 14, 2018

So could these all packages work with CoffeeScript 2 with some package upgrades?

That is a separate process all of packages using CoffeeScript in Meteor will eventually have to do. I have updated many of my own packages (including this one) to CoffeeScript 2 because some users are already using that.

But yes, that would also solve a problem you are having, if everyone just upgrade to CoffeeScript 2.

@xet7

This comment has been minimized.

xet7 commented Feb 14, 2018

@mitar

Ok, I'll all pull requests for upgrades to CoffeeScript 2, it's a better solution.

@xet7 xet7 closed this Feb 14, 2018

@mahmost

This comment has been minimized.

mahmost commented Feb 14, 2018

I Agree that the CoffeeScript 2 upgrade is the better long term choice .. I also think that maintaining a 0.7.1 version with this change 1.0.17 is not bad .. just to keep things working with meteor 1.6.1 for now ..

And for the tests to pass .. I think adding package constraint to line 35 in package.js will do the trick

@xet7

This comment has been minimized.

xet7 commented Feb 14, 2018

@mahmost

Downgrading to old package is still monkey patching to probably broken versions, and that's already possible. I would like to upgrade all packages instead.

@xet7 xet7 reopened this Feb 14, 2018

@xet7

This comment has been minimized.

xet7 commented Feb 14, 2018

@mitar

Can you release this as v0.7.1 ? I tried to upgrade all dependencies, but got lost in the process.

@xet7

This comment has been minimized.

xet7 commented Feb 14, 2018

@mitar

It seems that with these dependencies it's not possible to use coffeescript@1.12.7_3, it downgrades to 1.0.17 anyway.

@xet7

This comment has been minimized.

xet7 commented Feb 14, 2018

Sadly, the CoffeeScript 1.0 version of this package is broken.

Ok.

@xet7 xet7 closed this Feb 14, 2018

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment