Skip to content
This repository

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP
Browse code

Simplecov added

  • Loading branch information...
commit 54707ea15651d0aba1cef8c29a553b4a2eafcafa 1 parent 749e702
Jose Peleteiro authored October 23, 2010
12  .gitignore
... ...
@@ -1,3 +1,11 @@
1  
-pkg/*
2  
-*.gem
  1
+.DS_Store
  2
+.idea
3 3
 .bundle
  4
+*~
  5
+#*
  6
+*.gem
  7
+.yardoc/*
  8
+coverage/*
  9
+doc/*
  10
+pkg/*
  11
+
7  Gemfile.lock
@@ -2,14 +2,19 @@ PATH
2 2
   remote: .
3 3
   specs:
4 4
     ruby-duration (0.5.0)
  5
+      i18n
5 6
 
6 7
 GEM
7 8
   remote: http://rubygems.org/
8 9
   specs:
9 10
     activesupport (3.0.1)
  11
+    bluecloth (2.0.9)
10 12
     i18n (0.4.1)
11 13
     minitest (1.7.2)
12 14
     rake (0.8.7)
  15
+    simplecov (0.3.6)
  16
+      simplecov-html (>= 0.3.7)
  17
+    simplecov-html (0.3.8)
13 18
     yard (0.6.1)
14 19
 
15 20
 PLATFORMS
@@ -17,9 +22,11 @@ PLATFORMS
17 22
 
18 23
 DEPENDENCIES
19 24
   activesupport (>= 3.0.0)
  25
+  bluecloth (>= 0.3.5)
20 26
   bundler (>= 1.0.0)
21 27
   i18n
22 28
   minitest
23 29
   rake
24 30
   ruby-duration!
  31
+  simplecov (>= 0.3.5)
25 32
   yard
5  ruby-duration.gemspec
@@ -14,12 +14,15 @@ Gem::Specification.new do |s|
14 14
   s.required_rubygems_version = ">= 1.3.6"
15 15
   s.rubyforge_project         = "ruby-duration"
16 16
 
  17
+  s.add_dependency "i18n", ">= 0"
  18
+
17 19
   s.add_development_dependency "bundler", ">= 1.0.0"
18 20
   s.add_development_dependency "minitest", ">= 0"
19 21
   s.add_development_dependency "yard", ">= 0"
20 22
   s.add_development_dependency "rake", ">= 0"
21 23
   s.add_development_dependency "activesupport", ">= 3.0.0"
22  
-  s.add_development_dependency "i18n", ">= 0"
  24
+  s.add_development_dependency "simplecov", ">= 0.3.5"
  25
+  s.add_development_dependency "bluecloth", ">= 0.3.5"
23 26
 
24 27
   s.files        = `git ls-files`.split("\n")
25 28
   s.executables  = `git ls-files`.split("\n").map{|f| f =~ /^bin\/(.*)/ ? $1 : nil}.compact
6  test/helper.rb
... ...
@@ -1,6 +1,12 @@
1 1
 # -*- encoding:  utf-8 -*-
2 2
 require 'rubygems'
3 3
 require 'minitest/spec'
  4
+begin
  5
+  require 'simplecov'
  6
+  SimpleCov.start do
  7
+  end
  8
+rescue LoadError
  9
+end
4 10
 
5 11
 $LOAD_PATH.unshift(File.dirname(__FILE__))
6 12
 $LOAD_PATH.unshift(File.join(File.dirname(__FILE__), '..', 'lib'))

0 notes on commit 54707ea

Please sign in to comment.
Something went wrong with that request. Please try again.