Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with
or
.
Download ZIP
Browse files

cleaned up the loading of the plugin

  • Loading branch information...
commit cade84b8fee806cbf80aace5e2c65596945b3fc2 1 parent bfedccf
@pelle authored
View
9 lib/oauth-plugin.rb
@@ -1,9 +1,14 @@
require 'oauth'
require 'oauth/signature/hmac/sha1'
-require 'oauth/rack/oauth_filter'
require 'oauth/request_proxy/rack_request'
require 'oauth/server'
require 'oauth/controllers/application_controller_methods'
+if Rails.version =~ /^3\./
+ require 'oauth/request_proxy/rack_request'
+else
+ require 'oauth/request_proxy/action_controller_request'
+ ActionController::Base.send :include, OAuth::Controllers::ApplicationControllerMethods
+end
module OAuth
@@ -15,4 +20,4 @@ class OAuthRailtie < Rails::Railtie
end
end
end
-end
+end
View
BIN  lib/oauth-plugin/.version.rb.swp
Binary file not shown
View
10 rails/init.rb
@@ -1,9 +1 @@
-require 'oauth'
-require 'oauth/signature/hmac/sha1'
-require 'oauth/rack/oauth_filter'
-require 'oauth/server'
-require 'oauth/controllers/application_controller_methods'
-if Rails.version =~ /^2\./
- require 'oauth/request_proxy/action_controller_request'
- ActionController::Base.send :include, OAuth::Controllers::ApplicationControllerMethods
-end
+require 'oauth-plugin'
Please sign in to comment.
Something went wrong with that request. Please try again.