Permalink
Browse files

Move rspec-rails integration code to webrat/integrations/rspec-rails

  • Loading branch information...
1 parent 2fc9f3f commit 723f4356b9a506ca6d3e546c6f667a6346e1770a @brynary brynary committed Aug 20, 2009
Showing with 12 additions and 10 deletions.
  1. +10 −0 lib/webrat/integrations/rspec-rails.rb
  2. +2 −10 lib/webrat/rspec-rails.rb
@@ -0,0 +1,10 @@
+# Supports using the matchers in controller, helper, and view specs if you're
+# using rspec-rails. Just add a require statement to spec/spec_helper.rb or env.rb:
+#
+# require 'webrat/rspec-rails'
+#
+require "webrat/core/matchers"
+
+Spec::Runner.configure do |config|
+ config.include(Webrat::Matchers, :type => [:controller, :helper, :view])
+end
@@ -1,10 +1,2 @@
-# Supports using the matchers in controller, helper, and view specs if you're
-# using rspec-rails. Just add a require statement to spec/spec_helper.rb or env.rb:
-#
-# require 'webrat/rspec-rails'
-#
-require "webrat/core/matchers"
-
-Spec::Runner.configure do |config|
- config.include(Webrat::Matchers, :type => [:controller, :helper, :view])
-end
+warn("Requiring 'webrat/rspec-rails' is deprecated. Please require 'webrat/integrations/rspec-rails' instead")
+require "webrat/integrations/rspec-rails"

0 comments on commit 723f435

Please sign in to comment.